Contribute
Register

[SUCCESS] Mojave install on i7 8700k and radeon rx 560

Status
Not open for further replies.
Joined
Jul 17, 2018
Messages
11
Motherboard
Asus z390 e gaming
CPU
i7 8700k
Graphics
Radeon VII
Successfully installed Mojave on my Hackintosh using the public beta utility. System specs are as follows:

intel core i7 8700k processor
msi z370 sli plus motherboard
16gb 2800mhz ram
Msi radeon rx 560 lp oc 4gb and Asus strix gtx 1070 (although this is turned off when using macos)
tp link wdn4800 wifi card

I'm using a triple monitor setup and all ports work on my rx 560. Also using latest lilu and whatever green kexts as well as AMD9xxxxControllerPatcher.kext. Mojave works great and I know its stable enough because I have been using it as my daily driver on my MacBook Pro. I did have to grab the IO80211Family-2.kext from high Sierra because Mojave broke my wifi cards functionality but after installing the kext it works fine. Also reason I have two gpus is because I was initially using my gtx 1070 with high Sierra and I was using the latest Nvidia web drivers and the web drivers are so badly optimized that there was noticeable lag throughout the ui. I picked up a rx 560 and it works almost natively and it's much smoother than my 1070. My gtx 1070 is still being used for gaming in windows though.
 

Attachments

  • Photo 2018-08-21 09.32.20 PM 2.png
    Photo 2018-08-21 09.32.20 PM 2.png
    18.7 MB · Views: 2,265
Joined
Jun 10, 2018
Messages
14
Motherboard
ASUS ROG Maximus X Hero Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Hey there. I'm also considering using AMD and Nvidia cards at the same time. I'm running a RX 580 perfectly. And I want to add a GTX 1080 when using windows. How did you disable the gtx 1070 when running macos?
 
Joined
Jul 17, 2018
Messages
11
Motherboard
Asus z390 e gaming
CPU
i7 8700k
Graphics
Radeon VII
Hey there. I'm also considering using AMD and Nvidia cards at the same time. I'm running a RX 580 perfectly. And I want to add a GTX 1080 when using windows. How did you disable the gtx 1070 when running macos?
Well technically I haven't disabled it completely in MacOS but what I did was I'm using an hdmi switch to switch the video output between the two cards. When I'm in macOS I switch the video to my Rx560 and it works perfect but while I boot to windows I switch it over to my 1070. In windows it's easy to disable a display adapter in settings but in macOS I have not figured it out how to disable it entirely meaning the 1070 is still powered on but it's not outputting any video signal because of my hdmi switch. I'm sure there's an option to disable it completely out there. I tried nvdisable_1 but that didn't seem to change anything.
 
Joined
Jun 10, 2018
Messages
14
Motherboard
ASUS ROG Maximus X Hero Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Well technically I haven't disabled it completely in MacOS but what I did was I'm using an hdmi switch to switch the video output between the two cards. When I'm in macOS I switch the video to my Rx560 and it works perfect but while I boot to windows I switch it over to my 1070. In windows it's easy to disable a display adapter in settings but in macOS I have not figured it out how to disable it entirely meaning the 1070 is still powered on but it's not outputting any video signal because of my hdmi switch. I'm sure there's an option to disable it completely out there. I tried nvdisable_1 but that didn't seem to change anything.
Thanks for the information!
 
Joined
Jul 4, 2018
Messages
1
Motherboard
Msi Z370 Sli Plus
CPU
i7 8700k
Graphics
GTX1080
Successfully installed Mojave on my Hackintosh using the public beta utility. System specs are as follows:

intel core i7 8700k processor
msi z370 sli plus motherboard
16gb 2800mhz ram
Msi radeon rx 560 lp oc 4gb and Asus strix gtx 1070 (although this is turned off when using macos)
tp link wdn4800 wifi card

I'm using a triple monitor setup and all ports work on my rx 560. Also using latest lilu and whatever green kexts as well as AMD9xxxxControllerPatcher.kext. Mojave works great and I know its stable enough because I have been using it as my daily driver on my MacBook Pro. I did have to grab the IO80211Family-2.kext from high Sierra because Mojave broke my wifi cards functionality but after installing the kext it works fine. Also reason I have two gpus is because I was initially using my gtx 1070 with high Sierra and I was using the latest Nvidia web drivers and the web drivers are so badly optimized that there was noticeable lag throughout the ui. I picked up a rx 560 and it works almost natively and it's much smoother than my 1070. My gtx 1070 is still being used for gaming in windows though.

can u give setting for your motherboard? and how do you setup clover?
 
Joined
Apr 12, 2018
Messages
43
Motherboard
Asus Z370-I ROG Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I second this. Would be helpful
 
Joined
Dec 2, 2018
Messages
3
Motherboard
370zpro
CPU
8700k
Graphics
1080gtx
did you have any driver issues im having trouble with all the drivers
 
Joined
Dec 23, 2018
Messages
2
Motherboard
msi b250m pro vd
CPU
i3 8100
Graphics
non
hey so can u send me ur config.plist for ur system?
 
Joined
Jan 24, 2018
Messages
3
Motherboard
A
CPU
I
Graphics
N
bump... I'd like to see your config.plist file as well.

I'm having an issue getting past:
"macOS could not be installed on your computer"
"An error occurred while updating system extension information."

Log states: "Install packages failed, Failure Reason: Error Domain=PKInstallErrorDomain Code=121"
 
Joined
Apr 12, 2018
Messages
43
Motherboard
Asus Z370-I ROG Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I can help y'all out but what is your system? Update in your bio.
 
Status
Not open for further replies.
Top