Contribute
Register

[Success] Mini-ITX build GIGABYTE Z390 I AORUS PRO WiFi + i9 9900K

Joined
Aug 31, 2019
Messages
10
Motherboard
Gigabyte Z390 I AORUS Pro Wifi
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
That's not true
Since it didn't work, I figured that the Windows boot would be that problem. (As in the post they talk about it.) My mistake. I already deleted the text referring to the boot in Windows.
 
Joined
Jul 29, 2020
Messages
19
Motherboard
Gigabyte Z390 I
CPU
Intel 9400
Graphics
HD 630
Mobile Phone
  1. iOS
I have some very newbish questions. Can someone help me out? I followed this guide to the letter because I have a very similar build. I was able to install Catalina (yay!), but I'm not clear on what the post-install steps mean. Currently, only the USB drive I used to install macOS contains the Clover folders in the EFI partition, so I'm not able to boot without it.
  • How do I get this hackintosh to boot into macOS without the bootloader on the USB drive?
  • Do I need to copy the EFI folders from my USB drive to the EFI partition of the internal SSD where macOS is installed?
  • There's a folder called "EFI Backups" on the main partition of my USB drive, created with Unibeast. Should I do anything with that?
^EDIT: I was able to copy the content from the USB boot disc EFI to the SSD's EFI. Solved that problem.
  • Post-Install
    Note: Since I copied the USB boot drive (created by UniBeast-9.0.0) EFI content to my SSD's EFI,
    I didn't use MultiBeast for the post install.
    1. Open Clover Configurator on your USB stick main Partition
    2. Mount EFI → SSD → Mount Partition
    3. Mount EFI → SSD → Open Partition
    4. Apply most Z390_Mini_ITX_EFI.zip kext from the top link into /Volumes/EFI/EFI/CLOVER/kexts/Other
    and /Volumes/EFI/EFI/CLOVER/kexts/10.14 accordingly.
    5. Install MultiBeast 3rd party USB patch if you want to use 3rd party USB hubs
    Are steps 1-4 instead of using MultiBeast?
  • Did you need to disable any USB ports/headers to fit the limit?
  • What is the most stable way to get WiFi/Bluetooth on this build?
^EDIT: mapped out usb I needed
 
Last edited:
Joined
Jul 29, 2020
Messages
19
Motherboard
Gigabyte Z390 I
CPU
Intel 9400
Graphics
HD 630
Mobile Phone
  1. iOS
I’m using integrated graphics on Gigabyte Z390I Aorus wifi and i5-9400. Both HDMI and DisplayPort are working, BUT I’m seeing some glitchy graphics, particularly Safari tabs in dark mode. Blurring, pixelation, trailing ... has anyone experienced this and fixed it?
 
Joined
Aug 4, 2019
Messages
4
Motherboard
Gigabyte Z370n Wifi
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
I am running a similar build in an SM560 (Sliger) and was unable to boot for the longest time. I had 5 quick beeps if the GPU was plugged in and the BIOS would change from the Aorus logo to an American Trends text-only version. With the GPU disconnected, I would boot without issues.

I bought the PCI bifurcation option and it appears that I must enable PCI bifurcation (8x/8x) in order to actually boot. Just FYI in case anyone may be running into the same issue.
 
Joined
Sep 8, 2020
Messages
1
Motherboard
Z390 PRO WIFI ITX
CPU
i5 9600k
Graphics
HP RX580 Short
Hello,

I have a running Z390 Pro Wifi ITX system running with Catalina 10.15.6. Everything worked nice. Only the USB Port have not the full speed. Have everyone here a USB Mapping for this board or do you know how can I fix it properly?

Thanks for your help
 
Joined
Sep 7, 2019
Messages
4
Motherboard
Gigabyte Z390 I AORUS PRO (WiFi)
CPU
i5-9500
Graphics
UHD 630, GTX 1660S
Mobile Phone
  1. Android
Has anyone been able to install Catalina? If Yes, you can upload the working config of the EFI folder here, thank you in advance.
 
Joined
Sep 7, 2019
Messages
4
Motherboard
Gigabyte Z390 I AORUS PRO (WiFi)
CPU
i5-9500
Graphics
UHD 630, GTX 1660S
Mobile Phone
  1. Android
I was able, here is my EFI folder running Catalina without any issues. (don't forget to change Serial, UUID and ROM)
what version of the BIOS do you use?
 
Joined
Dec 24, 2012
Messages
16
Motherboard
Gigabyte Z390 I Aorus Pro WIFI
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. SE
Mobile Phone
  1. iOS
Currently using latest, but I tested this EFI with default BIOS, If I remember good it was F6 or F7
Can please somebody this the board "Gigabyte Z390 I Aorus Pro WIFI" give the BIOS settings for version F8H working with Catalina 10.15.7?

Is there somebody using the onboard PCI M.2 with SSD for OSX boot?
 
Top