Contribute
Register

[SUCCESS] macOS Mojave 14.1 on GA-Z77X-UP5TH+Intel i7-3770S (IntelHD 4000)

Joined
Jul 25, 2012
Messages
6,899
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I have been running macOS High Sierra , Windows 10 and Ubuntu from 3 different SATA Spin disks on this system (listed in my profile) using ATI Radeon 5450. But when Mojave was released and it had no support for Radeon 5450, I removed the PCIE Graphics and decided to try the Integrated Intel HD 4000 associated with my CPU i7 3770S. Surprisingly in Mojave Intel HD 4000 is NATIVELY SUPPORTED; No Fake ID in config.plist _Devices , No [√]IntelInjector and No ig-platform-id in config.plist_Graphics.

  • For the installation I disconnected my other system disks and connected a SATA Segate ST 3500312CS 500GB Disk .
  • USB installer was created on a 16GB Kootion USB 2.0 using CreateInstallMedia Command and RehabMan's CLOVER Clover_v2.4k_r4701.RM-4963.ca6cca7c.zip manually installed on the created Mojave 14.1 UEFI USB Installer.
Sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia

  • CLOVER File tree and contents of CLOVER folders and config.plist are uploaded as images viewed from Clover Configurator Vibrant. [See images]
  • Booted the computer with the Mojave USB installer and at Gigabyte Splash screen , pressing Del key opened BIOS Setup screen.
  • Made the BIOS Screen options for the Installation and took Screen captures using F-12 and Saved on the EFI Partition of the USB installer.
    • BMP images converted to JPG are uploaded. (11 Images)
  • After booting the UEFI Mojave USB installer as First boot device from BIOS, pressed F12 and selected UEFI USB Installer to enter Clover Boot Manager (CBM) Screen. The Old High Sierra UEFI System Disk icon was seen along with the new UEFI USB Installer.. (See image 1)
  • CBM Options Boot Args and sub menu screens were checked to make sure everything is OK as per the config.plist of CLOVER (See images)
  • UEFI USB Installer was booted in Verbose mode and screen shots were made.
  • Target ST 3500312CS SATA disk was Formatted and Installation started and competed ( See images)
  • After reboot License Agreement, Apple Account Creation, iCloud Account, Desktop Setup were created and Desktop opened. (see images from Desktop )
  • The EFI Partition of USB Installer was mounted and its EFI folder was copied.
  • EFI Partition of System ST 3500312CS was mounted and its EFI Folder was deleted.
  • Copied EFI from USB installer was pasted on System Hard disk's EFI partition.
  • SATA System Disk's EFI >CLOVER and subfolders were checked for all required kexts and properly edited config.plist.
  • System Disk was booted and logged back in.
  • Apple About This Mac_Overview and System Report menus were checked to make sure everything is set properly.
    • Images uploaded
  • Everything is working OK with the above installation routine with Intel HD 4000 Graphics, Intel LAN, Realtek ALC 892 Audio and TPLink WDN 4800 PCIE WiFi.
 

Attachments

Last edited:
Joined
Dec 30, 2013
Messages
83
Motherboard
Dell 9570
CPU
i7-8750H
Graphics
HD 630
Hello

Thank you for the great guide. Very visual and accessible for someone like me. I just had a question to understand well how you made your sound work.

Can you tell me when you comfigurated Clover Configurator. Even though there are explicit numbers I don't understand well what you did first.

Here my guess of the order

1. Bios Confuration.
2. Install pictures of Mojave
3. Clover Configurator
4. pictures about verification inside Mac OS.

Is that right ?

Could you tell me which of your pictures I should take in consideration to concentrate only on working Audio? I have the exact same mother board and also the Intel i7 3770K processor.

Then I also have the TP 4800 for wifi and I don t understand which page in clover configurator I have to set up.

For graphics I ordered a Saphire Nitro + Vega 64. I have no idea until now if it will even work on Windows 10 with this motherboard.

Please let me know.


Best regards
 
Joined
Feb 4, 2018
Messages
2
Motherboard
HP Elitebook 820G1
CPU
i5-4210U
Graphics
HD 4400
I will try to inspire you with your tutorial for an elitebook 820 G1 I5 4210u intel 4000 HD
 
Joined
Jul 25, 2012
Messages
6,899
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hello

Thank you for the great guide. Very visual and accessible for someone like me. I just had a question to understand well how you made your sound work.

Can you tell me when you comfigurated Clover Configurator. Even though there are explicit numbers I don't understand well what you did first.

Here my guess of the order

1. Bios Confuration.
2. Install pictures of Mojave
3. Clover Configurator
4. pictures about verification inside Mac OS.

Is that right ?

Could you tell me which of your pictures I should take in consideration to concentrate only on working Audio? I have the exact same mother board and also the Intel i7 3770K processor.

Then I also have the TP 4800 for wifi and I don t understand which page in clover configurator I have to set up.

For graphics I ordered a Saphire Nitro + Vega 64. I have no idea until now if it will even work on Windows 10 with this motherboard.

Please let me know.


Best regards
Can you tell me when you comfigurated Clover Configurator. Even though there are explicit numbers I don't understand well what you did first.
The order I had uploaded images are:

  1. EFI_CLOVER File structure with Folders showing essential EFI and kexts for flaw less booting and eventually using the EFI to copy and paste on to System Hard disk's EFI Partition as its own EFI.
  2. config.plist views from CCG displaying ACPI to System Parmeters Sections and essential for a proper booting and Themes editor to show that if you have installed the theme folder of your choice in /EFI/CLOVER/themes folder you can use config.plist_Themes Editor to upload that (YosemiteLogin in my case) and Save to show the looks of your Clover Boot Manager icons the way you want them to be shown. For that you also need to select that theme in config.plist_Gui as Theme [YosemiteLogin]in my case
  3. BIOS options chosen for this Board to boot OS X -macOS . Initially First boot device is the UEFI USB installer and all other devices if any are DISABLED in Boot Option Priorities list. After install and USB Installer EJECTED, go back to BIOS and make CLOVER containing macOS Disk as first boot device and all other connected OS disks are Disabled in that list. CLOVER will bring them all to CBM screen for you to choose whichever OS you want to boot.
  4. Clover Boot Manager Screen and all its Sub-menu which are essentially the config.plist SECTIONS from ACPI to System Parameters. Since the 3 most important things I want to have during Installation are Booting in Verbose Mode, Using the correct USB Injector options and the Right Graphics Injector options, I make sure to check Boot Args, PCI Devices and Graphics Injector from CBM screen. In fact checking all Sections would be a very good idea. I have listed all of those images.
  5. Verbose boot screens to see certain important visual clues I have about a flawless boot. I take pictures of them and if possible many more until the USB installer reaches Disk Utility and performs the Partition and Format of Target HDD and start the installation.
  6. Since the installation can take 2-3 reboots of varying lengths I continue to watch and guide the UEFI installer to enter the CBM screen and use the Partly installed System HDD to exit the CBM screen until full installation and the System HDD gets its own working CLOVER EFI.
  7. Once the System is successfully booted and logged into Desktop, I check and correct the TIME and Time zone, get the System Preferences Security setup to allow me to download non-mac software.
    • For this I run "sudo spctl command" through the terminal.
  8. Next I check the System Report to make sure all kexts are properly installed.
  • It is like the Device Manager in Windows.
  1. After that I check System Preferences: Network, Sound, etc and then launch the Safari Bowser to test everything.
Could you tell me which of your pictures I should take in consideration to concentrate only on working Audio? I have the exact same mother board and also the Intel i7 3770K processor.
  • Concentrate on CLOVER/kexts/Other to make sure you have the latest Lilu.kext and AppleALC.kext ( Toleda's Emphasis)
  • Concentrate on finding what Audio Chip you have on your MoBo from MoBo GUIDE or SPECS (mine Realtek ALC 892)
  • Confirm if needed by downloading and launching DPCIManager( see image)
  • config.plist >Devices>Audio (I am uploading that again):
    • This is where you select the layout ID for Audio Injection through CLOVER .
    • You can find out the Status of your Motherboard's, Audio device through DPCIManager [see uploaded image]
    • From Toleda's Audio GUIDE , we can find out that the Realtek ALC 892 can have a few Layout ID numbers we can choose from.
    • 2 is one of several you can pick from the list.
    • I just picked 2 .
    • I have used 7 in another System with the same Realtek ALC 892.
  • You can check System Report >Audio and you will see a full page of various items listed if Audio is going to work
  • Finally test Audio , through System Preferences>Sound and its various tabs Input/Output/Sound Effects including Sample Sounds to be heard through your Speakers or Headphones [See images]
Then I also have the TP 4800 for wifi and I don t understand which page in clover configurator I have to set up.
You need to install AirportAthros40.kext using Kextbeast or Kext Utility at Post-install stage (I'm uploading that kext as zipped) If you do an upgrade install of Mojave from High Sierra you may not need to install Atheros.kext


So far TPLink WDN 4800 WiFi has been working OK in all my systems with the above 'trick'.

According to RehabMan, this is not a safe strategy as Atheros Wifi Chip is not Apple's Favorite and we might lose the current capability with our TPLink PCIE card (with Atheros Chip) with future releases of macOSes.

I am considering getting Wifi cards with Broadcom Chip with Apple Support as suggested by RehabMan. Price of a mini PCIE card and the proper PCIE adapter card with perfectly mating Pigtail Antennae cables are the current problems I see in switching to that hardware.

Hope the information provided will help you in your installation.
 

Attachments

Last edited:
Joined
Feb 28, 2011
Messages
17
Motherboard
Gigabyte Z390 Designare
CPU
i9
Graphics
RX 580
Mobile Phone
Android
Thanx, this worked very well for my old GA-Z77X-UD5H as well. Sound set-up is little different. Bios 16j makes it possible it boot to a NVMe disk. Incredible speed for this old board
 
Last edited:
Joined
Aug 1, 2020
Messages
1
Motherboard
Gigabyte Z77x-UD5H
CPU
3770k
Graphics
Intel HD Graphics 4000 1536 MB
Mac
MacBook Pro
Classic Mac
iBook
Mobile Phone
iOS
Thanks so much for your brilliant guide!! I've got my Z77X-UD5H booting, with all the trimmings (wifi, ethernet,bluetooth,audio,nvidia760) Only quirk seems to be the About this Mac > Graphics = Intel HD Graphics 4000 7MB (when it should be Intel HD Graphics 4000 1536 MB). Again, thanks a bunch. I installed the wifi,ethernet ktext files to /System/Library/Extensions with ktext wizard, after the second reboot from installation, I could then set up the ethernet via the Network System Preference, but had to go to /Applications/Utilities and launch the Airport Utility.app so as to see the wifi in the left hand side of the Networking System Preference pane.
 
Top