Contribute
Register

[Success] Lenovo M93p, M73p "Tiny" mini PC i5 4570t, i7 4765t Yosemite-Catalina

Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
hi @trs96

updated signature with all macs

thanks.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,581
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
hi @trs96

updated signature with all macs

thanks.
The EFI in the guide works in Catalina, however, it has not been updated to the newest clover.
I have not updated past Catalina 10.15.5 on my machine but nobody has mentioned it not working in the latest version.
 
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
L'EFI nella guida funziona in Catalina, tuttavia, non è stato aggiornato al nuovo trifoglio.
Non ho aggiornato Catalina 10.15.5 sulla mia macchina ma nessuno ha detto che non funziona nell'ultima versio
If it helps, I updated to 10.15.7 and that's okay.
 

Attachments

  • Schermata 2021-04-30 alle 08.39.17.png
    Schermata 2021-04-30 alle 08.39.17.png
    92.1 KB · Views: 62
Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
hi @Gigamaxx , @mamomamo

so i could start the Catalina installation without any problems, is the 10.15.4 installer

Thanks.
 
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
hi @Gigamaxx , @mamomamo

so i could start the Catalina installation without any problems, is the 10.15.4 installer

Thanks.
I don't know if I understood correctly I'm on google translator, I updated from catalina to catalina, I don't remember what installer number I had, as soon as the installation was finished there were updates and I made them, everything went well and now I'm at 10.15.7
 
Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
Hi @Gigamaxx,

the installation worked partially, but the Catalina installation folders remain active on the boot menu due to the error:

"The bless tool was unable to set the current boot disk"

I tried to see the guide on the forum in the guides section and in the Catalina installation support, but I don't solve the problem as the .IA folders / files ?? do not exist and even deleting the contents of the "Data" partition on boot I keep seeing all the sections of "filevault, preloader, data, etc ..."

leaving aside the error; I tried to make all the updates; but these don't work, I tried multiple times as I did in the past but when I manually boot from Mac HD; on the updates menu in system preferences, it tells me to restart the mac to install them, as if the previous installation didn't work

normally after the updates from clover I hid "Preloader, Data" at boot menu so that it would automatically start Mac but now it doesn't work

how can i solve?

Thank you.
 
Joined
Feb 14, 2020
Messages
16
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
Hello,

I solved it, after several tests I was able to install the updates; the only problem was that for some reason the order of the boot menu was changed, first I had boot for mac as first and recovery second; so to prevent recovery from starting I had to hide the "recovery" in clover as well as "preboot and data".

a very inconvenient thing since in case of problems I could not start the recovery.

otherwise everything seems to work.

Thank you.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,581
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Hello,

I solved it, after several tests I was able to install the updates; the only problem was that for some reason the order of the boot menu was changed, first I had boot for mac as first and recovery second; so to prevent recovery from starting I had to hide the "recovery" in clover as well as "preboot and data".

a very inconvenient thing since in case of problems I could not start the recovery.

otherwise everything seems to work.

Thank you.
This is why we always recommend a backup USB installer stick. Even a stick with only the Clover folder on the EFI partition.
 
Joined
Jan 9, 2019
Messages
94
Motherboard
Lenovo M83 SFF
CPU
i5-4570
Graphics
HD4600
I just picked up a M93P with a I5-4570T

I used my existing Catalina install USB stick from another Lenovo Desktop replacing the EFI folder with the one in this thread. I can boot to clover and start the install, the Apple logo appears but every time the progress bar reaches half way it re boots and does the same thing over and over.

I checked the BIOS and it had been updated to a version from Dec 2021. Could this be the issue?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,191
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I can boot to clover and start the install, the Apple logo appears but every time the progress bar reaches half way it re boots and does the same thing over and over.
Boot Verbose then read the info that presents. Gives you a clue as to why it hangs there.
 
Top