Contribute
Register

[Success] Lenovo M93p, M73p "Tiny" mini PC i5 4570t, i7 4765t Yosemite-Catalina

Joined
Aug 6, 2018
Messages
27
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Got it up and running without too many issues but I have a few questions.
1. I don't have the NVRAM plist, did I miss a step? I didn't have this in my other mackintoshes EFI folders.
2. Maybe related to my first question, but after waking from sleep the computer works for around 20 seconds and then restarts? I'm not sure what would be causing this, as everything else seems to work. If you have any ideas that would be great! Thank you for the guide!
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,581
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Got it up and running without too many issues but I have a few questions.
1. I don't have the NVRAM plist, did I miss a step? I didn't have this in my other mackintoshes EFI folders.
2. Maybe related to my first question, but after waking from sleep the computer works for around 20 seconds and then restarts? I'm not sure what would be causing this, as everything else seems to work. If you have any ideas that would be great! Thank you for the guide!
Do you have the i5 4570t, i7 4765t or other CPU? if its not one of these then remove the SSDT.aml form Clover/ACPI/Patched folder.
 
Joined
Aug 6, 2018
Messages
27
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Do you have the i5 4570t, i7 4765t or other CPU? if its not one of these then remove the SSDT.aml form Clover/ACPI/Patched folder.
I have the i5-4570t, I got the SSDT.aml from the M93P tools folder.
 
Joined
May 26, 2020
Messages
13
Motherboard
Lenovo
CPU
i5 4750t
Graphics
Intel 4600
Hello all, I am new and have my m93p running opencore with Catalina almost perfect. There are only 3 problems:

1. Most important to me is I have a USB bluetooth adapter that needs to be in usb 2.0 mode but I cannot seem to figure out how to do that.

2. ATV wont play video streaming but if I download a full file it works. May be related to USB also since my wireless is USB.

3. I cannot use airplay to route music to my apple tv while on USB wireless but I can with ethernet.

Other than these 3 items everything is perfect including sleep, video, displayport sound. I am really happy with the build if I can get at least #1 solved so I can use my bluetooth input devices. Can anyone help? I assume its my DSDT but not sure how to resolve it.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,581
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Hello all, I am new and have my m93p running opencore with Catalina almost perfect. There are only 3 problems:

1. Most important to me is I have a USB bluetooth adapter that needs to be in usb 2.0 mode but I cannot seem to figure out how to do that.

2. ATV wont play video streaming but if I download a full file it works. May be related to USB also since my wireless is USB.

3. I cannot use airplay to route music to my apple tv while on USB wireless but I can with ethernet.

Other than these 3 items everything is perfect including sleep, video, displayport sound. I am really happy with the build if I can get at least #1 solved so I can use my bluetooth input devices. Can anyone help? I assume its my DSDT but not sure how to resolve it.
Take the USB ports kext from the EFI folder on page one and put it in OC Kexts folder, open up your config plist with ProperTree and go to top tool bar File/OC Snapshot. That should place the Kernel/Add folder that you need.
 
Joined
May 26, 2020
Messages
13
Motherboard
Lenovo
CPU
i5 4750t
Graphics
Intel 4600
Take the USB ports kext from the EFI folder on page one and put it in OC Kexts folder, open up your config plist with ProperTree and go to top tool bar File/OC Snapshot. That should place the Kernel/Add folder that you need.

Gave it a go and still performs the same. I need to figure out how to designate a port to be forced as usb 2.0 only.

edit: I just swapped the ACPI with the ones on page 1 and I'm fixed. Thanks!!!!!
 
Last edited:
Joined
May 26, 2020
Messages
13
Motherboard
Lenovo
CPU
i5 4750t
Graphics
Intel 4600
Jumped the gun, while USB 2.0 now shows in my system profile, I need to figure out how to still designate a port so that my BCM20702A0 falls under 2.0
 

Attachments

  • Screen Shot 2020-06-03 at 9.12.16 AM.png
    Screen Shot 2020-06-03 at 9.12.16 AM.png
    105.8 KB · Views: 50

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,581
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Jumped the gun, while USB 2.0 now shows in my system profile, I need to figure out how to still designate a port so that my BCM20702A0 falls under 2.0
Is it in a 2.0 port or is it the WiFi card? MacOS routes Bluetooth through internal USB in most cases.
 
Joined
May 26, 2020
Messages
13
Motherboard
Lenovo
CPU
i5 4750t
Graphics
Intel 4600
Is it in a 2.0 port or is it the WiFi card? MacOS routes Bluetooth through internal USB in most cases.

Its an IOGEAR Bluetooth USB Micro Adapter, GBU521 which works some times and read the fix is to have on a usb 2.0 only port.
 
Top