Contribute
Register

[SUCCESS] jbarnette's Build - ASUS TUF Z390 M Gaming + i9-9900K + Sapphire RX Vega 64 8GB + 32GB RAM + MacOS 10.14.3 w/ USB3 working!

Joined
Jul 17, 2011
Messages
21
Motherboard
Gigabyte Z390 M Gaming
CPU
i3-8100
Graphics
UHD 630 + RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi everyone,
djkinetic, I have a build the same as yours, and I would like to install Mojave.
Can you please post your EFI folder?

thank you very much for your consideration
Just use OsxAptioFix2Drv-free2000.efi instead of AptioMemoryFix-64.efi.

Attached is my EFI, it does contain the OsxAptioFix2Drv-free2000.efi, I used that instead of AptioMemoryFix-64.efi during my install, like I said previously I needed to make changes in the config along with adding OsxAptio and EMU64 to get the nvram strings to populate in order to get iMessage to work, its not installed by default. Attached is my EFI folder, it has the USB DSDT, the only thing I haven't played around with fixing is the usb 3.0 ports at the top of the boards back panel, I think it has something to do with the buffer value in the DSDT and finding the correct port # ie if its port 1 the port underneath that entry would be port 11. other than that minor issue this build is golden and working, there is a known issue with Netflix and safari, to my knowledge no one has solved it, I have Lulu and whatever green installed so I know that's not the issue.
 

Attachments

  • EFI.zip
    21.9 MB · Views: 275
Joined
Jul 17, 2011
Messages
21
Motherboard
Gigabyte Z390 M Gaming
CPU
i3-8100
Graphics
UHD 630 + RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I would like to work with you and figure all of those out and update this thread. I have another SSD coming tomorrow. I will clone my setup and then use the new ssd to make changes. I can't have my production machine go down.

that OsxAptio driver seems to be the key to shutdown and sleep working. only thing to work on is those 2 USB ports. I will continue experimenting when I have some time later in the wk.
 
Joined
Mar 31, 2019
Messages
2
Motherboard
gigabyte z390m gaming
CPU
i9 9900k
Graphics
amd rx580
Attached is my EFI, it does contain the OsxAptioFix2Drv-free2000.efi, I used that instead of AptioMemoryFix-64.efi during my install, like I said previously I needed to make changes in the config along with adding OsxAptio and EMU64 to get the nvram strings to populate in order to get iMessage to work, its not installed by default. Attached is my EFI folder, it has the USB DSDT, the only thing I haven't played around with fixing is the usb 3.0 ports at the top of the boards back panel, I think it has something to do with the buffer value in the DSDT and finding the correct port # ie if its port 1 the port underneath that entry would be port 11. other than that minor issue this build is golden and working, there is a known issue with Netflix and safari, to my knowledge no one has solved it, I have Lulu and whatever green installed so I know that's not the issue.

thank you so much
 
Joined
Mar 1, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Good @jbarnette

I was just prepping my files, and getting ready for my equipment to come in. I just want to know if based on your USB layout, if I got the back right? If it is, please feel free to use it if you'd like, if not let me know what I need to fix.

398770
 
Joined
Apr 10, 2016
Messages
12
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-8600K
Graphics
RX 580
Mobile Phone
  1. iOS
For those who lost on-board audio after 10.4.4 update. I managed to get it back to work just by installing the codecs again from MultiBeast tool, reboot and everything back to normal.
 
Joined
Mar 1, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@TxarLs, thanks for the info, I'm still waiting on my case to come in before I start this build. I did have a question for you, I labeled everything in the post above according to the USB info from jbarnette. I'm a visual guy, so could you eyeball what I have done, and let me know if that looks right? I'm just trying to get all my notes in order before I start building...
 
Joined
Apr 10, 2016
Messages
12
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-8600K
Graphics
RX 580
Mobile Phone
  1. iOS
@TxarLs, thanks for the info, I'm still waiting on my case to come in before I start this build. I did have a question for you, I labeled everything in the post above according to the USB info from jbarnette. I'm a visual guy, so could you eyeball what I have done, and let me know if that looks right? I'm just trying to get all my notes in order before I start building...

Regarding the USB labels on your previous post I have no clue. All what I did was copy the SSDT_USB.aml to the specific folder and I got my USB 3.0 working. I really don't care about the top USBs as those are my mouse and keyboard and they work equally on USB 2.0 and USB 3.0 speeds, no difference for mice and keyboards. The rest USBs are working on 3.0 speeds.
 
Joined
Mar 1, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Does anyone have any issues with wake from sleep? All I have connected is my keyboard, I'm using a Magic Mouse, and there is the PCI-e card attached to the onboard USB2 header for WiFi and Bluetooth. I am able to put the computer to sleep, via the menu, but, left it on overnight, and it won't wake up from sleep.
 
Top