Contribute
Register

[SUCCESS] jbarnette's Build - ASUS TUF Z390 M Gaming + i9-9900K + Sapphire RX Vega 64 8GB + 32GB RAM + MacOS 10.14.3 w/ USB3 working!

Joined
Sep 11, 2012
Messages
21
Motherboard
Gigabyte Z390M Gaming
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Mobile Phone
  1. iOS
What does Slide=0 do?

Seems to work, no boot premission errors (Finkers crossed)
But Shutdown is stil a pain in the ass, does DARKWAKE van somethinhg to do with it! Thanx for the help!
 
Joined
Sep 11, 2012
Messages
21
Motherboard
Gigabyte Z390M Gaming
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Mobile Phone
  1. iOS
Nope, I did try to make a Windows boot drive on separate SSD, but it messed up the system again, “no permission” sign keeps coming back, can't enter with USB or boot M.2. Is this a hardware or software issue?
Seems to be very unstable. Previous builds I made were more robust.
 
Joined
Sep 11, 2012
Messages
21
Motherboard
Gigabyte Z390M Gaming
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Mobile Phone
  1. iOS
Could this be happening because I only have 2 RAM slots in USD and not all 4? Is it the only difference with your system? @jbarnette
 
Joined
Nov 24, 2018
Messages
282
Motherboard
ASUS TUF Z390M-PRO GAMING (WI-FI)
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Could this be happening because I only have 2 RAM slots in USD and not all 4? Is it the only difference with your system? @jbarnette
IDK man I mean I would be happy to find a way to share anything I can to help ya out.


I'm not sure exactly what problem you are having.
Are you able to install OSX and get it running?
or
Are you getting and error during the install of OSX?
or
Is it windows install related?

That last one you need to amen sure that you take every drive out of the system except the one that you are installing windows on out of the system until you have windows up and running and updated. then you can add the OSX drives back in and if you want to boot directly to windows you need to use the F12 boot menu.
 
Joined
Sep 11, 2012
Messages
21
Motherboard
Gigabyte Z390M Gaming
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Mobile Phone
  1. iOS
@jbarnette

Yes, installation is all good,. Its just after a couple of boots and some adjustments (nothing crazy, butt still).
I have a new plan, I'll use the OsxAptioFix2Drv-free2000.efi instead of the memory.
Having better experience already. Shutdown also works. (Not sleep, though.)

hope this is going strong
 
Joined
Mar 12, 2018
Messages
9
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Just completed my very similar build and had some help from this thread. Thanks all! I've got everything working except sleep. It goes to sleep. But, when I try to wake it up, the display never turns on. The HDD activity light start blinking. So I suspect that the system is running but can't wake the GPU back up?
 
Joined
Mar 12, 2018
Messages
9
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Well I spent a couple of hours figuring out how to enable the iGPU for hardware accelerated video encoding, and now suddenly my sleep/wake is working too! Not sure wether it's related, I've been tweaking lots of stuff, but for anyone else who wants to try I highly recommend this guide:

I tried overclocking to 5ghz but the system is not stable and shuts down when running Cinebench so I'm back to stock settings. Anyone else here running overclocked on this setup?
 
Joined
Mar 12, 2018
Messages
9
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Aaaand I couldn't stop myself from updating to 10.14.4 which broke sleep again for me... also broke the integrated audio that I had working before. Can live without both for now, please tell me if you had a similar experience upgrading and if you managed to solve it.

Got the latest kexts for AppleALC, WhateverGreen and Lilu but didn't help.
 
Joined
Aug 26, 2018
Messages
7
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-8700
Graphics
VEGA 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Aaaand I couldn't stop myself from updating to 10.14.4 which broke sleep again for me... also broke the integrated audio that I had working before. Can live without both for now, please tell me if you had a similar experience upgrading and if you managed to solve it.

Got the latest kexts for AppleALC, WhateverGreen and Lilu but didn't help.
The sleep is still working for me, but the audio is broken after upgrade to 10.14.4.
 
Top