Contribute
Register

Success Installation TOSHIBA L745 families

Status
Not open for further replies.
Joined
Jul 2, 2011
Messages
2
Mac
Classic Mac
Mobile Phone
My Current Spec

Sandy Bridge Notebook Platform Intel HM65 Chipset
Booting Single Core @ 2.3 Ghz Intel Core i5 Cache 3MB (cpus=1 busratio=23)
VGA NVIDIA GeFORCE GT 525 1 GB detected as 512 MB (idk, GeFORCE 5 isn't supported natively, fail :D)

Memory 4GB @ 1333 Mhz PC-Timing CL 9-9-9-24 instead of Mac-Timing (CL7)
HDD 500 GB 3 partition (recovery, Windows 7, MAC OSX)
Installed on MBR using OSInstall.mpkg patch
Conexant Sound Card FAIL to Install with Vodoo 0.2.71 (OSX fix included)



Steps

Boot Snow-Leopard Installation DVD 10.6.3 with
busratio =23 (must)
cpus = 1 (conditional)
GraphicsEnabler = No (conditional)
PCIRootUID = 1 (conditional)
-v -x
at mine:
cpus=1 busratio=23 PCIRootUID=1 -v -x

When booted wait for Apple Splash Screen..
Install MAC OSX in MBR or GPT as you want

once finished,
reboot using iBoot CD (I'm not using legacy one at that time)

just Install Bridge-Helper(if you want to update 10.6.7) or
Backup AppleACPIPlatform.kext , IOPCIFamily.kext , or download it wherever (for you who wanna update to 10.6.8, cause you need to rollback some kexts after update)

for 10.6.8 you need to do this thing:
Remove the ACPI_SMC_PlatformPlugin.kext from the System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/Plugins/

Install the Update

Install Multibeast as you want
1. Easybeast (if you want it easily)
2. System Utilities (must)
3. Audio Driver (ALC8xx) or just Vodoo(Universal)
4. OSX86 Software (useful tools)
5. Boot Options fix if you want one (but i recommended to put boot flag by your own later, just put boot flag to com.plist, search it)

INSTALLING... done

reboot with your previous boot flag without "-x" or safemode
pmVersion=23 (Oftenly needed, honestly idk what this word means) or you can get some KP

at mine to avoid KP use this:
cpus=1 busratio=23 PCIRootUID=1 pmVersion=23 -v

sometimes you can use just
busratio=23 -v or whatever I found different thing different flags lol :headbang:

Once rebooted, Update Video Card if you are using NVIDIA
then.. MACOSX Retail already to eat :D
 
Joined
Jul 17, 2011
Messages
8
Motherboard
GA-Z77P-D3 (rev. 1.1)
CPU
Core i7 3770
Graphics
Gigabyte NVIDIA GeForce GT 640
Mac
Classic Mac
Mobile Phone
  1. iOS
  2. Other
Hi Mayharlin

I also have Toshiba L745. Almost every specification of the computer is the same as yours except that it has no GT525m as a Graphics card.

I putted command Busratio=23 only to install Snow Leopard. I followed instruction on this page. http://tonymacx86.blogspot.com/2010/04/ ... -x-on.html . Actually, it made no different either I putted Busratio=23 or not.
The first strange thing was I never saw "Mac OS X Snow Leopard Welcome Video".

When I got to About this Mac. It showed as 10.6.3. When I clicked at Info to see details. Only Sound, Graphics QE/CI and Wifi did not work.

So I Installed MacOSXUpdCombo10.6.7.pkg and Ran Mulitibeast. Actually, I did not know which is the right way to Choose. So, I chose EasyBeast Install, System Utilities, some drivers which I had no ideas which were rights for my Toshiba L745, and Bootloaders. Then, I installed Bridge-Helper and Then Boot again. I also tried to remove

After I Rebooted - from your new Snow Leopard installation drive. Then, mouse and keyboard did not work. The cursor of mouse could be moved, but the clicked could not be performed. Also, Ethernet did not work as well. It seemed that I could get into Snow Leopard screen but I could not do anything else.

Could you please tell what exact tick to choose in MultiBeast in order to install successfully.?
 
Joined
Jul 25, 2011
Messages
1
Motherboard
Win 8
CPU
Intel Core I5 2430
Graphics
Intel hd 3000
Mac
Classic Mac
Mobile Phone
HI mayharlin:

I have a laptop with almost the same specifications like yours.the diference is my grafic card is nVidia GT520m 1GB ram. When i first tried to install SL i received a screen with RESTART YOUR COMPUTER blablabla. So in next try when selecting to run the dvd installer i wrote CPIRootUID=1 and instalation was ok.

In SL the first thing i tried to do is upgrade from 10.6 to 10.6.8 and when instalation almost finished i recieved again the screen with RESTART YOUR COMPUTER HOLDING THE POWER BOTTON blablabla. Then i couldn´t boot again SL.

Is there anything that has to be done before upgrading?

TIA for any recommendation, i´m a beginner.
Any tutorial to learn how and where to put busratio=23
 
Joined
Dec 15, 2011
Messages
2
Motherboard
wth
CPU
dual core e5700
Graphics
hd 4850
Mac
Classic Mac
Mobile Phone
ive got toshiba l745-1050x. GT 525M, i3-2310, 2gb. ive got a mac os x lion 10.7. i tried using this method.

but i dont understand this part

just Install Bridge-Helper(if you want to update 10.6.7) or
Backup AppleACPIPlatform.kext , IOPCIFamily.kext , or download it wherever (for you who wanna update to 10.6.8, cause you need to rollback some kexts after update)

for 10.6.8 you need to do this thing:
Remove the ACPI_SMC_PlatformPlugin.kext from the System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/Plugins/

and everytime after i install multibeast, and i restart, the problem is always the same. kernel panic. and i dont know what to do to get back to mac os x other than reinstall the OS. for the last 4 days, i've reinstalled MAC OS X lion 10 times. 0,0

:crazy: :crazy: :crazy: :crazy: :crazy: :crazy: :crazy: :crazy:
 
Status
Not open for further replies.
Top