Contribute
Register

[SUCCESS] i7-5820k / GTX 970 / GA-X99-UD4 Sierra 10.12 [Clover Guide] (100% Working)

Joined
Sep 18, 2011
Messages
499
Motherboard
Gigabyte GA-X99-UD4
CPU
Intel Core I7 5820K
Graphics
EVGA Nvidia Geforce GTX 1080 Ti SC2
Mac
Mac Pro
Classic Mac
Lisa
Mobile Phone
Android
16464190_1048406201937653_5156976475076820992_n.jpg
20170826_190127.jpg

Here is a full install guide using Unibeast / Clover to install Mac OS Sierra 10.12 on your custom built Haswell E X99 Computer! I made this guide from using instructions gathered from the TonyMac forums. 10.12 appears to be the most solid version of MacOs for x99!

What's working:
Everything!!!! 100% on 10.12.6!!!!

* Update * 9/1/2017 Final update for guide

The build:
GIGABYTE GA-X99-UD4 (Motherboard)
Intel Core i7 5820k Haswell E Processor (Cpu)
32GB Corsair Vengence DDR4 2400 RAM (Memory)
EVGA GTX 1080 Ti SC2 11GB (Graphics Card)
Sandisk Extreme ii 120GB SSD (El Capitan drive)
Samsung 840 Evo 120GB SSD (Windows Drive for dual boot)
(4) Western Digital Caviar Black 1 TB (Hard Drives)
LG Blu-Ray / CD / DVD Writer (Optical drive)
Corsair Hydro H115i (Cpu Water Cooler)
Corsair HX1000 Series (Power Supply)
Corsair Obsidian Series 750D Airflow (Computer Case)

Monitors:
Seiki SM40UNP 40" (4k Monitor)
LG 24UD58-B 24" (4k Monitor)
Vizio 1080p HDTV 42" (Tv connected from the other room for streaming movies, and gaming)

Requirements for this install:
An empty flash drive for Unibeast + an already working copy of OS X to make the drive.

A usb audio device. I have a Sabrent USB sound adapter, it's plug and play! Link: https://www.amazon.com/dp/B00IRVQ0F8/?tag=tonymacx86com-20

Pre installation requirements:
Update Bios to f23 from Gigabyte's Website (for x99 ud4 motherboard) @ http://www.gigabyte.com/products/product-page.aspx?pid=5123#bios

Go into bios, use "load optimized defaults"

Save.

Thats it.

Bios settings not required, but recommended for this install:
  • Go into bios under frequency settings set "cpu boost 5820k to 4.3 ghz"
  • Set memory settings xmp memory profile to "profile 1" or "profile 2" (depending on your memory speed)

Note: This will overclock your cpu and memory, you may or may not want to do that. i reccommend it. computer definetly runs better with overclocking. It's automatic and the motherboard takes care of all the voltage settings. Use 4.3ghz for your cpu and profile 1 or profile 2 depending on the speed of your memory. I use profile 1 because I am using 2400mhz memory.

Pre Install - Step 1
Use the tonymacx86 method to install "Sierra" to a USB Flash Drive using Unibeast. You will need to make an account on tonymacx86 to be able to download Unibeast.

Here is the link to the guide to make the unibeast flash drive:
https://www.tonymacx86.com/threads/unibeast-install-macos-sierra-on-any-supported-intel-based-pc.200564/

Install Unibeast / Sierra To flash Drive using the guide from the link I posted.

Pre Install - Step 2
After installing Unibeast / Sierra flash drive you will need to get "EFI Mount 3 and Clover Configurator".

Get Clover Configurator from http://mackie100projects.altervista.org/download-clover-configurator/

Get EFI Mount 3 from the Downloads section > Community Software @ Tonymacx86.com Link: http://www.tonymacx86.com/downloads.php?do=cat&id=10 (must be logged in to view this page)

Pre Install - Step 3
Copy EFI Mounter 3 / Clover Configurator to Your Applications. Then open the EFI partition from the unibeast drive (it should already be mounted).

(If it is not mounted open EFI Mounter 3 and mount the first selection in the menu. Then open the EFI partition from the unibeast drive)

Pre Install - Step 4
Download OsxAptioFix2Drv-free2000.efi from this link: https://www.dropbox.com/s/d74tdymovdxmlly/OsxAptioFix2Drv-free2000.efi?dl=0 (Source: https://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-update/ )

Copy OsxAptioFix2Drv-free2000.efi to your /EFI/ClOVER/drivers64UEFI folder and remove OsXAptioFix2Drv.efi (This is the key to getting the unibeast drive to boot!)

- Thanks to Sunman for the info! https://www.tonymacx86.com/threads/so-close-to-success-x99-ud4-5820k-x290-5770-sierra-boot.203495/ <---- reference link

Pre Install - Step 5
Open config.plist from the EFI > Clover folder on your Unibeast drive with Clover Configurator.

In the "Boot" Section of Clover Configurator Tick:

dart=0
npci=0x2000

in the custom flags box type
-v

Now your ready to install MacOS Sierra!

Install - Step 6
Reboot your computer and choose to boot from usb drive. It should boot into the MacOs installer screen!

* If it does not boot, click the icon that looks like a gear on the clover boot menu. Try adding "nv_disable=1" (without quotation marks) to the boot flags section.

Follow the guide from Tonymacx86 to complete the installation: https://www.tonymacx86.com/threads/unibeast-install-macos-sierra-on-any-supported-intel-based-pc.200564/

After 10.12 is installed continue to follow this guide.

Install - Step 7
Now that it's installed, boot once again from your Unibeast drive, but this time select your new MacOs Installation from the clover screen. You should not need any extra boot flags.

* If it does not boot, click the icon that looks like a gear on the clover boot menu. Try adding "nv_disable=1" (without quotation marks) to the boot flags section.

Continue to set up the computer and finish the boot until you see the desktop. Remove your Unibeast drive.

Post Install - Step 8
Download & run Multibeast - Sierra from here: https://www.tonymacx86.com/resources/categories/tonymacx86-downloads.3/

Select These Options:
Quick Start > UEFI Boot Mode
Drivers > Disk > Intel Generic AHCI Sata
Misc > NullCPUPowerManagement
Misc > VoodooTSCSync > VooDooTSCSync 6 Core
USB > Increase Max Port Limit 9 Series
Network > Intel > AppleIntelE1000e v3.3.3 (or newer)
Customize > NVIDIA Web Drivers Boot Flag

Install Multibeast.

Post Install - Step 9
After installing Multibeast the EFI Partition for your MacOs install should automatically mount.

Copy OsxAptioFix2Drv-free2000.efi to your /EFI/ClOVER/drivers64UEFI folder and remove OsXAptioFix2Drv.efi. Also remove VBoxHfs-64.efi (we will be replacing this driver)

Remove VBoxHfs-32.efi from the /EFI/ClOVER/drivers32UEFI folder. This file might also be in /EFI/ClOVER/drivers32 folder (if there is one)

Open config.plist from the EFI > Clover folder on your system drive with Clover Configurator

Post Install - Step 10
In the "Boot" Section of Clover Configurator Tick:

dart=0
npci=0x2000

Then go down to "Install Drivers" under the "Tools" Section of Clover Configurator (Bottom Left).

Make sure these drivers are installed (grey means installed):

Drivers UEFI 64 Bit (Bottom Left Menu): EmuVariableUefi
Extra Drivers (Bottom Right Menu): HFSPlus, HFSPlus UEFI, OsxFatBinaryDrv UEFI

Go to File > Save and save your config.plist. Close Clover Configurator.

Post Install - Step 11
Download VoodooHDA.Kext https://sourceforge.net/projects/voodoohda/files/?source=navbar (get 2.89 or newest one, 2.89 works verified)

Copy VoodooHDA.Kext to EFI > Clover > Kexts > Other

This will kext will enable sound, although it is not fully reliable unless using Spidf out.

Note: Plugging in computer speakers to the green audio jack will eventually stop working. In this case you will need your USB Audio Device. If using Spdif out you will have no problems. I have tried all ways possible to enable onboard sound with this build and this is the best method. All other ways are even more unreliable and can cause problems with the install. I came to this conclusion after about a year of trial and error.

Post Install - Step 12
Download USBInjectAll.Kext https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads/ (get the newest one)

Download FakePCIID_XHCIMux.Kext and FakePCIID.kext https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads/ (get the newest one)

Download X99_Injector USB 3.kext (attached at bottom of this post)

Copy USBInjectAll.Kext, FakePCIID_XHCIMux.Kext, FakePCIID.kext & X99_Injector USB 3.kext to EFI > Clover > Kexts > Other

Delete all other folders inside "Kexts" folder, except the "Other" folder

Now you will have enabled USB with full support for 3.0! (Credit goes to crismac2013 via his post on Page 10, his post described how to properly enable USB 3.0.)

Note: From my understanding USBInjectAll.Kext works with X99_Injector USB 3.kext to enable usb 3.0 support on x99 motherboards. This works in conjunction with the Multibeast "Increase Max Port Limit" patch for full support. FakePCIID_XHCIMux.Kext and FakePCIID.kext are used to determine which devices are USB 3.0 and which are 2.0. If you do not use FakePCIID_XHCIMux.Kext and FakePCIID.kext everything will look like it is a USB 3.0 device under System Report even if it isn't. With these kexts installed only true USB 3.0 devices will be detected as so when plugged into a 3.0 port. The rest will fall under USB 2.0.

Post Install - Step 13
Download and install NVidia Web Drivers from: https://www.tonymacx86.com/nvidia-drivers/

Reboot

Post Install - Step 14
Go to Applications > Utilities > Terminal enter 'sudo trimforce enable' (without the ''s) this will enable Trim if using an SSD Drive (Highly recommended, SSD only)

System will reboot automatically.

Congratulations you now have a fully working x99 Hackintosh running 10.12.x!

Optional Install - Dual Boot with Windows
In order to dual boot with windows 10 you will need to open up your config.plist file again.

Open EFI Mounter 3 and mount the first selection in the menu. Then open the EFI partition and open config.plist from the Clover folder with Clover Configurator.

  • If windows was installed using UEFI Mode:

In the "Boot" Section of Clover Configurator the menu on the top right should say "PBR"

Go down to "Install Drivers" under the "Tools" Section of Clover Configurator (Bottom Left).

Make sure these drivers are installed (grey means installed):

Extra Drivers (Bottom Right Menu): NTFS UEFI

Go to File > Save and save your config.plist. Close Clover Configurator.

  • If it doesn't boot from clover, you have installed windows without UEFI:

In the "Boot" Section of Clover Configurator change the "Legacy" menu on the top right to "LegacyBiosDefault" (it should say PBR by default)

Then go down to "Install Drivers" under the "Tools" Section of Clover Configurator (Bottom Left).

Make sure these drivers are installed (grey means installed):

Extra Drivers (Bottom Right Menu): NTFS

Go to File > Save and save your config.plist. Close Clover Configurator.

You should now be able to dual boot with Windows from the Clover Menu!

Disable Gatekeeper In MacOs Sierra

The Gatekeeper settings can be found in System Preferences > Security & Privacy > General. The Gatekeeper options are located beneath “All apps downloaded from:” with the choice of “Anywhere” missing.

Thankfully, the “Anywhere” setting can be restored to Gatekeeper in Sierra with a Terminal command. First, quit System Preferences if it’s open and then open a new Terminal window. Enter the following command, followed by your admin password when prompted:

sudo spctl --master-disable

Now, relaunch System Preferences and head back to the Gatekeeper settings. You’ll now see that “Anywhere” has been restored. Click the padlock in the lower-left corner to enter your password and make changes, then select “Anywhere” from the list of Gatekeeper options. The security feature will no longer bug you about apps from unidentified developers.

How To Optimize OS X!
Go to system Preferences > Mission Control, untick all check boxes. turn dashboard off (may require log out / log back in)

Go to system preferences > Security & Privacy, Under General > untick all check boxes (may require clicking lock at bottom left of box), fill in bubble on allow apps downloaded from anywhere (now system boots to desktop and auto logs in without needing password) Under Privacy tab > Untick enable location services

Go To system preferences > spotlight, untick all check boxes in search results tab, then go to privacy tab, drag all drives into that tab. This will turn spotlight off, so you can't search, but will make computer faster. If you want to keep search function, don't do this, but if you want faster computer. Turn it all off!

Go to system preferences > notifications, untick everything, then go to notification panel on the top right of screen, and click the grey box at the bottom. Drag any apps with the red coicon next to them to the green icon section. That will turn off all notifications for apps (speeds up computer a bit)

Go To System Preferences > Energy Saver, turn display off after: Never (drag bar all the way to right) untick all check boxes, especially untick put hard drives to sleep

Go to System Preferences > Bluetooth, turn bluetooth off (unless you need it then turn bluetooth on)

Go to System Preferences > App Store, untick automatically check for updates

Go to System Preferences > Siri, untick Enable Siri

Thats about the extent of it,
Good luck!!!!

Screenshots of my Clover configurator are attached for your reference!

geekbenchelcapitan.png Screen Shot 2016-11-25 at 7.07.11 PM.png Screen Shot 2016-11-25 at 7.07.21 PM.png Screen Shot 2016-11-25 at 7.07.30 PM.png Screen Shot 2016-11-25 at 7.07.38 PM.png Screen Shot 2016-11-25 at 7.07.46 PM.png Screen Shot 2016-11-25 at 7.07.53 PM.png Screen Shot 2016-11-25 at 7.08.08 PM.png Screen Shot 2017-03-14 at 2.50.23 AM.png Screen Shot 2016-11-25 at 7.08.24 PM.png Screen Shot 2016-11-25 at 7.08.32 PM.png Screen Shot 2016-11-25 at 7.08.42 PM.png Screen Shot 2016-11-25 at 7.09.22 PM.png
 

Attachments

Last edited:
U

underwnm

Guest
I have similar hardware. When I install it through the usb drive and then go to the usb drive again and click on sierra to finish the install. It just continues to run through some -v then restart without continuing. Any ideas?
 
Last edited by a moderator:
Joined
Nov 9, 2014
Messages
20
Motherboard
Asus x99-a
CPU
i7 5820k
Graphics
nvidia gtx 760
Mac
Mac Pro
Classic Mac
Mobile Phone
iOS
Does not work. All did as the instructions. Put Test2016.efi. Flags set that you have. Loading did not go. Although I have not installed through Unibeast. And I was able to install the system, though my Gtx 760 would not start. In the About this mac: Nvidia chip model.
My system
Asus x99-a
5820k
Gtx 760
 
Joined
Sep 18, 2011
Messages
499
Motherboard
Gigabyte GA-X99-UD4
CPU
Intel Core I7 5820K
Graphics
EVGA Nvidia Geforce GTX 1080 Ti SC2
Mac
Mac Pro
Classic Mac
Lisa
Mobile Phone
Android
I have similar hardware. When I install it through the usb drive and then go to the usb drive again and click on sierra to finish the install. It just continues to run through some -v then restart without continuing. Any ideas?
Yeah that happened to me when i was trying to install at first. Could be graphics card. Did you use test2-2016.efi. Try booting with -f. Sometimes it doesnt boot from flash drive.

Does not work. All did as the instructions. Put Test2016.efi. Flags set that you have. Loading did not go. Although I have not installed through Unibeast. And I was able to install the system, though my Gtx 760 would not start. In the About this mac: Nvidia chip model.
My system
Asus x99-a
5820k
Gtx 760
You did not use unibeast? You need to follow the guide it should work if you follow my steps. Ymmv since you have slighty different components i can only vouch / provide support for my setup. But its possible on x99. Runs really smooth
 
U

underwnm

Guest
Yeah that happened to me when i was trying to install at first. Could be graphics card. Did you use test2-2016.efi. Try booting with -f. Sometimes it doesnt boot from flash drive.
I tried -f and still didn't work. I have EVGA GTX 970. Should I try to remake usb drive and start from scratch again?
 
Joined
Jan 9, 2014
Messages
49
Motherboard
Gigabyte X99-UD4
CPU
i7-5820K
Graphics
RX 580
Malki you ROCK
Did you notice any difference between El Capitan and Sierra ?
 
Joined
Sep 18, 2011
Messages
499
Motherboard
Gigabyte GA-X99-UD4
CPU
Intel Core I7 5820K
Graphics
EVGA Nvidia Geforce GTX 1080 Ti SC2
Mac
Mac Pro
Classic Mac
Lisa
Mobile Phone
Android
I tried -f and still didn't work. I have EVGA GTX 970. Should I try to remake usb drive and start from scratch again?
maybe. You might need different boot flags or kexts to get it to boot with that board. see if anyone else had success with your motherboard on el capitan and try it on sierra.

Malki you ROCK
Did you notice any difference between El Capitan and Sierra ?
Thanks! Sierra seems to perform more smooth than El Capitan in all areas! Maybe supports x99 or the gtx 970 graphics card better. Highly reccommend the update!
 
Joined
Jul 23, 2015
Messages
91
Motherboard
x99-UD4
CPU
5820K
Graphics
280x
Mac
MacBook Pro
Hi Malki,

I remember you had an issue at the beginning with not the correct EFI booting. How did you solve that? I want to install Sierra but I have other drives still attached with Clover EFI (backup drives). Will that be problematic for me?

Thx
 
Joined
Sep 18, 2011
Messages
499
Motherboard
Gigabyte GA-X99-UD4
CPU
Intel Core I7 5820K
Graphics
EVGA Nvidia Geforce GTX 1080 Ti SC2
Mac
Mac Pro
Classic Mac
Lisa
Mobile Phone
Android
Hi Malki,

I remember you had an issue at the beginning with not the correct EFI booting. How did you solve that? I want to install Sierra but I have other drives still attached with Clover EFI (backup drives). Will that be problematic for me?

Thx
Wiped my mac osx drive and clover still loaded up. Thats when i realized it was on another drive. Once I deleted it from the 2nd drive i had no problems booting. Even if you have clover on other drives it shouldn't be a problem as long as your bios is set to boot from the drive you want to work with. I had the 2nd drive selected as the first boot device without knowing. After many boot fails trying to install sierra, the bios reset itself a few times, and it changed the boot order without me realizing it.
 
Joined
Jul 23, 2015
Messages
91
Motherboard
x99-UD4
CPU
5820K
Graphics
280x
Mac
MacBook Pro
Wiped my mac osx drive and clover still loaded up. Thats when i realized it was on another drive. Once I deleted it from the 2nd drive i had no problems booting. Even if you have clover on other drives it shouldn't be a problem as long as your bios is set to boot from the drive you want to work with. I had the 2nd drive selected as the first boot device without knowing. After many boot fails trying to install sierra, the bios reset itself a few times, and it changed the boot order without me realizing it.
Hey thanks for the reply! Seems everything works fine. Except sound. I installed the kext with kext utility... Did I have to do anything else?

Thx
 
Top