Contribute
Register

[Success] i7 4770k - GA-Z87X-UD3H - 16GB RAM - GTX 770 2GB

Joined
Feb 13, 2014
Messages
3
Motherboard
GA-Z87X-UD3H
CPU
i7 4770k
Graphics
MSI GTX 770
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
lazza13's Build: i7 4770k - GA-Z87X-UD3H - 16GB RAM - GTX 770 2GB

Schermata 2018-01-06 alle 11.55.04.png
Components

Intel Core i7-4770K Processor
https://www.amazon.com/dp/B00KPRWAX8/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16819117369

Gigabyte GA-Z87X-UD3H Motherboard
https://www.amazon.com/dp/B00CU4L508/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16813128592

Corsair Vengeance 16GB (2x8GB) DDR3 1600 MHz Memory
https://www.amazon.com/dp/B007TG8QRW/?tag=tonymacx86com-20

MSI NVIDIA GeForce GTX 770 2GB Graphics Card
https://www.amazon.com/dp/B00CZ58WUI/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16814127741

Crucial 120GB MX 500 SSD (CT120M500SSD1)
https://www.amazon.com/dp/B00BQ4F9ZA/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820148693


Comments

Installation

Initial Step

I followed all the steps from squadseven's post (https://www.tonymacx86.com/threads/success-squadsevens-build-i7-4770k-ga-z87x-ud3h-16gb-ram-gtx-780-3gb.109540/), and I had already a fully working system with macOS 10.10.3.

I decided to upgrade my system to macOS 10.13.2, and with the same BIOS configuration I followed the installation guide from here: https://www.tonymacx86.com/threads/unibeast-install-macos-high-sierra-on-any-supported-intel-based-pc.235474/.

Configuration of MultiBeast (High Sierra v10.2.0):

Schermata 2018-01-06 alle 11.43.52.png

Final configuration:
Now I have a fully working system with sleep function. I'll update this post if I'll find any problem.

Big thanks to squadseven and tonymacx86 for all the stuff.
 
Joined
Feb 24, 2014
Messages
9
Motherboard
ASUS Prime Z390-P LGA1151
CPU
i5-9600K
Graphics
GTX 950
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
Very helpful, thank you. Have been having a nightmare with this.

All seems to be working fine so far - USB 3, audio, ethernet, IGFX.
Now to setup and reinstall everything again, for the 1034th time...
 
Joined
Jan 9, 2014
Messages
26
Motherboard
GA-Z87X-UD3H (F9)
CPU
Intel Core i7-4790K @ 4GHz
Graphics
NVIDIA GeForce GTX 560 SE
Mac
MacBook Pro
Mobile Phone
iOS
Joined
Feb 6, 2013
Messages
91
Motherboard
GA-Z87X-UD3H
CPU
i7-4770K
Graphics
GTX 660 Ti
Mac
Classic Mac
Mobile Phone
Hey. I heve te same mb an cpu like you and I have a problem get to installation screen. I made bootable usb with high Sierra 10.13.3 via Unibeast 8.2. When I try to boot it stuck on:
Atempting system restart...MACH Reboot
so then via clover option i check droop MACH and DMAR, but then booting stuck on:
kextd stall appleacpicpu

any suggestion?
 
Joined
Sep 24, 2013
Messages
114
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
Vega
Mac
iMac, MacBook Pro
Classic Mac
eMac, iMac, Power Mac
Mobile Phone
iOS
Very helpful, thank you. Have been having a nightmare with this.

All seems to be working fine so far - USB 3, audio, ethernet, IGFX.
Now to setup and reinstall everything again, for the 1034th time...
every time when i start booting it ended up with spinning wheel with (movable) mouse pointer. I can boot in safe mode but that is not loading any graphics drivers I guess.

I am almost about to give up, any help would be appreciated.

please see : https://www.tonymacx86.com/threads/gtx-560-not-working-after-upgrading-to-h-sierra-ga-z87x-ud3h.243812/

Hello,

I have a very similar build to yours and I’m having some post installation problems.
It would be great if you could post your config.plist to help me troubleshoot mine.

For information here is my thread : https://www.tonymacx86.com/threads/help-updating-from-yosemite-to-high-sierra-i7-4770k-z87-ud5h.246440/#post-1697869

Thanks.
Hey. I heve te same mb an cpu like you and I have a problem get to installation screen. I made bootable usb with high Sierra 10.13.3 via Unibeast 8.2. When I try to boot it stuck on:
Atempting system restart...MACH Reboot
so then via clover option i check droop MACH and DMAR, but then booting stuck on:
kextd stall appleacpicpu

any suggestion?
Something's amiss, but here are some basics re Z87 and Z97. Please note that I use HFS+, not APFS. Add latest APFS driver if you use that file system:

1) You don't need the latest firmware for the Z87X motherboards; but check the Gigabyte website to make sure you have firmware that works well with Haswell. For my OC board that's F7. Don't use beta firmware. If you update, do it from a flash drive using Q-flash; don't use the @BIOS utility.

2) In BIOS (UEFI), you know to start by loading optimized defaults. Use the profile for your RAM, if you need it. No OC on your processor. Fast Boot (DISabled); Execute Disable Bit (Enabled); Intel Virtualization (Enabled); Secure Boot (DISabled); Boot Mode Selection (I suggest UEFI and Legacy, but can try UEFI Only); Storage Boot (Legacy Only); Initial Display (PCIE 1) if you use first slot; XHCI Mode (Smart Auto /or Auto); Intel Graphics (DISabled); Intel Rapid Start (DISabled); Legacy USB (Enabled); XHCI Hand-Off (Enabled); EHCI Hand Off (DISabled).

3) Very important: In order to disable CSM you must not use "Other OS" in BIOS. Instead set to "Windows 8" (and if you dual-boot and use Windows 10, that's the setting as well; if your system is macOS only you still set to Windows 8). When you do that it opens up the CSM Support setting below it. Now change that setting to "Never." See post #53, by Antilogical: https://www.tonymacx86.com/threads/...high-sierra-black-screen-panics.234390/page-6
Solves a monitor blackout. Now the Clover boot loader and the entire boot up process are in full resolution, and the startup takes far less time. And the boot up in Windows 10 is also almost instantaneous.

4) Follow this guide by ILikeHackintosh to install updates, a huge help:
https://www.tonymacx86.com/threads/...erra-black-screen-panics.234390/#post-1603620
In the latest High Sierra, for updates, you won't have to disable SIP. You can keep SIP on.

5) Make sure the MATS table is dropped in your Clover plist:
A kernel panic results from an invalid character in the MATS table in the system UEFI with Z87/ Z97 boards, as detailed by Moheban79 here (#7): https://www.tonymacx86.com/threads/...n-in-clover-configurator-to-drop-mats.226488/ and worked out in Pikeralpha et. al. discussion, ”Chameleon and High Sierra…” for a solution re Z87/ Z97 boards and High Sierra: https://pikeralpha.wordpress.com/2017/06/11/chameleon-and-high-sierra/

6) The FakeSMC_GPUSensors.kext in FakeSMC Plugins is NOW compatible with NVIDIA Pascal graphics cards in High Sierra only. As noted in previous MultiBeast update listings, in Sierra and past macOS, if you do not delete it from /Library/Extensions your system will kernel panic on boot. OK w/ Maxwell anyway.

7) And more to the point, always use the latest versions of Clover and all kexts (and drivers); if you use UniBeast and MultiBeast, make sure they're the latest versions. I use Rehabman's installer detailed here:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
This method really works well. With High Sierra, don't put kexts into S/L/E. It's debatable whether or not to put kexts into L/E or even into the disk EFI (aside from the kexts mentioned in Post #1.) You could put everything into your flash drive installer and boot from that, but that's up to you. Clover will inject regardless. I use these kexts' latest versions: Lilu; IntelMausi, USBInject, FakeSMC, and both FakePCIID were RehabMan’s; and NvidiaGraphicsFixup and VoodooHDA (at least 2.9.1). I replaced the VBoxHfs-64.efi UEFIx64 driver with Apple’s HFSPlus.efi.

8) Settings on your Clover plist, post-installation using Clover Configurator, can be complex, but start with the MultiBeast installation's plist. I believe one relevant setting, “Dart=0”, per Rehabman, negates the VT-d that seems enabled by default in the UEFI. [EDIT: VT-d is disabled by design in the 4770K, and several other UNLOCKED CPUs.] Also, make an SSDT with this method:
https://www.tonymacx86.com/threads/quick-guide-to-generate-a-ssdt-for-cpu-power-management.177456/

Regardless of your system definition (should be iMac 14,2 or 15,1) when using an NVIDIA card use the latest Lilu.kext and the latest NvidiaGraphicsFixup.kext. If you use 15,1 and several other definitions, you MUST use these two kexts to avoid black screen /kernal panics. There are additional benefits to using these kexts, per RehabMan.

Please go to my profile and other posts for addition information re Z87X.


I hope this helps. Cheers!
 
Last edited:
Joined
Feb 20, 2012
Messages
4
Motherboard
ASUS P8Z68 PRO
CPU
i7-2600K
Graphics
GTX 770
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
I've got a very similar system (GTX 760 and 32GB ram) and can report success with Mojave 10.14.2. Everything is working nicely except losing LAN when waking from sleep. Though I believe this issue is with AppleIntelE1000 v3.3.6 and rolling back to AppleIntelE1000 v3.2.4.2 or using IntelMausiEthernet v2.1.0 may fix this.

Multibeast config:

Screen Shot 2019-01-02 at 2.26.19 AM.png


UPDATE:
Rolling back to AppleIntelE1000e v3.2.4.2 has resolved the LAN issue.
 
Last edited:
Joined
Jul 3, 2013
Messages
32
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i7-4770
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
I've got a very similar system (GTX 760 and 32GB ram) and can report success with Mojave 10.14.2. Everything is working nicely except losing LAN when waking from sleep. Though I believe this issue is with AppleIntelE1000 v3.3.6 and rolling back to AppleIntelE1000 v3.2.4.2 or using IntelMausiEthernet v2.1.0 may fix this.

Multibeast config:

View attachment 376223

UPDATE:
Rolling back to AppleIntelE1000e v3.2.4.2 has resolved the LAN issue.
How about USB 3 speeds? I'm in Mojave 10.14.2 right now USB 3 speed is at USB2 speed.
 
Top