Contribute
Register

[SUCCESS] HP Z600 High Sierra Installation Guide

Joined
Nov 8, 2014
Messages
48
Motherboard
HP Z600
CPU
E5606
Graphics
K1200 Nvidia
Mac
MacBook Pro
Hi All,

I am suffering from an issue during a clean installation, can anyone help?
These are the steps I did to my old Z600

1 - Create and config a installation HDD with UniBeast and clover configurator in my iMac
2 - Plug the installation HDD to Z600
3 - Clover boot select "Boot Mac OS X from HDD"
4 - Edit the minstallconfig.xml in terminal to prevent APFS conversion, Restart
5 - Installer started, select the SSD which has been formatted to OSX Journaled
4 - Installer started to copy the files to the SSD
5 - After a few seconds, system reboot
6 - Clover boot select "Boot Mac OS X from SSD"
7 - Then an error screen shows "an error occurred while loading the installer resources" (as below)

Thanks
Hmm. The error is a little vague. Can you boot using the -v flag and get a more detailed output?
 
Last edited:
Joined
Nov 8, 2014
Messages
48
Motherboard
HP Z600
CPU
E5606
Graphics
K1200 Nvidia
Mac
MacBook Pro
Is it possible to install MacOs without a ps2 keyboard and mouse, I only have a USB keyboard and mouse,
Thanks for your help
Yesssss!

IF You have purchased and fitted this to your Z6/800 like I did. Now I have handoff Bluetooth and WiFi all working natively without any drivers or hacking.

The apple keyboard and Magic Mouse both work at bois level from cold boot so technically, yes, you can perform a build without the legacy PS2 keyboard or mouse


 
Joined
Nov 8, 2014
Messages
48
Motherboard
HP Z600
CPU
E5606
Graphics
K1200 Nvidia
Mac
MacBook Pro
Yesssss!

IF You have purchased and fitted this to your Z6/800 like I did. Now I have handoff Bluetooth and WiFi all working natively without any drivers or hacking.

The apple keyboard and Magic Mouse both work at bois level from cold boot so technically, yes, you can perform a build without the legacy PS2 keyboard or mouse


I stand corrected. Upon the initial install you are required to deleted the AppleHPET.kext driver to allow the Bluetooth functionality to work!

So, yes you do require a PS2 keyboard and mouse for build purposes.

Additionally, when I upgraded to the later .updates by apple, the AppleHPET.kext re-appeared.

Now we can script the OS so whenever it sees that file in the directory it deletes it, but if you upgraded like I did, then was greeted without any input devices to login as a result, you will hold your head in your hands for sure.

My only saving grace as I didn’t have PS2 devices to hand was that screen sharing was already set up on this build. I remotely connected to machine and deleted the AppleHPET.kext thus gaining access back to my hackintosh.
389199
 
Last edited:
Joined
Feb 26, 2019
Messages
2
Motherboard
HP Z600
CPU
Xeon E5520
Graphics
Nvidia Geforce 680 GT
My mobo came with the BIOS updated to v3.61. Is it necessary to downgrade to v3.60 for this guide to work?
I successfully installed High Sierra using the instructions in this thread. I had previously updated to BIOS v3.61, so I tried to install MacOS this way. It didn't work, when it came to boot into the installer it would just crash and reboot.

However downgrading to v3.60 was not easy. It looks like HP doesn't allow you to downgrade BIOS. It didn't work from BIOS itself, using the flash menu option.

So instead I used the bootblock emergency recovery method. First you need a USB stick/thumbdrive on which to copy the BIOS image, directly to the root of the drive, in fact I recommend you format the disk before this.
Then you need to locate the jumper location that forces emergency bootblock recovery. It's near the BIOS battery, you need to short it with a jumper, with the Z600 turned off of course.
Connect the USB stick and power on the Z600. A menu should appear to allow you to flash the BIOS from the USB stick.
Alternatively look for the procedure online or in the service manual.

I'm not entirely sure, but I think something can be changed in config.plist smbios section, to make it work with BIOS v3.61. But at least downgrading to v3.60 worked for me.

I hope this info is useful.
 
Joined
Mar 7, 2019
Messages
1
Motherboard
HP Z600 Rev C2
CPU
2x X5675
Graphics
GTX 1060
Cheers d4vinder, thanks for the straightforward guide! My first Hackintosh is up and running! Installed 10.13.6 17G5019 using your method (plus the Clover config changes / serial number generation to get iMessages, App Store, etc working) on my Z600 C2 with BIOS v3.61.

Only minor issue I personally had was needing to delete and remake the EFI partition on my target install SSD (apparently the EFI partition made by Windows is smaller than the one made by Mac, and the installer would throw an error about the target drive not having enough space).
 
Joined
Feb 26, 2019
Messages
2
Motherboard
HP Z600
CPU
Xeon E5520
Graphics
Nvidia Geforce 680 GT
Cheers d4vinder, thanks for the straightforward guide! My first Hackintosh is up and running! Installed 10.13.6 17G5019 using your method (plus the Clover config changes / serial number generation to get iMessages, App Store, etc working) on my Z600 C2 with BIOS v3.61.

Only minor issue I personally had was needing to delete and remake the EFI partition on my target install SSD (apparently the EFI partition made by Windows is smaller than the one made by Mac, and the installer would throw an error about the target drive not having enough space).
So it worked for you with BIOS v3.61. I have a B3 stepping Z600, maybe that is why it didn't work for me.
 
Joined
Jan 14, 2014
Messages
20
Motherboard
HP Z600
CPU
X5570 x2
Graphics
W7000
Mac
MacBook Pro
Classic Mac
Power Mac, PowerBook, SE
Mobile Phone
iOS
Fantastic guide. Running great on a Rev. 1 z600. Thanks a ton.

My one wish is that I could find a way to boot without this old Quadra fx580 in it. The variety of supported GPUs on this model is very small, apparently. And when I try to boot with my FirePro w7000 as the primary boot card, I get the dreaded six beeps.
 
Joined
Dec 10, 2018
Messages
9
Motherboard
iMac Pro
CPU
3.2GHz Intel Xeon W
Graphics
Nvidia GTX 1070
Fantastic guide. Running great on a Rev. 1 z600. Thanks a ton.

My one wish is that I could find a way to boot without this old Quadra fx580 in it. The variety of supported GPUs on this model is very small, apparently. And when I try to boot with my FirePro w7000 as the primary boot card, I get the dreaded six beeps.
I've running my Z600 with a MSI GTX 1070 Gaming X on High Sierra. The power supply of Z600 is at the limits of power requirements of the GTX 1070, but using some adapter to get PCI8 from Sata power did it the trick. P.D.: I don't close the Z600 case never with the GTX 1070 from MSI installed. You can try to search another model with lower profile.
 

Attachments

Joined
Jan 14, 2014
Messages
20
Motherboard
HP Z600
CPU
X5570 x2
Graphics
W7000
Mac
MacBook Pro
Classic Mac
Power Mac, PowerBook, SE
Mobile Phone
iOS
Oh, it's not that I can't boot with the FirePro in it -- the GPU is working fine. But I have to keep the Quadro sitting in that slot just taking up a slot so the machine doesn't do the six-beeps on boot that indicate there isn't a supported GPU in the slot.
 
Top