[Success] [High Sierra] i7 4770k - GA-Z87X-UD3H - 32GB RAM - GTX 770 4GB

Not open for further replies.
Jan 4, 2014
i7 4770k
GTX 770 4GB
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Aleasy's Build: i7 4770k - GA-Z87X-UD3H - GTX 770 4GB


Gigabyte GA-Z87X-UD3H Motherboard

Intel i7 4770K Processor

Antec H2O 620 Processor Cooler

Gigabyte GeForce GTX 770 4 GB (Nvidia) Graphics Card

32GB G.Skill DDR3 1600 MHz Memory

Cooler Master V1000 Power Supply

Lian Li PC-V650 Computer Case

Dell U2412M Monitor (2x)

Samsung 840 EVO 250GB SSD (2x)

Western Digital 3TB Green SATA Hard Drive

Western Digital 1TB Blue SATA Hard Drive (2x)

TP-Link TL-WDN4800 PCIe Wireless Network Adapter

LG BH16NS40 Bluray Optical Drive


My First Build

I built my first Hackintosh in 2014 and I installed Mavericks 10.9.1 using tonymacx86 guide: everything went perfect.
I hadn't done any update until I upgraded directly to High Sierra 10.13.3.


I created a USB boot drive using UniBeast 8.1.0 and a High Sierra OS installation app which I downloaded on my MacBook Pro running Sierra. On my Mavericks Hackintosh it only downloaded the 19MB installer of High Sierra.

Then I followed the post of lazza13 (Thanks!):
Which pointed me towards another post from squadseven which I used partly to configure my BIOS (Thanks too!):

As squadseven suggested, I flashed version F8m to my motherboard (I was on F8k which might have worked as well...)
Then, the settings I used from his build were:

- Press F7 to load optimized default values
- xHCI Mode: AUTO
(although I changed it eventually to SMART AUTO as I had some issues in my first trials and I tried that following a post from outside this forum. My build is with SMART AUTO now but I believe it wouldn't make any difference AUTO or SMART AUTO for me. The general consensus seems to be to leave it on AUTO though)
- xHCI Hand-OFF: Enabled
- EHCI Hand-OFF: Enabled
- Internal Graphics: Disabled
- Init Display First, change it to the PCIe slot that you placed your graphics card in
- Wake on LAN: Disabled

After re-booting, I pressed F12 and chose the UEFI version of my HIGH SIERRA BOOT USB

At this point is where I had the only issues during the installation.
I couldn't get past the dreaded frozen wheel with the progress bar stuck (picture credits by SpooderPutato)


The way I finally managed to get through this was by deleting the boot arg nv_disable=1. When it re-booted automatically, by default the nv_disable=1 was there again, causing the process to get stuck again with the frozen wheel. So the next time, after starting from the beginning, I stopped the automatic re-boot by pressing a key on the keyboard when the clover bootloader menu showed up and I deleted again the boot arg nv_disable=1. In total I had to do it 3 times I think.

Once High Sierra was installed, I noticed I didn't have sound, and I couldn't play normal mov videos from my drive. It seems that the default drivers were fine to install the OS but it was limited.

So, then, I used MultiBeast 10.2.0 with this configuration

Drivers > Audio > Realtek ALCxxx > ALC898
Drivers > Misc > Fake SMC
Drivers > Misc > Fake SMC Plugins
Drivers > USB > 3rd Party USB 3.0
Bootloaders > Clover UEFI Boot Mode
Customize > Graphics Configuration > Nvidia Graphics Fixup
Customize > System Definitions > iMac > iMac 14,2​

Then I installed the last available Clover installer v2.4k_r4411 using the default installation. Don't ask me why, I don't know what I was doing there. I don't know if it installed anything that MultiBeast hadn't installed yet, so this step was possibly not necessary for me. My knowledge is very limited. I spend a lot of time reading posts that I half understand (when I'm lucky) and then it's quite often the trial and error method (many times not knowing really what I'm doing).

After re-booting, everything was fine except USB3 drives that were not supported although these same ports recognized USB2 drives. After some research, using MultiBeast, I installed:

Drivers > USB > 7/8/9 Series USB Support​

Now everything is working perfect. No issues at all :)

I haven't installed the latest Nvidia driver. Since it seems to be working fine so far, I will leave it as it is. I will need the CUDA driver eventually but I'll skip on the other driver if I can since some people report lagging with the last release for High Sierra.

Thanks to tonymacx86 and all the community!!!
Last edited:
Not open for further replies.