Contribute
Register

[Success] High Sierra 10.13.4 - Mojave 10.14.1 | MSI Z370 PC PRO | Intel™ Core® i3 8100 | UHD 630 | Corsair 8GB

Joined
Dec 26, 2015
Messages
216
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
Android
Poles Coffelake Build:
MSI Z370 PC PRO - i3 8100 - UHD 630 - Corsair Vengance 8GB - Samsung EVO 860 250GB SSD

Components

MSI Z370 PC PRO ATX Board
https://www.amazon.com/dp/B075VLR7Z3/?tag=tonymacx86com-20

Intel™ Core® i3 8100 3.6GHz Coffe Lake Processor
https://www.amazon.com/dp/B0759FTRZL/?tag=tonymacx86com-20

Corsair Vengeance 2400MHz DDR4 RAM
https://www.amazon.com/dp/B01ARHBBPS/?tag=tonymacx86com-20

Samsung EVO 860 250 GB Solid State Drive
https://www.amazon.com/dp/B0793FNNP6/?tag=tonymacx86com-20


Cooler Master Elite Power 350 Watt SMPS
https://www.amazon.com/dp/B0034ADOB0/?tag=tonymacx86com-20


Antec VSK4000B -U3 Cabinet
https://www.amazon.com/dp/B00CY9TMFO/?tag=tonymacx86com-20




Comments

Its been a year since I have build a hackintosh. Now, when tonymacx86 released their April 2018 buyer’s guide with the new 300 series motherboards & 8th generation Intel Processors, I couldn’t resist myself. I convinced (actually forced) one of my friends to buy his computer parts according to this site. Though I prefer Gigabyte, this time I wanted to try MSI. But I regret it a little bit. I will tell you why.

The Build

BIOS Settings:


  1. To access BIOS/UEFI Setup, press and hold Delete on a USB Keyboard while the system is booting up.
  2. Load Optimized Defaults
  3. Settings \ Advanced \ Integrated Peripherals → Network Stack : Disabled
  4. Settings \ Advanced \Integrated Peripherals → Intel Serial IO : Disabled
  5. Settings \ Advanced \ Integrated Graphics Configuration → DVMT Pre-Allocated : 64MB
  6. Settings \ Advanced \ USB Configuration → XHCI Hand-off : Enabled
  7. Settings \ Advanced \ USB Configuration → Legacy USB Support : Auto
  8. Settings \ Advanced \ Windows OS Configuration → MSI Fast Boot : Disabled
  9. Settings \ Advanced \ Windows OS Configuration → Fast Boot : Disabled
  10. Overclocking → Extreme Memory Profile(X.M.P) : Enabled
  11. Overclocking \ CPU Features → Intel Virtualization Tech : Enabled
  12. Overclocking \ CPU Features → Intel VT-D Tech : Disabled
  13. Press F10 to Save and Exit

UniBeast 8.3.2:

I ran UniBeast 8.3.2 on my Mac Mini to create high sierra 10.13.4 bootable flash drive. (Previously when I tried UniBeast 8.3.1 and got the famous "The recovery server could not be contacted" error while installing. Then I found that its UniBeast's bug started from version 8.2 which was corrected on 8.3.2. Thanks @P1LGRIM )


Installation

The USB didn't boot. Then I found that specially MSI motherboard has the booting problem using OsxAptioFx2Drv.efi driver. According to this post I have to use OsxAptioFix2Drv-free2000.efi !!! So I removed OsxAptioFx2Drv.efi from EFI/EFI/CLOVER/drivers64UEFI and downloaded & copied OsxAptioFix2Drv-free2000.efi. I think the UniBeast & the MultiBeast should have a option like "MSI motherboard" & "Other motherboards" so that user when user select MSI then OsxAptioFix2Drv-free2000.efi will be copied otherwise by default OsxAptioFx2Drv.efi will be copied to EFI/EFI/CLOVER/drivers64UEFI. What do you think @tonymacx86 ? After that the booting and installation went smoothly.

MultiBeast 10.2


You must remove OsxAptioFx2Drv.efi from EFI/EFI/CLOVER/drivers64UEFI every time after you run MultiBeast. Remember OsxAptioFix2Drv-free2000.efi is your driver for MSI not OsxAptioFx2Drv.efi. Otherwise it won't boot. This is where I regret buying MSI motherboard.:banghead:

Audio

According the the MultiBeast guide to get audio working we have to run MultiBeast twice which I did but it didn't worked. So uninstalled realtekALC & I restored native AppleHDA.

Then I decided to run CloverALC:

AppleHDA Realtek Audio Methods - Required: a. native AppleHDA.kext, b. EFI mounted
cloverALC (c. SIP disabled, d. Clover and e. network required)
1.Download/View Raw: audio_cloverALC.command.zip
I got the audio working but it breaks on sleep/wake. Used @RehabMan 's CodecCommander.kext using KextBeast. Now audio works on sleep/wake.

Graphics

The graphics has been very glitchy though its showing UHD 630 1536MB.I found in this forum that i3's UHD graphics is not natively supported by macOS. You have to spoof it. So here are the steps I found on the internet:

Method : Coffee Lake 0x3E91808 FakeID + Blank ig-platform-id

Required Kexts:

  1. Download & unzip the most recent version of FakePCIID
  2. Copy FakePCIID.kext & FakePCIID_Intel_HD_Graphics.kext from the Release folder of Rehabman-FAKEPCIID & paste them to EFI/CLOVER/kexts/Other
  3. Download the latest of Shiki.kext
  4. Download the most recent version of IntelGraphicsFixup.kext
  5. Copy & Paste Shiki.kext & IntelGraphicsFixup.kext into EFI/CLOVER/kexts/Other
Now open config.plist using Clover Configurator & do the following


  1. Select Boot on left-side column
  2. Under Arguments check if -disablegfxfirmware is there or not if not then add it
  3. add shikigva=1 right after -disablegfxfirmware
  4. Select RtVariables on left-side column & Disable SIP (put CsrActiveConfig 0x67)
  5. Save & Exit

Now you have to edit the .plist files of two Kaby Lake kexts and insert the Coffee lake strings into them. You can’t edit the kext files directly in Finder because they are locked. So what you can do is go into Terminal and use nano to make changes.


  1. Open Terminal App & type the following:
    sudo nano /System/Library/Extensions/AppleIntelKBLGraphics.kext/Contents/Info.plist​
  2. Enter Password and Info.plist will populate in Terminal
  3. Find <key>IOPCIPrimaryMatch</key> near the bottom of Info.plist in Terminal. It’s hidden when Info.plist populates. Use down arrow key scroll down Info.plist
  4. Use the arrow keys to highlight the first 0 in 0x3E928086
  5. Add 0x3E918086
  6. Press Space Bar
  7. Should look like this:
    <key>IOPCIPrimaryMatch</key>
    <string>0x59128086 0x59168086 0x591B8086 0x591E8086 0x59268086 0x59278086 0x3E9B8086 0x3EA58086 0x3E918086 0x3E928086</string>
  8. Press Ctrl+X and then press Y then Enter to save it.

  1. Type the following into Terminal:
  2. sudo nano /System/Library/Extensions/AppleIntelKBLGraphicsFramebuffer.kext/Contents/Info.plist
  3. Enter Password and Info.plist will populate in Terminal…
  4. Find <key>IOPCIPrimaryMatch</key> again for this Info.plist
  5. Press Spacebar before the first “<” at the start of </string> using your keyboard arrow keys
  6. Add 0x3E918086 0x3E928086
  7. Should look like this:
    <key>IOPCIPrimaryMatch</key>
    <string>0x59128086 0x59168086 0x591B8086 0x591E8086 0x59268086 0x59278086 0x59238086 0x3E918086 0x3E928086</string>
  8. Press Ctrl+X and then press Y then Enter to save it.

  1. Paste the following into Terminal:
    sudo kextcache -i /​
  2. Paste the following into Terminal
    sudo touch /System/Library/Extensions && sudo kextcache -u /​
  3. Close Terminal
  4. Navigate to /Volumes/EFI/EFI/Clover/
  5. Right click config.plist and open with Clover Configurator
  6. Click Graphics on left-column of Clover Configurator
  7. Remove ig-platform-id value
  8. Click Devices on left-column of Clover Configurator
  9. Set IntelGFX box to 0x3E928086
  10. Save config.plist & Reboot.

After reboot your graphics should be working.


What Works

  1. Integrated Graphics
  2. Audio
  3. Sleep/wake
  4. Audio after sleep/wake
  5. PowerManagement.

Not Checked

  1. iMessage
  2. FaceTime


Geekbench Score:



UPDATE (11-18-18) : Upgraded to Mojave 10.14.1. Used the latest Lilu+Whatevergren on that time.
 
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
2,178
Motherboard
Gigabyte Z370M D3H
CPU
i3-8350K
Graphics
RX 560
Mac
iMac, Mac mini
Classic Mac
eMac, iBook
Mobile Phone
iOS
Hi there.

Good build :thumbup:

There is plenty of scope there for future upgrades in that case, if you decide to do any. And the work you did explaining Intel UHD graphics is very useful. Excellent!

:)
 
Joined
Nov 17, 2011
Messages
7
Motherboard
MSI Z370-A Pro
CPU
i5-8600
Graphics
Intel 630
@poles, great writeup, worked flawlessly. I've also got a MSI Z370-A Pro with an Intel Core i5-8600. Using the MSI's Intel 630, I can get full 4K resolution via DisplayPort on a Samsung U28E590 monitor. For those using this monitor, be sure to hit the monitor's power/action button, then up for Menu > Settings> System > DisplayPort Ver. Then change this from 1.1 to 1.2. If this monitor is set to 1.1, the screen will report that it's not at the optimum resolution (3840x2160@60hz) even though High Sierra > System Prefs > Displays will note that the monitor is okay (using "gather windows"). I couldn't get the monitor to reproduce the screen, but it should either have a floating error or will have hundreds of broken vertical lines, much like you might see if your video cable was bad.
 
Joined
Apr 28, 2018
Messages
16
Motherboard
Z370-HD3
CPU
i5-8400
Graphics
UHD 630
great work man! If I only had your guide a few weeks back I would just get the i3 8100 instead of the i5 8400 :p
Really appreciate your detailed walkthrough.
Cheers mate!
 
Joined
Jun 2, 2017
Messages
18
I almost abandoned the idea of building a hackintosh by i3 8100 when I noticed that acceleration of i3's UHD630 is a huge problem. But this thread saves the idea. Thanks a lot.
 
Joined
Feb 7, 2018
Messages
34
Motherboard
Gigabyte H370M DS3H
CPU
i3-8100
Graphics
UHD 630
Mobile Phone
iOS
Your fix seemed like the most promising for my i3-8100 build paired with a Gigabyte H370M-DS3 but my issue still persists. Currently experiencing flickering when booting up which I only get with Inject Intel disabled. Kernel panic guaranteed every time if I turn this off. Any tips on what may be the culprit? I included my EFI folder and hopefully a useful screenshot of what macOS sees in terms of specs.
Screen Shot 2018-12-08 at 11.28.34 AM.png
 

Attachments

Joined
Dec 26, 2015
Messages
216
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
Android
Not sure. Everything may work fine but except the graphics. For graphics you need to set different ig-platform-id which you will find in this forum. I can say give it a chance.
 
Top