Contribute
Register

[Success] Hackintosh on Gigabyte Z390 M (non-Gaming), Mojave

Joined
May 21, 2018
Messages
1
Hello Guys and Girls!

A short epilogue of my macOS and Hackintosh experiences:
I've bought my first Apple products last year, an iPad 2018 and a used MacBook Air(2011). I really like the Apple ecosystem. Before, I thought it is for stupid or simple people. But no! If you are productive, it can make your life easier. I've bought an iPhone, as well, but I didn't like it, so I went back to Samsung Galaxy S9.

I really like the macOS. I just wanted to use it more often for my daily tasks. Then, I started to play on my desktop system (Gigabyte H310,i7-6700,16GB,GTX1080). I could install macOS High Sierra with UniBeast and MultiBeast. It was really simple and it worked without problems. However, I sold this desktop.
After that system, I was looking forward for a Mac Mini, but it was way too old, and the new one was too expensive.
Suddenly, I found a good deal from HP. I just bought a Pavilion 590 with i7-8700. Sadly, I couldn't install any version of macOS on it, and it came with a GTX1050. So, anyway, the supported OS was High Sierra only.
Then, I started to think about a new rig. I took out the i7-8700 and replaced with a Pentium G5400. I bought the rest of the stuff and here starts the story. (And I've preferred Nvidia cards, but now time has come to change. I was hesitating between the RX 580/590/Vega 56. I took the Vega 56 for 312 EUR and 2 free games. This card will be future-proof for gaming, and in macOS it is a beast.)

Specs:
  • Gigabyte Z390 M
  • Intel i7-8700
  • 2x Crucial 8GB DDR4 2666 Mhz
  • 120GB Patriot Burst SSD
  • 256GB Transcend NVMe SSD
  • Asus AMD Radeon AREZ Strix RX Vega 56 OC
  • Chieftec Tower CI-01B-OP
  • FSP 700W PSU
  • ABWB 802,11 AC WI-FI + Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS Combo
Install:
It was pain in the *ss. I've spent 2 days and ca. 8-10 installations to get the OS running.
I've tried Mojave, High Sierra, with UniBeast and MultiBeast. I've tried even with some custom Clover EFIs.
I was getting all the time several errors.
In the end, I got the system running. And how?
I've prepared an installation USB drive with UniBeast. After I did some fine-tuning in the Clover options file, I've replaced it in the EFI folder.
I just put some recommended kexts according to my chipset in the EFI folder.
After several installations and boot processes, I got a running system. Immediately, I made an EFI backup. Then I started to tweak it.
At this point, I could boot from the USB EFI successfully any time. This was really useful.
I didn't use MultiBeast. I wasn't brave enough to do the Vanilla install, but I did something close to this.
After the first boot, I realized that the graphics and the Wifi are working properly. OK, that's good.
I had an issue with the shutdown and restart. I found some tricks/hacks how to fix it.
From 3 methods, which are settings and installing drivers in Clover, 2 of them made my system unbootable. I took my USB drive again to boot my macOS, then I tried different fixes. The 3rd one was a driver, which was downloaded by Clover Configurator.
When the system was running, I did a Windows install on the other SSD.

What works?
  • Wifi
  • Vega 56
  • Shutdown/Reboot
  • Sound through HDMI
  • iMSG/Facetime
  • USB ports (I haven't check all of them. I know the USB 3.0/3.1 could be an issue. I didn't checK them all yet. But at least the USB connection is working for my printer)
  • I was brave, and I've accepted the newest macOS update. After a reboot, the system is still stable. So far without problems.

407861



407862
 
Top