Contribute
Register

[SUCCESS] “Hac Pro” Asus Sabertooth mark II, i7 4790k, xfx AMD 280x

Status
Not open for further replies.
Joined
Dec 30, 2015
Messages
83
Motherboard
Asus z97 Sabertooth Mark II
CPU
i7-4790k
Graphics
ASUS ROG STRIX 480x 8GB
[SUCCESS] “Hac Pro” Asus z97 Sabertooth mark II, i7 4790k, xfx AMD 280x


ricky7's Build: Asus Z97 Sabertooth Mark II - i7-4790K - XFX R9 280X

Components


Asus Z97 Sabertooth Mark II USB 3.1 Motherboard
Intel Core i7-4790K Processor
XFX Double Dissipation AMD 280X Boost Graphics Card
Fenvi 802.11AC Wifi BCM94360CD Desktop Wireless PCIe card
Corsair Carbide Series Air 540 Computer Case
Corsair Hydro Series H100i GTX High Performance Liquid CPU Cooler CW-9060021-WW
Corsair RM Series 850 Watt PSU
Crucial Ballistic Elite 16GB (8GBx2) Memory Kit DDR3 1866 (BLE2KIT8G3D1869DE1TX0)
Samsung EVO 120 SSD
Samsung EVO 250 SSD

Western Digital 3.5 Blue 1TB 7200rpm Hard Drive


Comments

First of all this forum is the only reason I could have ever gotten this computer to work, so thank you all so much!!

Quick back story. (skip if you like, it doesn't have anything important for the build) I have a small video business and have been using my MacMook Pro with Final Cut Pro X for a while to edit and render video. Well, after rendering a particularly difficult video in Final Cut Pro X, my computers CPU monitor warned me that my CPU has hit 105 degrees centigrade. When I tried to clear this warning, the computer just shut down. I let it cool, restarted it, and set it on top of a box fan. It worked, but would still get to 85 to 90 degrees, a little hot in my opinion. I bought laptop fans and a couple desk fans and just pointed them at my computer while I worked, but it just didn't seem like a permanent solution.

So, I started look at Mac Pros. Having used Premier and Final Cut, I prefer Final Cut, thus, the Mac I had to stay on my list. But, even refurbished they were too expensive for me. I ran the numbers and decided I could build something nearly equivalent for about $1500 vs the $3000 base price for a new Mac Pro. I also liked the fact that I could build a machine with specifically chosen parts to be a Windows beast (I'm an engineering student and use Solid Works a lot) as well as a beast for video editing on OS X. I sure did underestimate the work but I can finally tell you that it all works! Mostly!

The Build:

Building was pretty easy and I won’t go in depth there are a lot of tutorials out there on how to build a machine. I will however mention a few important points.

First of all make sure your ram is in the right place. This Asus motherboard has very specific locations for where to put the ram. Follow the instructions.

Second of All if you buy this power supply the fan won’t spin. Don't be alarmed its made to do that. If your worried get corsair link or tape a sensor on it to monitor it but I swear its made to do that.[

Third, don’t forget that pesky USB cable for the water cooler. I forgot it and was very concerned when the pump didn't turn on. Just read the instructions (do as I say not as I do).

Fourth, if you get the Fenvi WiFi card, it does have a little USB plug as well hidden in the packaging under the card. The instructions are in Chinese. So, unless you can read Chinese, here's what you do. Remove the protective plate on the PCI express mounting location on your case. Plug it into an available PCI express slot on your motherboard, plug the little USB header into the card and into an available slot on your motherboard. Screw in the mounting bracket to the case. Remove the rubber plugs and screw in the antennas and you're done.


The First Boot and BIOS settings:
For whatever reason the CPU fan doesn't get recognized on Asus motherboards if you use this watercooler. It’s an easy fix though. Just enter the BiOS by hitting F1 and go to advanced. There’s a Gfan tuning button. In the BIOS, go to Advanced->Monitor->Gfan tuning. Click it and let it run. You'll see all your fans spin up, then turn off, and then run normally. Go back to EZ Mode then save and exit. If it happens again, repeat the process and it'll usually work on the second go around if it doesn't on the first.

The BIOS on this board was a pain. I played with all kinds of settings, but finally found a combination that works. Unlike tonymacx96's guide, if you have an Asus motherboard with this graphics card booting with other OS selected doesn't help. It turns out that using windows UEFI is the way to go but make sure you go to Advanced->Boot->Secure Boot-> Delete Secure Boot Keys. This is the only thing that seemed to work. with this combination. Save and Exit again.

Next, you need to set up the graphics. It will not boot from the thumb drive with the graphics card (except in Safe Mode, but then you can’t mount your EFI or use MultiBeast) In the BIOS go to Advanced->System Agent Configuration-> Graphics Configuration->Change Graphics from Auto to CPU Graphics. Save and exit again. Now, unplug your video cable from the graphics card and plug it into your motherboard. If nothing pops up on your screen reboot, it just means you didn't switch the cable fast enough.

Summary:Load optimized defaults. Run Gfan to fix CPU fan error. Delete Secure Boot Keys. Switch to Internal Graphics and reboot.

Installing OSX El Capitan:
I’m guessing if you're reading this you’ve already read the tonymacx86 Guide's installation instructions, if not go read it. Follow those steps, but when you get to graphics injection, don't inject anything, no Intel, no ATI nothing. We will worry about that later. I recommend unplugging all but the installation hard drive It will make things easier later. Make your boot drive is plugged in and boot form the UniBeast USB thumb drive. Front IO ports won’t work and rear 3.0 and 3.1 ports won’t work for booting, so plug it into a USB 2.0 plug. Install El Capitan, reboot and then boot from the hard drive. It usually seemed to freeze on me, but give it a couple minutes and it’ll boot.

MultiBeast and Clover Configurator:
Here’s the setup. Just follow it. Also quick fix here too, if you don't inject Intel network drivers the Apple Mac App Store won’t work. Don't really know why. I only tried injecting both, I haven't injected just one and tried how it works, but injecting both doesn't seem to hurt anything.
Screen Shot 2016-01-13 at 7.32.52 PM.png
Now download clover configurator. (If you have the WiFi card, its automatically supported so just connect to WiFi). The settings you need to change are as follows. If you like to see how things boot select verbose mode in boot (not necessary). Important: under graphics select Inject ATI and Load VBios. This is where things get a little more advanced. XFX cards are not supported by OS X (sometimes one works but its super rare). Therefore, you need to add a patch hence load VBios. Asus cards are supported so download the VBios for the Asus 280x card. Make sure all specs are the same or as close as possible to your XFX card. This is where I downloaded mine: “https://www.techpowerup.com/vgabios/145837/asus-r9280x-3072-130828.html” You will now need to change the name of the VBIOS, which will have a series of numbers then .rom. You will need to change the name so it says “[vendornumber]_[deviceid].rom”. The vendor number is XFX’s vendor number. The device ID is that particular devices id. I got mine by doing graphics info in Windows 8.1. I believe it is on the box as well but I don't know for sure. It will look something like this “1002_6798.rom”. Move it onto your EFI partition in EFI->Clover->ROM. Save everything and reboot. Enter bios and change your graphics back to auto. It will not change to PCIe so just leave it as auto it doesn't seem to have any issues. Reboot and plug your HDMI cable back into your graphics card. If you get a black screen reboot again and select the OS on your hard drive. It should work! If it doesn't comment and I’ll try to help!

Random Information:
As I said earlier, the purpose of this computer is to be a video editing machine. I downloaded Final Cut, and it works great(I'll add render time comparisons later). Well, since this is a video machine, I wanted redundant storage. Sadly, they removed it from disk utility. I looked at other software but I didn't like any of them. I also tried to use Asus’s built into the motherboard, but then OS X doesn't boot any longer so leave it off. Turns out, they only removed it from the GUI. Its actually still included in full functionality. Open terminal and use diskutil which is apples advanced disk utility system, its simply hidden now. Type diskutil for help and refer to this link for a detailed description of everything included. “https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/man8/diskutil.8.html” Also for Final Cut add your main files into this raid array. Then if you have a small boot hard drive you can use this for all your storage.

Windows
I installed Windows first, but you can do it second. Unplug your mac hard drive. I tried to install both on the same hard drive and I couldn't get it to work. My recommendation is just pony up for a second hard drive. It ends up being a lot easier. You can get a cheap disk drive for 30 bucks, it doesn't need to have a lot of storage if you don’t plan on adding a lot of material. If you want speed the go for a solid state. Do a standard windows install and install all drivers. Again there are a lot of descriptions on how to do this. The hard part is getting the WiFi and Bluetooth card to work. Put in the disk included with the WiFi card. There are 3 folders and an application. Ignore the application. One of the folders is called something with the word Bluetooth in it. Open this folder and then click the executable. It'll put the Bluetooth drivers in the right place and Bluetooth will work. Next is the wireless. The other folder has something with the name WLAN. There is no executable in it to install the drivers so instead you need to open device manager. Once open, under unsupported devices you will see wifi card. Right click on it and you'll see an install driver button. Open it and use the GUI to work through manually selecting driver location. Use the WLAN file on the disk and let it run. Once done WiFi should be up and running! Again if there are any problems comment, and I’ll help out!

Current Problems (HELP!):
If you got this far I commend you, sorry this is a long description. Here’s what doesn't work yet.

Rear audio ports don't work but my front IO does. Fixed

Also I get this weird screen flicker about every 10 minutes. Happens once then goes away. It just flickers once (too fast to see what it says but it looks like just my desktop) and then operates just fine afterwards. Fixed

Only one usb 3.0 port works. Found a potential fix, will update if it work. Fixed

If anyone has any ideas let me know in the comments!

CONGRATULATIONS YOU’RE DONE!

UPDATES:

Update 1:Just ran geek bench (didn't pay for it so its only a 32 bit score)Here are my results: http://browser.primatelabs.com/geekbench3/4899751
Single core: 3910
Multi core: 14977
Compared to Genuine 4 core mac pro: https://browser.primatelabs.com/geekbench3/4895216
Single core:3275
Multi core:13043
The only thing it didn't compare well with was the mac pros memory speed, which is excepted as this machine uses 16 gigs currently where the Genuine mac has 64 gigs.

Update 2: Fixed rear audio. Turns out the inputs on the motherboard register as outputs in OS X settings. Just select "rear audio" and plug it in. Blue port works best reason being is in windows you can program the blue port to be an output instead of an input so when I switch between mac and windows I don't have to plug the plug back in somewhere else.

Update 3: Using rehabmans instructions I have gotten 3 of the 4 USB 3.0 ports working. The only one that doesn't work is the one that is shared with the bios boot function, I wonder if theres a correlation however I can not confirm there is. Follow rehabmans recommendations for x 7/8/9 series motherboards and it should work. This includes renaming in clover, adding fakePCIID.kext, and FakePCIID_XHCIMux.kext as well as performing the patch as described for usbinjectall If you follow these you'll get at least 3 ports working. However I am yet to achieve full 3.0 speeds.
With OS X Sierra add -uia_exclude_hs bootflag
 
Last edited:
Joined
Jan 22, 2011
Messages
32
Motherboard
ASUS SABERTOOTH Z97 MARK 2
CPU
i7-4790K
Graphics
RX 6800
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello Ricky7, I want to thank you for the Installation Guide of El Capitan in this configuration. if it were not for you I would not have succeeded.

What works:
Front USB (2.0): Works
Rear USB (2.0): Works
Rear USB (3.0): Works but not at full speed
Rear USB (3.1): does not work
Front and rear audio: works perfect
Ethernet: works
System Definition: iMac 27¨ Late 2013 (System Definition Mac Pro 6.1 did not work)

Currently using Mac OS X 10.11.3

My Hackintosh: iMac 27¨- SABERTOOTH Z97 MARK 2/USB 3.1 - i7 4790K - GeForce GTX 970


Thanks again.

Alf.
 

Attachments

  • SCORE.jpg
    SCORE.jpg
    133.9 KB · Views: 300
Joined
Feb 2, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
This helped me a lot. I have a XFX R9 280, and followed your directions and loaded an MSI vbios (renamed it 1002_479A.rom), and did the same modifications in Clover.

Awesome. You saved me a lot of time. :)
 
Joined
Dec 30, 2015
Messages
83
Motherboard
Asus z97 Sabertooth Mark II
CPU
i7-4790k
Graphics
ASUS ROG STRIX 480x 8GB
Great to hear! Glad I was able to help! As for USB I have been following RehabMan's guide, and, so far, it has worked for most ports but the USB 3.0/BIOS flashback as well as the USB 3.1 ports still do not work. However, the other USB 3.0 port now works, as well as the 2 front USB 3.0 ports. I have not tested speeds yet but its a step in the right direction.

Here are RehabMan's directions. Link. So far, I used kext beast to install facePCIID.kext and FakePCIID_XHCIMux.kext. I added the renames in Clover for EHC1 to EH01 and EHC2 to EH02 as well as adding the USB inject all patch. I am currently working on the final port, but so far no luck. As for USB 3.1, it appears the only software that has it enabled on mac so far is the MacBook, however there is no SMBIOS that lets you choose that, so 3.1 might be a lost cause at this point sadly. Hopefully, an update will come soon enough! Good luck!
 
Last edited:
Status
Not open for further replies.
Top