Contribute
Register

[Success] Gigabyte Z490M Gaming X - i9 10850K - RX580 - OpenCore 0.6.6 4k - Big Sur - Video Editing

Joined
Feb 11, 2014
Messages
34
Motherboard
Gigabyte DZ490m Gaming X
CPU
i9-10850K 3.6 GHz 10-Core
Graphics
Radeon RX 580 8 GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Afuera's Gigabyte Z490m Gaming X Hackintosh (Video Editing FCPX and Adobe Suite Machine)
Gigabyte DZ490m Gaming X - i9-10850K - AORUS Radeon RX 580 8GB



IMG_2474.jpg





Components:
Screen Shot 2021-02-07 at 15.09.14.png


Comments:
Believe me, I was scared of switching from Clover to a completely "unknown world" of OpenCore. With this build I Updated/replaced my Ga-X56a-Ud5 Intel Xeon W3680 (6 cores) Hack from 2010. I wanted a not too expensive upgrade and to be able to have a fast stable machine to edit FCPX 4k video, Photos and Design. Something more powerful than my imac i9-9900K 2019 and a m1 Apple Mini.

Reading and trying to understand OpenCore took me a couple of weeks and I thought it was going to be a long process with many tries. But this end up being a less than a day project of understanding and doing it... It was completely worth it and easy. WHAT A CHANGE! Everything works as expected and this machine is faster than my 2019 Imac!

BIOS:
Disable:
  • Fast Boot
  • Secure Boot
  • VT-d (can be enabled if you set DisableIoMapper to YES)
  • CSM
  • Intel SGX
  • Intel Platform Trust
  • CFG Lock (MSR 0xE2 write protection)(This must be off, if you can't find the option then enable both AppleCpuPmCfgLock and AppleXcpmCfgLock under Kernel -> Quirks. Your hack will not boot with CFG-Lock enabled)
Enable:
  • VT-x
  • Above 4G decoding
  • Hyper-Threading
  • Execute Disable Bit
  • EHCI/XHCI Hand-off
  • OS type: Windows 8.1/10 UEFI Mode
  • DVMT Pre-Allocated(iGPU Memory): 64MB
  • SATA Mode: AHCI
  • Primary Graphics Adapter: PCIE
  • Share Memory: 64MB
  • IGPU Multi-Monitor: Enabled (this keeps the iGPU enabled even when a graphics card is detected)

Installation Notes:
I chose this parts because I read on the forums that they are really compatible to run MacOS. This Motherboard/CPU/GPU/WIFI combo work with almost any tweaking. The process was really easy.


Installation:

Dortania's Guide
made this process posible. Follow this, is long (for some is new) but it is super detailed, clear and easy to follow. https://dortania.github.io/OpenCore-Install-Guide/

@nazrm guide was key with USB MAP: https://www.tonymacx86.com/threads/success-gb-z490m-10-5-7-i7-10700k-5700xt-opencore.300519/

Once you have Downloaded BIGSUR, created a bootable USB, Edited the EFI, added the EFI (you can use mine attached IF YOU HAVE THE SAME MOTHERBOARD/GPU/CPU will have no issues) in the installing USB.

Insert the USB you have created following the Dortania's Guide, at the boot picker chose "instal...mac os.." wait until the installer, watch the verbose mode run through... and wait fot the installer menu, Format you SSD m.2 with disk utility (m.2 should be GUID partition Scheme and APFS). Install and wait for the first RESTAR, after the first Restart pick "Your disc name" on the boot menu and not the "Installer... macOS..." the installation will continue, then it will restart again, some more verbose and patience and the Boom you are in. Don't freak out with the 2-3 restarts the process does.

macos-big-sur-installer copy.jpg



Post Installation:
After the installation, the Post installation is incredibly easy, basically: Mount you USB EFI, copy your USB´s EFI (with all your opencore work) and place it on the desktop. Eject the USB´s EFI and then mount your system EFI, copy the EFI folder to you System's EFI. That's it.

Summary:

Running OpenCore 0.6.6 on Big Sur 11.2

This build is fast and reliable enough to be my main Editing/Working machine. No complaints whatsoever, not to fancy, not to expensive and with that fluidity of a powerful built that allows you concentrate on your creativity.

What Works:
  • Ethernet via IntelMausi.kext
  • Intel onboard audio
  • GPU: Hardware Acceleration
  • Airdrop
  • Imessagge/Facetime/Icloud
  • Sleep / Wake / Shutdown
  • Wifi / BT
  • USB3.2 / USBC / FRONT USB3 at full speed
  • Dual Monitor
  • SSD m.2
What Does Not Work:

Can't find anything really






Screen Shot 2021-02-07 at 14.36.05.png
 

Attachments

  • config.plist
    13.8 KB · Views: 109
  • EFI.zip
    2.3 MB · Views: 155
Last edited:
Joined
Dec 2, 2010
Messages
49
Motherboard
Gigabyte Z490 Gaming X
CPU
I7-10700K
Graphics
RX 580
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
Afuera's Gigabyte Z490m Gaming X Hackintosh (Video Editing FCPX and Adobe Suite Machine)
Gigabyte DZ490m Gaming X - i9-10850K - AORUS Radeon RX 580 8GB​
...​
Hi, OP,

I have Catalina installed successfully. But the Ethernet can't be recoganized. I have the IntelMausi.kext in the kext folder as well.

What did I do wrong ?
 

Attachments

  • config.plist
    15 KB · Views: 14
  • EFI.rar
    1.6 MB · Views: 17
Joined
Feb 11, 2014
Messages
34
Motherboard
Gigabyte DZ490m Gaming X
CPU
i9-10850K 3.6 GHz 10-Core
Graphics
Radeon RX 580 8 GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Hi, OP,

I have Catalina installed successfully. But the Ethernet can't be recoganized. I have the IntelMausi.kext in the kext folder as well.

What did I do wrong ?
Hello, maybe you can update to the new "IntelMausi.kext" the EFI and config.plist you attached have the "IntelMausiEthernet.kext" your config.plist is very different to mine. I don´t use the FakePCIID.kext either.
 
Last edited:
Joined
Dec 2, 2010
Messages
49
Motherboard
Gigabyte Z490 Gaming X
CPU
I7-10700K
Graphics
RX 580
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
Yes, you are right. I went through the guide and make one myself. It's all working now.

Thanks for your reply.
 
Joined
Feb 9, 2021
Messages
25
Motherboard
MSI Z490 Gaming Plus
CPU
i9-10850K
Graphics
Intel > Need version > See Rules!
Yes, you are right. I went through the guide and make one myself. It's all working now.

Thanks for your reply.
What did you do to get it working? I am new at this and have internet connection but cannot connect, plus my VRAM is only reading 7Mb... can you help?
 

Attachments

  • EFI.zip
    12 MB · Views: 12
  • config.plist
    26.4 KB · Views: 10
Joined
Dec 2, 2010
Messages
49
Motherboard
Gigabyte Z490 Gaming X
CPU
I7-10700K
Graphics
RX 580
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
First, go to https://opencore.slowgeek.com/ to check your config.plist. I checked. Most of them are fine. There are some fields you might want to look into it.

"have internet connection but cannot connect" -- do you mean you don't get IP address?
 
Joined
Feb 9, 2021
Messages
25
Motherboard
MSI Z490 Gaming Plus
CPU
i9-10850K
Graphics
Intel > Need version > See Rules!
First, go to https://opencore.slowgeek.com/ to check your config.plist. I checked. Most of them are fine. There are some fields you might want to look into it.

"have internet connection but cannot connect" -- do you mean you don't get IP address?
I checked that and everything was green"good to go". Yes ,I do not get an IP address. I have to enter it manually then it says connected but I cannot get online, says no internet connection.. On my old 2009 iMac it gives me a router options where my PC install does not
 
Joined
Dec 2, 2010
Messages
49
Motherboard
Gigabyte Z490 Gaming X
CPU
I7-10700K
Graphics
RX 580
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
This sounds like a post installation software issue. Can you share the screen of your network panel?
 
Joined
Feb 9, 2021
Messages
25
Motherboard
MSI Z490 Gaming Plus
CPU
i9-10850K
Graphics
Intel > Need version > See Rules!
This sounds like a post installation software issue. Can you share the screen of your network panel?
is this what you want to see?
 

Attachments

  • Screen Shot 2021-02-15 at 9.09.33 AM.png
    Screen Shot 2021-02-15 at 9.09.33 AM.png
    96.7 KB · Views: 91
  • Screen Shot 2021-02-15 at 9.08.47 AM.png
    Screen Shot 2021-02-15 at 9.08.47 AM.png
    106.7 KB · Views: 90
Top