Contribute
Register

[Success] GIGABYTE Z370 Gaming 7 + Intel Core i7-8700K + RX 580 + (2x) Dell P2715Q 4k @ 60Hz

Joined
Jun 15, 2012
Messages
418
Motherboard
Z370 AORUS Gaming 7 - F11
CPU
i7-8700K OC @ 5.1Ghz
Graphics
GTX 1080 Ti
Mac
MacBook Pro, Mac Pro
Classic Mac
Performa
Mobile Phone
iOS
Doing some testing and review, the Intel exploit press release today, is patched by microcode version B4 (180) for 8700K. I did some checking of macOS microcode version and with 10.14.5 or 10.13.6 with security update installed,
sysctl -a | grep microcode does indeed return "180".

If you are interested in installing the MCU through BIOS update itself, per usual https://www.win-raid.com/t3217f44-OFFER-Gigabyte-GA-Z-Aorus-Gaming-BIOS-mod.html has it already. F13 Update 2 has latest microcode update versions that mitigate against https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00233.html . Although make sure you have RTC ACPI patch that enables versions above F11 to actually be bootable in macOS.

Also note, you don't need to do this, it just means macOS won't need to software patch it on boot cause it'll exist in hardware. My testing of macOS is that it only loads software microcode if it's newer than hardware one, if hardware one is newer it loads instead. In this particular instance, right now the modified BIOS and latest security updates are both version 180 (for Coffee Lake 8700K anyways, it'll be diff based on CPUID)
 
Last edited:
Joined
Oct 30, 2013
Messages
7
Mac
Classic Mac
Mobile Phone
Hello all, I seem to be stuck on step 7 setting up the sound. I followed the steps as explained and don't seem to have success. Starting from the beginning I get stopped at the same spot.

Is it possible that the current AppleALC.kext and Lilu.kext files need to be within a specific version range to work? 1.2.1 AppleALC and Lilu audio files were available when this post was first released, up to version 1.35 as of currently.

Any help would be appreciated as I haven't had to build a Hackintosh for so long! And holy crap Clover Configurator has come a long way.
 
Joined
Nov 3, 2017
Messages
196
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
Hello all, I seem to be stuck on step 7 setting up the sound. I followed the steps as explained and don't seem to have success. Starting from the beginning I get stopped at the same spot.

Is it possible that the current AppleALC.kext and Lilu.kext files need to be within a specific version range to work? 1.2.1 AppleALC and Lilu audio files were available when this post was first released, up to version 1.35 as of currently.

Any help would be appreciated as I haven't had to build a Hackintosh for so long! And holy crap Clover Configurator has come a long way.
I have AppleALC v1.3.6 and Lilu v1.3.5 and sound is working great, running Clover v2.4k_r4920.
 
Top