[SUCCESS] Gigabyte GA-Z270-Gaming K3 + (Gigabyte Nvidia GeForce 210) now Sapphire ATI Radeon RX580

Not open for further replies.
Jan 26, 2012
Gigabyte GA Z270 Gaming K3
RX 580
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
My Setup
  • Motherboard: Gigabyte GA-Z270-Gaming K3 (rev. 1.0)
  • CPU: Intel Core i5-7600K (with CPU Cooler Noctua NH-U9S)
  • RAM: 2x8GB Ballistix Sport LT BLS2C8G4D240FSCK @2400
  • Harddrive: Samsung SSD 850 EVO 500GB
  • Graphics: Gigabyte GeForce 210 (PCIe) [removed as of 07/03/2019]
  • Graphics: Sapphire ATI Radeon RX580 (8GB) [installed as of 07/03/2019]
  • Soundcard: RME AIO (PCIe)
  • DSP Card: UAD Solo (PCIe)
  • USB: all ports working [configured properly as of 03/07/2019 see here]
  • SATA: all ports working
  • Ethernet (Killer E2500 LAN chip): works
  • PCIe Bus: all slots working (tested with GeForce 210, RME AIO and UAD)
  • Sleep, Wake: works (for GeForce 210 in Clover configurator provide: darkwake=1 [this is not required with Sapphire RX580])
  • Graphics: Dual Heading works (with GeForce 210, in Clover only provide: nvda_drv=1, that's all! Don't use web drivers or anything else!!! [this is not required with Sapphire RX580])
  • Graphics: Internal Graphics Intel HD630 deactivated
  • Graphics: Internal Graphics Intel HD630 in BIOS activated, used as internal only [as of 07/03/2019]
  • Hibernation: not tested yet
  • HDMI Sound: not tested yet
  • Audio: Realtek ALC1220 not installed (b/c of running RME AIO. To make ALC running ppl are coding tons of things since 10 yrs. Check here for details.)
  • Feb/2018: This is a stable installation of Sierra 10.12.6. I had to read a few pages here and there, but it was a lot more simple than my EP35DS3 10yrs ago, where I even set my DSDT. I had to replace the EP3DS3 now, b/c of Ableton 10's requirements.
  • Jul/2019: Update to 10.13.6 went smooth.

0. UEFI BIOS Preparation
  • System (BIOS Version): F8 F9D [as of 07/31/2019 see here]
  • System (BIOS Date): 07/06/2017
  • BIOS (Windows 7/10 Features): Other OS
  • BIOS (Storage Boot Option Control): UEFI
  • Peripherals (Initial Display Output): PCIe 1 Slot (or whatever slot you installed your graphics card into)
  • Peripherals (Onboard LAN Controller): Enabled
  • Peripherals (USB 3.0 DAC-UP 2): Normal
  • Peripherals/USB Configuration (Legacy USB Support): Enabled
  • Peripherals/USB Configuration (XHCI-Hand-Off): Enabled
  • Peripherals/USB Configuration (USB Mass Storage Driver Support): Enabled
  • Peripherals/SATA and RST Configuration (SATA Controllers): Enabled
  • Peripherals/SATA and RST Configuration (SATA Mode Selection): AHCI
  • Peripherals/SATA and RST Configuration (Aggressive LPM Support): Enabled
  • Chipset (VT-d): Disabled Enabled [as of 07/03/2019 see here]
  • Chipset (Internal Graphics): Disabled Enabled for Intel QuickSync Purposes [as of 07/03/2019 see here]
  • Chipset (Audio Controller): Disabled (you may try to get this running, but it was just not needed by me)
  • Power (Platform Power Management): Disabled Enabled [as of 11/03/2018]
1. Installation
  • created bootable pen drive with UniBeast (version 7.1.1)
  • used USB 3.0 for the pen drive (only the red USB 3.0 port on the back works during installation, otherwise take the USB 2.0 ports, but that takes much longer)
2. Post Installation

2.1. MultiBeast configuration
(get version 9.2.1 here):
  • Quick Start: UEFI Boot Mode
  • Drivers (Disk): Intel Generic AHCI SATA
  • Drivers (Misc): FakeSMC v6.25-333-g05e0f4be.1759
  • Drivers (Misc): FakeSMC Plugins v6.25-333-g05e0f4be.1759
  • Drivers (Misc): FakeSMC HWMonitor Application v6.25-333-g05e0f4be.1759
  • Drivers (Misc): NullCPUPowerManagement v.1.0.0d2
  • Drivers (Network): AtherosE2200Ethernet v.2.2.1
  • Drivers (USB): Increase Max Port Limit 200 Series
  • Bootloaders: Clover v2.4k r4173 UEFI Boot Mode
  • Customize (Graphics Configuration): Inject NVDIA (only!!!)
  • Customize (SSDT Options): (none)
  • Customize (System Definitions): iMac 14,2 (you change this in clover configurator to 18,3)
  • then click '''Build'''
2.2. Clover Configurator:
  • Tools (Mount EFI): Mount the EFI Partition where MultiBeast installed your UEFI Clover boot loader into
  • You should consider updating Clover before moving on.
  • Open: EFI (partition) -> EFI -> Clover -> config.plist
  • ACPI (Fixes): FixShutdown (needs to be enabled, otherwise shutdown too often just reboots) **new 03/11/2018 [removed as of 07/03/2019]
  • ACPI (Generate Options): Generate PStates, Generate States, APSN, APLF
  • Boot (Arguments): darkwake=1, dart=0, nvda_drv=1 [removed as of 07/03/2019]
  • SMBIOS (Up/Down Arrows, on the right): select iMac 14,2 iMac18,3 [with ATI Sapphire RX580 as of 07/03/2019]
  • SMBIOS (Serial Number): click "Generate New" or better go here and create proper SMBIOS entries.
  • Save config.plist and reboot. You should be good to go...

// minor updates (03/11/2018):
// - Shutdown had issues (FixShutdown had to be enabled in Clover Configurator)
// - I also updated to TonyMac's latest Clover installer (version 4411), provided here
// - in contrast to the first attempts, in the meantime I also enabled the Platform Power Management in BIOS (see above).
// some more updates (07/03/2019) see here and
// some more updates (07/31/2019) see here (because of random freeze issues)
Last edited:
As an addendum:

if you decide to use that crappy "Migration Assistant" for migrating a Chameleon/Chimera based Hackintosh to a Clover based system, get ready for tons of issues and a non booting system (even if it was running perfectly ten seconds ago).

What does "Migration Assistant" do to our systems what we even remotely don't need:
  • it moves the deprecated "/Extra" folder with all its contents to the Clover based system, which screws up your system, because Clover tries to use what it finds in "/Extra" (you'll see after reboot). Unless you don't have a fallback installation to repair your main installation you would be done here. Neither Safe mode nor single user mode can be booted...
  • it moves tons of old outdated kexts to the "/System/Library/Extensions" folder. So even if you need them, you'd better move them to "/Library/Extensions" (which is the right place for all third party kernel extensions). So I wish you much fun, going fishing for kexts to remove. As said: I hope you have a fallback installation of the very same system to compare the contents of the folders.
  • it moves the "/Library/Audio" with all its entirely outdated plugins to your new system without asking, thus making your DAW unstable
I will never use that Migration Assistant anymore, that's for sure...
Last edited:
Sorry for not getting back any earlier, I had issues with my account here.

I am not sure, if sharing the EFI folder is allowed, since I don't know about all the license types. I attach a screenshot for you. I hope this helps... I don't use anything fancy...

See here: #7


  • Screen Shot 2019-05-04 at 20.18.05.png
    Screen Shot 2019-05-04 at 20.18.05.png
    118.2 KB · Views: 385
Last edited:
So in the meantime, I tried to make iCloud working and had to learn, that iCloud, iMessage seem to require a working NVRAM and valid SMBIOS entries, which were not the case on my system. iCloud allowed me to ask for 2 factor auth, but eventually didn't login on the hackintosh.

1. NVRAM EFI driver
After reading here and there I found an NVRAM driver on this German forum: (by vit9696 and Download-Fritz). I don't have any clue why this driver is called OsxAptioFix2Drv-WTH.efi but it works.

2. Proper SMBIOS definitions
I also had to rework the SMBIOS definitions. This article helped a lot:

As you can see I use iMac18,3 as product name. This is due to the fact that I switched the graphics to ATI Sapphire RX580.


  • Bildschirmfoto 2019-07-05 um 22.28.09.png
    Bildschirmfoto 2019-07-05 um 22.28.09.png
    249.7 KB · Views: 420
  • Bildschirmfoto 2019-07-05 um 22.32.46.png
    Bildschirmfoto 2019-07-05 um 22.32.46.png
    47.1 KB · Views: 341
Last edited:
A couple of other additions:

1. VT-X
In order to re-enable VT-X on this board's UEFI settings, I added DMAR signature to DROP TABLES in clover configurator. Found here:

2. USB Stability
I had to learn, that port patches that increase the amount of available USB-ports to more than 15 are not recommended. System stability is at stake then. For getting USB stable and close to vanilla I followed this approach:
Some minor DSDT patches must be applied (see picture: XHC1 to XHC and XHCI to XHC and see SSDT-USB.aml in the attachment and some ports have to be removed that are just not allowed to work in order to fulfil Apple's USB-Port limit of 15: uia_exclude=HS05;HS06;HS09;HS10;SS05;SS06;USR1;USR2 see picture).

3. CPU SpeedSteps
Works ok. I could not manage to get the CPU stable down to 800MHz, so I decided to stay with Clover Generate Options: Generate PStates, Generate CStates, APSN, APLF. (see picture). I removed NullCPUPowerManagement.kext from the EFI kexts folder.

4. Graphics
I updated to High Sierra 10.13.6 and replaced the nVidia with the Sapphire ATI Radeon RX580. Together with LILU and Whatevergreen, everything works perfectly, as long as I plug the screens to the Sapphire card. I turned on the internal Intel HD630 in the BIOS for video encoding and decoding purposes (see Intel Power Gadget picture).

5. Thermic issues
The CPU went up to 85degrees celsius. The Zalman cooler obviously does not fit my demands. I replaced it with the Noctua NH-U9S. Temperature is now down to 62degrees celsius.


  • Bildschirmfoto 2019-07-05 um 22.06.38.png
    Bildschirmfoto 2019-07-05 um 22.06.38.png
    306.7 KB · Views: 371
  • Bildschirmfoto 2019-07-05 um 22.33.54.png
    Bildschirmfoto 2019-07-05 um 22.33.54.png
    85.3 KB · Views: 371
  • SSDT-USB.aml
    658 bytes · Views: 291
  • Bildschirmfoto 2019-07-05 um 22.34.44.png
    Bildschirmfoto 2019-07-05 um 22.34.44.png
    30.3 KB · Views: 362
  • Bildschirmfoto 2019-07-05 um 22.35.58.png
    Bildschirmfoto 2019-07-05 um 22.35.58.png
    37.5 KB · Views: 380
  • Bildschirmfoto 2019-07-05 um 23.05.40.png
    Bildschirmfoto 2019-07-05 um 23.05.40.png
    43.6 KB · Views: 392
Last edited:
as of 07/11/2019:
- Kexts


    438.3 KB · Views: 319
    328.8 KB · Views: 323
After having had a lot of those random freezes/crashes (with mouse ball spinning, sound distortion, completely unresponsive and so on, no usable kernel messages in log) I almost tried everything (creating rock solid SMBIOS definitions allowing for iCloud & iMessage; configuring USB properly; installing new NVme, AMD GX580, unplugging all SATA-drives).

It often occurred while watching sth. on Youtube, listening to NAS streamed music in iTunes or while making music on my own (Ableton Live / Cubase / Reason). It occurred no matter if I used WhatEverGreen or configured the GFX manually. It also had no impact if I chose to enable the internal Intel HD630 or not.

It looks like, that eventually I solved this issue by updating the BIOS. Newer BIOS revisions contain Intel Microcode Updates... I'll keep you posted, if the issues are gone now, or if this party is too early. Last step will be to buy a new CPU.

Links to random freeze issues:
// edit 08/09/2019
// Now running the system for more than 6wks absolutely stable, that means…
// the thesis of having had microcode issues before upgrading the BIOS firmware is confirmed.
// edit 21/10/2019
// System still running rock solid. Catalina on 2nd hard drive for testing purposes already works stable


  • Bildschirmfoto 2019-07-31 um 13.46.01.png
    Bildschirmfoto 2019-07-31 um 13.46.01.png
    103.1 KB · Views: 401
Last edited:
Can you share your last config.plist?
Not open for further replies.