Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Sep 20, 2013
Messages
1,112
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Our saved presets are fortunately not cleared after CMOS Reset, so we can certainly reload them.
Where are they saved? I think that there may be long-term corruption in the saved setups, and I'd like to wipe them out, if possible. Thanks.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,816
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Where are they saved? I think that there may be long-term corruption in the saved setups, and I'd like to wipe them out, if possible. Thanks.
We can either overwrite them or re-flash the BIOS.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,816
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
OK, sounds like I may have to go the fresh install route. I think I may just get some new NVMe SSD before I do the upgrade. I will go through the restore process to get back to par. Once I do that, can you recommend some instructions to install Monterey clean and possible migrate my data/applications.
Sure; at the top of Post 1, in the spoiler labeled Quick Reference to Mini-Guides and Micro-Guides, please have a look at this guide. Although it's for Big Sur, the same procedure applies to Monterey. Because you already have a configured OpenCore 0.8.3 EFI folder, the task is simplified.

Screenshot 2022-08-10 at 10.18.54 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,816
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** OpenCore Configurator 2.62.0.0 has been released **
Open the "Preferences" dialog and set it to 0.8.3 Release Configuration as shown​

If you're using OpenCore 0.8.3 and seeing OCS Schema: LegacyEnable warnings during boot, simply open your config.plist in OpenCore Configurator 2.62.0.0, ensure that the application is set to "0.8.3 Release Configuration", then click through each of the main headings on the left side without making any changes :

  • ACPI
  • Booter
  • DeviceProperties
  • Kernel
  • ...
Then save the file (CMD-S). On reboot, the LegacyEnable warning will disappear.
Screenshot 2022-08-10 at 1.00.31 PM.png
 
Last edited:
Joined
Aug 25, 2012
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
Regarding Bluetooth:
  • Have you tried a CMOS Reset?
    • This is done by shutting down the system, flipping power switch on PSU to OFF (yes, to OFF), then shorting the two designated pins on motherboard for about 3 seconds with a flathead screwdriver or other metal (conductive) object.
    • Then we flip power switch on PSU back to ON and boot the system. It should take you to BIOS Setup. We start with Load Optimized Defaults, then we configure the remaining BIOS parameters per Post 1.
    • At the OpenCore boot picker we can press and hold CTRL key while selecting the macOS boot volume. That will make it the default startup disk on future reboots.
    • Then see if Bluetooth behavior has improved...
Just did a CMOS reset, but to no avail. Exactly the same problems. iPhone can't connect via Bluetooth, continuity etc. doesn't work, BT is shot after sleep. I can connect to a BT speaker without problems. Before sleep, that is. After sleep, I can reset BT by switching it off/on.

Weird. Are people using BT without issues under Monterey? Sleep and wake are no problem?

BT info looks OK?

Bluetooth Controller:

Address: A4:5E:60:C4:8B:84

State: On

Chipset: BCM_20703A1

Discoverable: Off

Firmware Version: v169 c4825

Product ID: 0x0001

Supported Devices: 0x382039 < HFP AVRCP A2DP HID Braille AACP GATT Serial >

Transport: USB

Vendor ID: 0x004C (Apple)
 
Joined
Jul 21, 2016
Messages
334
Motherboard
Gigabyte Z690 Aero G
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Weird. Are people using BT without issues under Monterey? Sleep and wake are no problem?
@zipb

I don't use BT with my Designare Z390 which has the Fenvi FV-T919 card installed. But to see if my hack also had problems with BT, I just checked both Monterey and the latest Ventura public beta to see if my iPhone SE with current iOS would connect via BT. It would pair and for a second or two show "Connected," then immediately disconnect.

If I repeatedly retry to "Connect" the iPhone, it would show "Connected," but instantaneously disconnect.

So I confirm your BT problem with the Designare. I also tried BT with my Z690 Aero G which has a Broadcom BCM94360NG Key A/E M.2 WiFi/BT module replacing the Intel WiFi module and it exhibits the same problem with Big Sur, Monterey, and public beta 3 Ventura. Maybe my iPhone model is a factor.

Since I don't use BT, I don't have time at this point to work the issue.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,816
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@zipb

I don't use BT with my Designare Z390 which has the Fenvi FV-T919 card installed. But to see if my hack also had problems with BT, I just checked both Monterey and the latest Ventura public beta to see if my iPhone SE with current iOS would connect via BT. It would pair and for a second or two show "Connected," then immediately disconnect.

If I repeatedly retry to "Connect" the iPhone, it would show "Connected," but instantaneously disconnect.

So I confirm your BT problem with the Designare. I also tried BT with my Z690 Aero G which has a Broadcom BCM94360NG Key A/E M.2 WiFi/BT module replacing the Intel WiFi module and it exhibits the same problem with Big Sur, Monterey, and public beta 3 Ventura. Maybe my iPhone model is a factor.

Since I don't use BT, I don't have time at this point to work the issue.
Although I have never tried to pair my iPhone to any Mac, I use various Continuity features and all seem to work well as long as both devices are on the same iCloud account.

I use AirDrop quite frequently to send photos from iPhone to Hackintosh. I also use Handoff, Continuity Clipboard, Continuity Markup, ApplePay on Hackintosh with iPhone for authentication, and phone/SMS integration.

Once in a while it may be necessary to (a) reboot the iOS device, and/or (b) logout of iCloud on all devices and log back in.
 
Joined
Aug 25, 2012
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
Although I have never tried to pair my iPhone to any Mac, I use various Continuity features and all seem to work well as long as both devices are on the same iCloud account.

I use AirDrop quite frequently to send photos from iPhone to Hackintosh. I also use Handoff, Continuity Clipboard, Continuity Markup, ApplePay on Hackintosh with iPhone for authentication, and phone/SMS integration.

Once in a while it may be necessary to (a) reboot the iOS device, and/or (b) logout of iCloud on all devices and log back in.
And no weirdness after sleep? I just woke my Hack and had a kernel panic (ionetworking family whathaveyou...) I had BT switched off.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,816
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
And no weirdness after sleep? I just woke my Hack and had a kernel panic (ionetworking family whathaveyou...) I had BT switched off.
Just tried AirDrop before and after sleep: I also needed to disable and re-enable Bluetooth after waking from sleep. No kernel panics. AppleVTD is enabled.
 
Top