Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jun 13, 2013
Messages
36
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
XFX Merc 319 6900 XT Limited Black
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Hi guys,

I have happily been running a Z390 Designare for the last 2.5 years and have been very happy with the overall stability of my system, all of course due to this thread and CaseySJ :) So thank you very much for that!

I upgraded my GPU to a XFX 6900XT Speedster MERC 319 Limited Black (geez, can they think of any other names to add to that mouthful!) Problem is that the chipset is a slight variant, the XTXH (Device ID 0x73AF).

I am running Monterey on OC 0.74 and it all seems to work fine as I am using a piece of code in the config.plis to spoof the GPU. I am trying to upgrade to 0.77 but if I copy the bits and pieces required to spoof my GPU from a XTXH (0x73AF) to a XTX (0x73BF), I just cant get it to work?

I am using CaseySJ's 0.77 template as I have always done, but I must be doing something wrong.

Would anyone be kind enough to cast an eye over my working 0.74 config.plist and the non working 0.77 config.plist? I can boot the system but there is no hardware acceleration.

Thanks so much in advance :)

loiphin


Been hackintoshing since 2005 (Mac OS X Tiger 10.4 Intel leak) :)
 

Attachments

  • Z390.zip
    10.2 KB · Views: 32
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi guys,

I have happily been running a Z390 Designare for the last 2.5 years and have been very happy with the overall stability of my system, all of course due to this thread and CaseySJ :) So thank you very much for that!

I upgraded my GPU to a XFX 6900XT Speedster MERC 319 Limited Black (geez, can they think of any other names to add to that mouthful!) Problem is that the chipset is a slight variant, the XTXH (Device ID 0x73AF).

I am running Monterey on OC 0.74 and it all seems to work fine as I am using a piece of code in the config.plis to spoof the GPU. I am trying to upgrade to 0.77 but if I copy the bits and pieces required to spoof my GPU from a XTXH (0x73AF) to a XTX (0x73BF), I just cant get it to work?

I am using CaseySJ's 0.77 template as I have always done, but I must be doing something wrong.

Would anyone be kind enough to cast an eye over my working 0.74 config.plist and the non working 0.77 config.plist? I can boot the system but there is no hardware acceleration.

Thanks so much in advance :)

loiphin


Been hackintoshing since 2005 (Mac OS X Tiger 10.4 Intel leak) :)
Hello @loiphin,

The two config files are identical in the areas that concern GPU device-ID spoofing. Which version of WhateverGreen are you using in 0.7.4 and in 0.7.7?

If you boot again with 0.7.4, do you see RX 6900 XT listed in About this Mac?
 
Joined
Jan 19, 2022
Messages
1
Motherboard
Gigabyte Z390 DESIGNARE
CPU
Intel Core i9-9900K
Graphics
AMD Radeon Pro WX 7100
Hello, I'm going to do a fresh install to update from Mojave to Catalina. I used your Mojave give for the install. As I'm reviewing the Catalina guide, I'm confused as to which parameters have to be set. What parameters? I'm still learning about building so sorry if this seems like an dumb question. Thanks for the help!
Set BIOS parameters according to main guide in Post #1.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello, I'm going to do a fresh install to update from Mojave to Catalina. I used your Mojave give for the install. As I'm reviewing the Catalina guide, I'm confused as to which parameters have to be set. What parameters? I'm still learning about building so sorry if this seems like an dumb question. Thanks for the help!
Hello @AHrndz,

Welcome to the forum. If you're asking about BIOS parameters, simply click here and open the spoiler corresponding to the BIOS version running on your motherboard. We recommend BIOS F9g or F9i. The most important guides are the ones highlighted in red:
Screen Shot 2022-01-23 at 10.44.36 AM.png



Screen Shot 2022-01-23 at 10.42.42 AM.png
 
Joined
Jun 13, 2013
Messages
36
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
XFX Merc 319 6900 XT Limited Black
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Hello @loiphin,

The two config files are identical in the areas that concern GPU device-ID spoofing. Which version of WhateverGreen are you using in 0.7.4 and in 0.7.7?

If you boot again with 0.7.4, do you see RX 6900 XT listed in About this Mac?
Thank you for taking a look @CaseySJ. It would have been the same version as what was in your 0.74 pack that you released.

But I plucked up the courage and ended up flashing an XTX BIOS, and now your 0.77 config works out of the box. Thanks @byteminer :)

And thank you CaseySJ :)

loiphin.
 
Joined
Aug 1, 2012
Messages
550
Motherboard
Asus ProArt Z690 Creator
CPU
i7-12700KF
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  • This allows a real Mac's drives to be mounted to a Hackintosh as if they were local drives. Only a real Mac can be the "host", but now for the first time a Hackintosh can be the "client" that connects to the host.
https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.316533/post-2095044

@CaseySJ do you know how to start an OC Machine with ALT+T so that the machine starts correctly in Target mode? Apparently even correctly selected the Target Mode option, the hackintosh restart in the same way as normal boot.
 

Attachments

  • Schermata 2022-01-23 alle 11.45.41.png
    Schermata 2022-01-23 alle 11.45.41.png
    126.4 KB · Views: 32

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Joined
Jan 1, 2020
Messages
1
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i7-9700K
Graphics
UHD 630
I was stupid and upgraded to the F9 BIOS on the Gigabyte webpage. Now I'm having trouble with unstable Thunderbolt. My UAD is responding as well as it used to, and Apogee Ensemble randomly reconnects. Is there any way to downgrade the BIOS?
 
Joined
May 15, 2020
Messages
1,320
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
I was stupid and upgraded to the F9 BIOS on the Gigabyte webpage. Now I'm having trouble with unstable Thunderbolt. My UAD is responding as well as it used to, and Apogee Ensemble randomly reconnects. Is there any way to downgrade the BIOS?
Unfortunately there's no simple way to downgrade
You have to flash an old version manually by serial communication
 
Joined
May 25, 2020
Messages
37
Motherboard
GIGABYTE Z390 DESIGNARE
CPU
i9-9900K
Graphics
RX 580
@CaseySJ thanks for truly phenomenal work on this one!
Would you be able to eloborate on "Going the Extra Mile" for Pro Audio app users? Many of the explanations seem to center around video/graphic apps, rendering, etc. I'm curious to hear what the recommended settings would be for Pro Audio App users (Logic Pro X) on Catalina.
Thanks!
 
Top