Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Apr 2, 2020
Messages
71
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Is the Bluetooth dongle plugged into your Apple keyboard? Have you tried moving it to a USB port directly on the rear IO panel (preferably a black USB 2.0 port)?
referably a black USB 2.0 port)?
Yes, the dongle is plugged into my good old Apple keyboard.
I tried on different port including the rear IO panel without any luck.
Maybe it is time for me to try your intel-wireless EFI ?
Is it more reliable now ? and can I enable Bluetooth and keep my wifi card ?
Or do I have to physically remove it ?
Thanks.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,480
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes, the dongle is plugged into my good old Apple keyboard.
I tried on different port including the rear IO panel without any luck.
Maybe it is time for me to try your intel-wireless EFI ?
Is it more reliable now ? and can I enable Bluetooth and keep my wifi card ?
Or do I have to physically remove it ?
Thanks.
Intel Bluetooth does not currently work in Monterey.

If you already have a Fenvi FV-T919, both Bluetooth and WiFi should work natively. Are you experiencing any problems with that card?
 
Joined
Apr 2, 2020
Messages
71
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
I am not using a Fenvi FV-T919 unfortunately.
I am using a TP-LINK TL-WDN7280 for my wifi and a dongle for my Bluetooth.
It is fixed.
Sorry, I haven't slept enough and I've quit coffee, so it might happen again.
I did not saved my SSD boot order yesterday, so I was booting on OpenCore 7.2 instead of 7.6 :banghead:
Now everything is working flawlessly.
A big thank you as usual.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,480
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** OpenCore 0.7.7 EFI for Z390 Designare **
Supports Mojave, Catalina, Big Sur, and Monterey
Please do not quote this post in its entirely. Use a link instead.

Also available from HackinDROM

** NOTE **
Mojave and Catalina Users: Please see "Post-Update Procedure" below.

Please use OpenCore Configurator 2.56.0.0 and ensure that it's set to
0.7.7 Release Version

When using OpenCore Configurator, ensure that only one EFI partition is mounted​


Windows Users:
If you are unable to boot Windows through OpenCore, try disabling AppleVTD by following the bottom half of this post.

Monterey -- What Does Not Work:
  • Intel I-211 Ethernet port driven by SmallTreeIntel82576 is not working at this time. The other Ethernet port (I-219) is fully operational. If a second Ethernet port is needed, options include:
    • USB to Gigabit Ethernet adapter
    • USB to 2.5GbE Ethernet adapter
    • USB-C dock with built-in Ethernet port
    • Thunderbolt dock with built-in Ethernet port
    • Apple Thunderbolt to Gigabit Ethernet adapter (requires AppleVTD to be enabled)
  • Laird BT851 Bluetooth 5.0 USB dongle not working at this time.
  • If Monterey is installed on Samsung NVMe SSDs, boot time can increase by 60-100 seconds due to "trim" incompatibilty.
    • This can be addressed by cloning the Samsung NVMe SSD to another disk, erasing the Samsung NVMe SSD with Disk Utility, and cloning macOS back. Please be careful with this process if you decide to do it.
  • Crucial P2 NVMe SSDs (only P2 series) also suffer from trim issues in Monterey.

This Update Includes:
  • OpenCore 0.7.7
  • AppleALC 1.6.8
  • Lilu 1.5.9
  • WhateverGreen 1.5.6
  • RestrictEvents 1.0.6
  • OpenIntelWireless ZIP:
    • IntelBluetoothFirmware 2.1.0
    • IntelBluetoothInjector 2.1.0 (not used in Monterey)
    • AirportItlwm 2.1.0 for Mojave, Catalina, Big Sur, Monterey
Instructions:
  • Download appropriate ZIP file below and follow these instructions to configure config.plist.
  • If "Resizable BAR Support" is enabled in BIOS, set ResizableAppleGpuBars to 0 in Booter quirks.
  • Copy EFI folder to EFI partition of USB flash disk and boot from USB flash disk.
  • Ensure that REL-077-xxx appears on bottom right corner of OpenCanopy Picker.
  • If everything is okay, mount the EFI partition of USB flash disk and internal macOS SSD, then copy EFI folder from USB flash disk to internal macOS SSD.
Things to Test or Check:
  • Any OCS or other warnings before OpenCore picker appears?​
  • Does macOS boot properly?​
  • Does Bluetooth work? Can you enable and disable Bluetooth?​
  • Does Bluetooth work if you (a) boot into Windows and then (b) boot into macOS without doing a cold start?​
  • If you use "Resizable BAR Support" in Windows, try enabling that in BIOS and check if macOS boots properly.​

Catalina and Mojave Users:
  • Set SecureBootModel to Disabled.
    Screen Shot 2022-01-14 at 5.21.42 AM.png


Issues:
Screen Shot 2022-01-15 at 10.52.10 AM.png



Which File to Download:
  • Broadcom WiFi/BT (such as Fenvi FV-T919) --> OC-077-DESIGNARE-Z390.zip
  • Intel WiFi/BT --> OC-077-DESIGNARE-Z390-INTEL-WIRELESS.zip
Reminder:
  • Radeon VII and Vega 56/64 users must disable or remove boot argument agdpmod=pikera.

Updates:
  • 14-Jan-2022: First version
 

Attachments

  • OC-077-DESIGNARE-Z390.zip
    8.4 MB · Views: 222
  • OC-077-DESIGNARE-Z390-INTEL-WIRELESS.zip
    71.4 MB · Views: 164
Last edited:
Joined
Sep 20, 2013
Messages
1,099
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Is this for me @jiffyslot ?
This is for anyone who needs F9i for the Z390 Designare since Gigabyte removed that version. I was lucky to have a backup after F9j became problematic. I am distrustful of any BIOS that does not allow reversion, but that's just me.
 

Attachments

  • Z390DESIGNARE.F9i.zip
    6.8 MB · Views: 48
Joined
May 10, 2014
Messages
10
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Update done !
All works fine but i have now 3 warning OCS.
OCS: NO schema For AudioOut at 2 index, context <audio> !
OCS: NO schema For MinimumVolume at 4 index, context <audio> !
OCS: NO schema For VolumeAmplifier at 8 index, context <audio> !

I do not use the internal sound card, work with a RME Fireface 802.

Thanks CaseySJ
 
Joined
Jun 27, 2019
Messages
34
Motherboard
Gigabyte Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Just updated to OC 0.7.7 and everything works well.
Thanks Casej
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,480
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Update done !
All works fine but i have now 3 warning OCS.
OCS: NO schema For AudioOut at 2 index, context <audio> !
OCS: NO schema For MinimumVolume at 4 index, context <audio> !
OCS: NO schema For VolumeAmplifier at 8 index, context <audio> !

I do not use the internal sound card, work with a RME Fireface 802.

Thanks CaseySJ
Because the OpenCore config.plist format (called "schema") changed between 0.7.6 and 0.7.7, please let me know how you performed the update:
  • With HackinDROM?
  • Or by downloading the EFI zip file and importing PlatformInfo credentials?
 
Top