Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
No, wifi doesn't work in any case with 0.7.5. the router assign the ip to the hack via dhcp but the network is unreachable, the same thing happens with 0.7.6.
Now I can reach the network because I connected the hack to the router via wired
This shows that the problem is not due to OpenCore. Also, at this time I think your Fenvi might be okay. If it had a hardware problem, it would not even get an IP address.

Have you tried disabling or deleting Little Snitch?

Another suggestion:
  • Boot into Recovery. Press space bar at OpenCore boot loader GUI and choose Recovery.
  • Disconnect Ethernet cable.
  • Then select Safari from the main window that appears.
  • Does WiFi work?
 
Last edited:
Joined
Jun 27, 2019
Messages
35
Motherboard
Gigabyte Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
This shows that the problem is not due to OpenCore. Also, at this time I think your Fenvi might be okay. If it had a hardware problem, it would not even get an IP address.

Have you tried disabling or deleting Little Snitch?

Another suggestion:
  • Boot into Recovery. Press space bar at OpenCore boot loader GUI and choose Recovery.
  • Disconnect Ethernet cable.
  • Then select Safari from the main window that appears.
  • Does WiFi work?
following your advice wifi works ....... grrrrrr i can't figure out where the problem is
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
following your advice wifi works ....... grrrrrr i can't figure out where the problem is
Does this mean:
  • WiFi works in Recovery?
  • WiFi also works in standard macOS?
  • Was it necessary to disable Little Snitch?
 
Joined
Jun 27, 2019
Messages
35
Motherboard
Gigabyte Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Yes, WiFi works in recovery;
WiFi doesn't work in standard MacOS;
I don't understand.

I can tell you the steps that I have done but that I have not understood:
1) update to Monterey 12.1 with Little Snitch disabled but installed, WiFi worked;
2) to test the system I rebooted the hack, Llittle Snitch disable but installed WiFi doesn't work;
3) removed Llittle Snitch and reboot the system, WiFi doesn't work;
4) connected the router to the hack by wired, logged to the router and changed the channel of the WiFi;
5) A Miracle happened, WiFi works both with static and dynamic IP.

In the end I'm not able to understand what was the matter, for now I stay with OpenCore 0.7.5. In the next days I will test OpenCore 0.7.6, and I would like to reinstall little snitch.

Thanks for the advice you gave me.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes, WiFi works in recovery;
WiFi doesn't work in standard MacOS;
I don't understand.

I can tell you the steps that I have done but that I have not understood:
1) update to Monterey 12.1 with Little Snitch disabled but installed, WiFi worked;
2) to test the system I rebooted the hack, Llittle Snitch disable but installed WiFi doesn't work;
3) removed Llittle Snitch and reboot the system, WiFi doesn't work;
4) connected the router to the hack by wired, logged to the router and changed the channel of the WiFi;
5) A Miracle happened, WiFi works both with static and dynamic IP.

In the end I'm not able to understand what was the matter, for now I stay with OpenCore 0.7.5. In the next days I will test OpenCore 0.7.6, and I would like to reinstall little snitch.

Thanks for the advice you gave me.
Good thinking!
 
Joined
May 15, 2020
Messages
1,306
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Unfortunately, I haven't found a solution for the i211 Ethernet port. The SmallTreeIntel82576 driver does not work in Monterey. A workaround is to use a USB-to-Gigabit Ethernet adapter. If you have a USB-C Hub or Thunderbolt Dock, it most likely has a Gigabit Ethernet adapter.
You could try the "old" AppleIGB Kext
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
You could try the "old" AppleIGB Kext
We found some issues with this, but it's certainly worth re-testing:
  • Ethernet port does not resume after wake-from-sleep
  • If Ethernet cable is hot plugged or hot unplugged, system may crash
 
Joined
May 15, 2020
Messages
1,306
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
We found some issues with this, but it's certainly worth re-testing:
  • Ethernet port does not resume after wake-from-sleep
  • If Ethernet cable is hot plugged or hot unplugged, system may crash
Could you test and post crash logs please

Also if anyone can test this kext on i210 please let me know
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Could you test and post crash logs please

Also if anyone can test this kext on i210 please let me know
Sure... I've compiled the kext and installed it successfully. This is being posted from i211 port on Z390 Designare in Monterey 12.1.
Screen Shot 2021-12-14 at 10.41.20 AM.png
Screen Shot 2021-12-14 at 10.41.47 AM.png

Now to check for reliability issues... No connection after wake-from-sleep:
Screen Shot 2021-12-14 at 10.46.45 AM.png
 

Attachments

  • AppleIGB.kext.zip
    61.6 KB · Views: 18
Joined
Oct 17, 2013
Messages
289
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
I would like to ask now that I cannot have a decent speed through i211 on Monterey between my 2x Designares, is there any other way to connect the 2 systems and be able to map Lacie 2BiG Tb3 through this connection just like I did it through LAN? I thought it might work with a 2M TB3 cable,. But I don't have one ATM, and they are quite expensive. Maybe a USB type C cable?
 
Top