Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jun 27, 2019
Messages
35
Motherboard
Gigabyte Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Yes, WiFi works in recovery;
WiFi doesn't work in standard MacOS;
I don't understand.

I can tell you the steps that I have done but that I have not understood:
1) update to Monterey 12.1 with Little Snitch disabled but installed, WiFi worked;
2) to test the system I rebooted the hack, Llittle Snitch disable but installed WiFi doesn't work;
3) removed Llittle Snitch and reboot the system, WiFi doesn't work;
4) connected the router to the hack by wired, logged to the router and changed the channel of the WiFi;
5) A Miracle happened, WiFi works both with static and dynamic IP.

In the end I'm not able to understand what was the matter, for now I stay with OpenCore 0.7.5. In the next days I will test OpenCore 0.7.6, and I would like to reinstall little snitch.

Thanks for the advice you gave me.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,154
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes, WiFi works in recovery;
WiFi doesn't work in standard MacOS;
I don't understand.

I can tell you the steps that I have done but that I have not understood:
1) update to Monterey 12.1 with Little Snitch disabled but installed, WiFi worked;
2) to test the system I rebooted the hack, Llittle Snitch disable but installed WiFi doesn't work;
3) removed Llittle Snitch and reboot the system, WiFi doesn't work;
4) connected the router to the hack by wired, logged to the router and changed the channel of the WiFi;
5) A Miracle happened, WiFi works both with static and dynamic IP.

In the end I'm not able to understand what was the matter, for now I stay with OpenCore 0.7.5. In the next days I will test OpenCore 0.7.6, and I would like to reinstall little snitch.

Thanks for the advice you gave me.
Good thinking!
 
Joined
May 15, 2020
Messages
1,306
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Unfortunately, I haven't found a solution for the i211 Ethernet port. The SmallTreeIntel82576 driver does not work in Monterey. A workaround is to use a USB-to-Gigabit Ethernet adapter. If you have a USB-C Hub or Thunderbolt Dock, it most likely has a Gigabit Ethernet adapter.
You could try the "old" AppleIGB Kext
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,154
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
You could try the "old" AppleIGB Kext
We found some issues with this, but it's certainly worth re-testing:
  • Ethernet port does not resume after wake-from-sleep
  • If Ethernet cable is hot plugged or hot unplugged, system may crash
 
Joined
May 15, 2020
Messages
1,306
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
We found some issues with this, but it's certainly worth re-testing:
  • Ethernet port does not resume after wake-from-sleep
  • If Ethernet cable is hot plugged or hot unplugged, system may crash
Could you test and post crash logs please

Also if anyone can test this kext on i210 please let me know
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,154
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Could you test and post crash logs please

Also if anyone can test this kext on i210 please let me know
Sure... I've compiled the kext and installed it successfully. This is being posted from i211 port on Z390 Designare in Monterey 12.1.
Screen Shot 2021-12-14 at 10.41.20 AM.png
Screen Shot 2021-12-14 at 10.41.47 AM.png

Now to check for reliability issues... No connection after wake-from-sleep:
Screen Shot 2021-12-14 at 10.46.45 AM.png
 

Attachments

  • AppleIGB.kext.zip
    61.6 KB · Views: 18
Joined
Oct 17, 2013
Messages
289
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
I would like to ask now that I cannot have a decent speed through i211 on Monterey between my 2x Designares, is there any other way to connect the 2 systems and be able to map Lacie 2BiG Tb3 through this connection just like I did it through LAN? I thought it might work with a 2M TB3 cable,. But I don't have one ATM, and they are quite expensive. Maybe a USB type C cable?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,154
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I would like to ask now that I cannot have a decent speed through i211 on Monterey between my 2x Designares, is there any other way to connect the 2 systems and be able to map Lacie 2BiG Tb3 through this connection just like I did it through LAN? I thought it might work with a 2M TB3 cable,. But I don't have one ATM, and they are quite expensive. Maybe a USB type C cable?
Hello @skroutz999

If you were using a wired Ethernet connection between the two Designare systems, it is still possible to connect them via a USB-to-Ethernet adapter. We can use:
  • USB Type A to Gigabit Ethernet adapter
  • USB Type C to Gigabit Ethernet adapter
  • USB Type A to 2.5GbE adapter
  • USB Type C to 2.5GbE adapter
The first two are 1 gigabit adapters that are about US$15.
The second two are 2.5 gigabit adapters that are about US$20 to US$30.

Regarding the Lacie 2BIG TB3 device, only a Thunderbolt cable will be compatible. A USB-C cable without the "lightning" logo will not work.
 
Joined
May 15, 2020
Messages
1,306
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Sure... I've compiled the kext and installed it successfully. This is being posted from i211 port on Z390 Designare in Monterey 12.1.

Now to check for reliability issues... No connection after wake-from-sleep:
Sorry I havent followed your previous experimentations with this kext
  • have you tried to kextunload un reload it back ? (even dont know if it is still possible in theses new macOSs)
  • What about setting DHCP manually ?
  • What happens when you unplug and replug ethernet cable?
  • Can you see any info about "wake-from-sleep issue" in Console.app ?
 
Last edited:
Top