Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,
I couldn't see this on the first post, so I'm probably not the first to ask, but I can see that there's a new BIOS available, F9: https://www.gigabyte.com/Motherboard/Z390-DESIGNARE-rev-10/support#support-dl

It seems to address some major vulnerabilities. Have you tested it? It seems if you upgrade to it, there's no going back. I had issues with Thunderbolt on F9j, so I'm afraid I'll have it on F9 too.
Thanks for reminding me! This came up last week, but I did not update the top of Post 1. Will do that now.

Meanwhile, my advice is not to upgrade to this new BIOS. @canyondust upgraded his Z490 Vision D to the new capsule BIOS and it's been successful, but that does not mean the same will happen on Z390 Designare.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, Caseysj, thanks for your interest.
Yes, I would try again OpenCore 0.7.6. Here below there is the IOReg file.
Apologies for the late reply... IOReg shows that WiFi is working properly. Is it actually working? Was this generated after booting from OpenCore 0.7.6?
Screen Shot 2021-12-12 at 10.14.28 AM.png
 
Joined
Jun 27, 2019
Messages
35
Motherboard
Gigabyte Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Hi, CaseSJ! The IOReg was created last time the WiFi worked with 0.7.6, too. After that, also with 0.7.5, WiFii doesn't work.
The strange thing is that WiFi works with a cell phone as a hot spot.
In any case here below there is a IOReg with wifi active bat not functional, booted with 0.7.6.
I hope you will be able to help me.
Thanks
 

Attachments

  • mario’s iMac (2).zip
    5.2 MB · Views: 15

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, CaseSJ! The IOReg was created last time the WiFi worked with 0.7.6, too. After that, also with 0.7.5, WiFii doesn't work.
The strange thing is that WiFi works with a cell phone as a hot spot.
In any case here below there is a IOReg with wifi active bat not functional, booted with 0.7.6.
I hope you will be able to help me.
Thanks
It still looks okay. Please try a cold start, like this:
  • Shutdown the computer.
  • Flip power switch on PSU to OFF for about 10 seconds.
  • Power back up.
  • Boot macOS and check if WiFi connects to your wireless network.
  • Also try turn WiFi off and on again from the menu bar.
Screen Shot 2021-12-12 at 1.36.43 PM.png
 
Joined
May 31, 2016
Messages
991
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Thanks for reminding me! This came up last week, but I did not update the top of Post 1. Will do that now.

Meanwhile, my advice is not to upgrade to this new BIOS. @canyondust upgraded his Z490 Vision D to the new capsule BIOS and it's been successful, but that does not mean the same will happen on Z390 Designare.
For clarity, my MB is a Z490 Vision G
 
Joined
May 3, 2020
Messages
76
Motherboard
GIGABYTE Z590 Vision D
CPU
i9-10850K
Graphics
RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Step 5: Program Modified Firmware into the Flash Chip.
  • Be sure that you have followed Step 4 and kept a copy of the original firmware.
  • Locate the modified firmware and program it into the chip as follows:
Code:
% sudo flashrom -p ch341a_spi -w Name_of_Modified_Firmware.bin
  • This will (a) erase the chip, (b) program new firmware into the chip, and (c) verify the new content.

(All photos except the first taken handheld on iPhone 11 Pro Max.)
Hi, I'm going to flash a Titan Ridge that I have for a computer in my studio. And I am seeing that there are different firmware for the GC Titan Ridge. One is the modification of elias and casey, and another is that of d2m. Which should be convenient to use?
 
Joined
Apr 24, 2019
Messages
16
Motherboard
Z390 Designare
CPU
i7-8700K
Graphics
UHD 630
CaseySJ hi.
Do you have a solution for this "Designaire USB randomly stops working"?
Mojave

Thanks.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
CaseySJ hi.
Do you have a solution for this "Designaire USB randomly stops working"?
Mojave

Thanks.
If you are using a number of USB 2.0 devices, please see if this post helps:
 
Joined
Jun 27, 2019
Messages
35
Motherboard
Gigabyte Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
It still looks okay. Please try a cold start, like this:
  • Shutdown the computer.
  • Flip power switch on PSU to OFF for about 10 seconds.
  • Power back up.
  • Boot macOS and check if WiFi connects to your wireless network.
  • Also try turn WiFi off and on again from the menu bar.
View attachment 537072
Hi, CaseySJ! I did everything you recommended to me, but without resolution of the problem.

I have also disassembled and reassembled the fenvi card, without resolution, I have reset NVRAM, too. But the result is always the same; the WiFi doesn't work connected to the router. At this point I believe is a problem of the Fenvi card.
I am only perplexed by the fact that the hack obtain a correct IP from the router, and the router works because I connect the cell phone to it without a problem.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, CaseySJ! I did everything you recommended to me, but without resolution of the problem.

I have also disassembled and reassembled the fenvi card, without resolution, I have reset NVRAM, too. But the result is always the same; the WiFi doesn't work connected to the router. At this point I believe is a problem of the Fenvi card.
I am only perplexed by the fact that the hack obtain a correct IP from the router, and the router works because I connect the cell phone to it without a problem.
Do you have any firewall, virus protection, or other Internet security software installed?
 
Top