Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Apr 4, 2014
Messages
90
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Because I am no longer familiar with Clover, I cannot answer that question. As you can guess, I recommend OpenCore.

Ok, so I got stuck with Clover so took a look at OpenCore again. Stupid me had forgotten to put in the SMBIOS device name (iMac19,1). With that done, the complete install of Monterey went without any hickups. That was with my Vega 64 card in, however.

The next thing I've done is to take out the Vega card and put in my new 6900 XT. I can tell that hardware acceleration is not active as I get glitchy graphics with "inverted" colors and the wrong name for the GPU in "About this Mac". I've done some digging around the forum and also elsewhere, but to be sure I'm using the latest/best method to get it working I'm thinking I might as well ask here.

I have a Merc 319 card.

These are my current boot args:
keepsyms=1 debug=0x100 alcid=11 shikigva=80 igfxfw=2 -v agdpmod=pikera

What's the best current way to fix it?

Thanks!
 
Last edited:
Joined
Apr 4, 2014
Messages
90
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Just to add a note: I have the XFX MERC 315 6900XT and it works flawlessly out of the box on 11.6.1 ... I've had an occasional red flash on window resizing but that's by far not a dealbreaker.

This is interesting as I have the exact same card, but I don't get hardware acceleration... I'm on Monterey though.

Correction: I’m on 319, you 315, my bad.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
This is interesting as I have the exact same card, but I don't get hardware acceleration... I'm on Monterey though.

Correction: I’m on 319, you 315, my bad.
What is the Device ID of your 6900 XT? I’m wondering if it’s 0x73AF instead of 0x73BF. System Information —> Graphics/Displays might show you this.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Bifurcate.... bifurcate... such a funny word. Like, "the price of that MacPro made me bifurcate all over myself!"
LOL! I had the same initial reaction. Fortunately PCIe bifurcation is present in Z490 Vision D, Z590 Vision D, and Z690 Aero G. It’s fairly common nowadays, but isn’t present in Z390 Designare.
 
Joined
Apr 13, 2021
Messages
6
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX 580
I would not recommend such cards on the Z390 Designare because:
  • BIOS does not have a feature called "PCIe Bifurcation". This allows the lanes in a PCIe slot to be split into multiple 4-lane "virtual" slots.
  • This Asus card accommodates up to 4 PCIe NVMe SSDs. Each NVMe SSD works best when it's given 4 PCIe lanes.
  • In a x16 slot, all 4 NVMe SSDs can operate at full speed if the BIOS can bifurcate the slot into x4/x4/x4/x4.
  • If not, then it's best to check the instructions or technical specs of the card to see how it deals with cases where fewer PCIe lanes are available, and cases where bifurcation is simply not available.
You can see that Asus makes this quite clear on their website:

View attachment 536182
Thanks. I was reading on my phone and must have missed this. I also probably got excited by the possibility and rushed through this.

BTW, I have an RME FF400 working perfectly via FW400 to FW800 (9pin to 6pin) cable, to a FW to TB adapter, to TB to TB3 (USB-C) adapter. not ideal, but I get to keep my precious FF400.
 
Joined
Jan 5, 2019
Messages
119
Motherboard
Gigabyte Z390 Designare
CPU
i7-8700K
Graphics
RX 580
Trying to update to OpenCore 0.7.5, system will boot and almost immediately follow login it would restart to a problem screen. Rolling back to 0.7.4 and all is good. I'd triple checked all of the platform info, I did notice processor type was 3841 on oc 0.7.4. I've tried 0 and 3841 and they lead to same issue. Have I missed a bios change or something similar? I've seen this same type of reboot to an immediate error press any key or wait screen on native Mac when there is a hardware issue.
 
Joined
May 23, 2017
Messages
90
Motherboard
Designare z390
CPU
i9-9900k
Graphics
Vega64
Mac
  1. iMac
LOL! I had the same initial reaction. Fortunately PCIe bifurcation is present in Z490 Vision D, Z590 Vision D, and Z690 Aero G. It’s fairly common nowadays, but isn’t present in Z390 Designare.
Yeah, I used to BIFURCATE the slots on my old z170, that is…until the wife caught me.
 
Joined
Oct 9, 2013
Messages
130
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Two small images, just to show that Clover is not dead yet !! (although I also use OC 0.7.5) :) Configuring Clover remains simpler (in my opinion) than OpenCore !!
 

Attachments

  • Capture d’écran 2021-12-04 à 07.31.55.png
    Capture d’écran 2021-12-04 à 07.31.55.png
    83.4 KB · Views: 34
  • Capture d’écran 2021-12-04 à 07.33.30.png
    Capture d’écran 2021-12-04 à 07.33.30.png
    126.6 KB · Views: 32
Joined
Apr 4, 2014
Messages
90
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
What is the Device ID of your 6900 XT? I’m wondering if it’s 0x73AF instead of 0x73BF. System Information —> Graphics/Displays might show you this.

Correct, it's "0x73af".

Do I need to flash it per:


:shifty:
 
Last edited:
Top