Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Apr 4, 2014
Messages
90
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
To another question and request for advice.

I'm currently on Clover 5122 and macOS 10.15.7. I've recently bought a Radeon 6900 XT, which is one of the reasons I now want to upgrade to macOS Monterey.

What is the best course of action to go about doing this?

I'm extremely happy with my current system. It's setup exactly the way I want it and it's very stable. I also have dual boot with Windows setup on a separate SSD which is working great. I want to make this transition as painless as possible, so how do I do it best?

  • Should I transition from Clover to OpenCore? Or is it now possible to upgrade Clover on this system?
  • Can I upgrade to Monterey on top of my current install or is it definitely better to do a clean install? (and then use TimeMachine restore)
  • Depending on what you guys suggest, are there any links to guides/info that I need that you could direct me to?
  • Anything else I should think about regarding the Radeon 6900XT? My plan is to keep my current Vega 64 inside the computer while doing all the updating and then swap the card when all that is done. Does that sound like a good plan?
Thanks a bunch guys/gals!!
 
Joined
Oct 9, 2013
Messages
130
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
To another question and request for advice.

I'm currently on Clover 5122 and macOS 10.15.7. I've recently bought a Radeon 6900 XT, which is one of the reasons I now want to upgrade to macOS Monterey.

What is the best course of action to go about doing this?

I'm extremely happy with my current system. It's setup exactly the way I want it and it's very stable. I also have dual boot with Windows setup on a separate SSD which is working great. I want to make this transition as painless as possible, so how do I do it best?

  • .../... Or is it now possible to upgrade Clover on this system
If you want to continue using Clover (which is still a good choice from my point of view - I use OpenCore 0.7.5 or Clover 5142 indefinitely) you will have to update it in its 5142 version (with update day of UEFI drivers - OpenRuntime.efi in particular) and kexts as usual ...
It will also be necessary to modify the config.plist, using Plist Editor for example, by adding a Quirk in the "Quirks" section:
Key: ResizeAppleGpuBars, Type: Number, Value: -1
and,
to install or update Monterey, using Clover configurator (imperatively 5.19.0.0) :
in the SMBIOS section: check Update Firmware Only (to keep the serial numbers, Board Serial Number, SmUUID, etc.)
In the drop-down menu located next to this box, choose your SMBIOS, in this way two new items will be entered: Extended Firmware Features and Extended Firmware Features Mask.

If you use an SMBIOS corresponding to a Mac equipped with the T2 chip, you will also need to enter a new item entitled HWTarget in the Rt Variables section.

The HWTarget corresponding to the SMBIOS “T2” used is found in this table: (do not use parentheses)

MacBookPro 15.1 (J680AP) 15.2 (J132AP) 15.3 (J780AP) & 15.4 (J213AP)
MacBookPro16.1 (J152FAP) 16.3 (J223AP) & 16.4 (J215AP) MacBookPro16.2 (J214KAP)
MacBookAir8,1 (J140KAP) & 8,2 (J140AAP)
MacBookAir9,1 (J230KAP)
Macmini8,1 (J174AP)
iMac20.1 (J185AP) & 20.2 (J185FAP)
iMacPro1,1 (J137AP)
MacPro7,1 (J160AP)

EDIT : I forgot to say that Clover remains the best bootloader for Dual Boot (with Windows and macOs)

Attached is an example of config.plist for iMacPro1,1
 

Attachments

  • config.plist.zip
    3.5 KB · Views: 25
Last edited:
Joined
Mar 30, 2019
Messages
15
Motherboard
GIGABYTE Z390 DESIGNARE
CPU
i7-9700K
Graphics
RX 580
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
To another question and request for advice.

I'm currently on Clover 5122 and macOS 10.15.7. I've recently bought a Radeon 6900 XT, which is one of the reasons I now want to upgrade to macOS Monterey.

What is the best course of action to go about doing this?

I'm extremely happy with my current system. It's setup exactly the way I want it and it's very stable. I also have dual boot with Windows setup on a separate SSD which is working great. I want to make this transition as painless as possible, so how do I do it best?

  • Should I transition from Clover to OpenCore? Or is it now possible to upgrade Clover on this system?
  • Can I upgrade to Monterey on top of my current install or is it definitely better to do a clean install? (and then use TimeMachine restore)
  • Depending on what you guys suggest, are there any links to guides/info that I need that you could direct me to?
  • Anything else I should think about regarding the Radeon 6900XT? My plan is to keep my current Vega 64 inside the computer while doing all the updating and then swap the card when all that is done. Does that sound like a good plan?
Thanks a bunch guys/gals!!
I asked CaseySJ this same sort of question not to long ago. I was in a similar predicament. He had me follow the migration to OpenCore and then went through these steps:

First I had to upgrade the BIOS and just modify these steps https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.316533/post-2284374

Then I went through these steps:
https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.316533/post-2284427

It has been extremely helpful and I am running Monterey fine. OpenCore appears to be much easier to maintain than Clover. I don't regret it.
 
Last edited:
Joined
Nov 22, 2011
Messages
126
Motherboard
z390 Designare
CPU
i9 9900k
Graphics
Radeon 6900xt
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Just a note for the Samsung SSD list:

SAMSUNG 950 PRO - NVRAM Picker broken
For the longest time I have been unable to get NVRAM to pick the right boot drive. I had the Samsung 950 PRO which functioned fine for the last two years but now that Samsung made the naughty list with TRIM I decided to finally upgrade to the WD SN750.

I made matching APFS containers as the previous drive, used Carbon Copy Cloner, and copy/pasted the EFI folder but found that the drive wasn't bootable for some reason. I made a new USB Installer to make sure the 6900xt had recovery support and dirty installed (no data wipe) Big Sur onto the new drive.

Presto, everything works, no data loss, and NVRAM finally works the way it is supposed too! :clap:

Also the WD SN750 is about 6x faster.
 
Joined
May 14, 2019
Messages
20
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Sapphire Pulse RX 5500XT 8GB
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all and @CaseySJ

After 8 months of neglecting OpenCore updates, I finally updated my system. This time using macOS Monterey on 970 Evo Plus SSD instead of macOS Big Sur on 970 Evo.

I did a clean install, I had OC 0.6.7 version and I followed each and every guide, used HackinDROM Copy Config option on the website (without the app) to copy configs to each successor version, though I think directly choosing the newest version would work but I wanted to do consecutive updates to the config (using OC 0.7.5 now). Used a USB stick to test out if OC boots Big Sur and then used the new SSD to test if Monterey will work and if there will be any issue with 970 Evo Plus SSD, due to the TRIM issue. Also reinstalled the latest Win10 to a new 970 Evo Plus SSD, so I have a dual-boot system (like before).


Overall, everything went really smooth. Monterey on 970 Evo Plus boots 20 seconds FASTER (~10s in total from OC Picker to macOS login screen) than Big Sur on 970 Evo. At least that's a relief for now, and the fact that almost everything works.

I just have one problem; Bluetooth works until the computer sleeps, then bluetooth stops working. System Preferences -> Bluetooth page is not responding or showing an empty device list or altogether an empty page. About Mac -> System Report -> Bluetooth shows the correct (i think?) information, and information for devices as well.

I know the problem is related to macOS Monterey and OpenCore 0.7.6 is around the corner, although I don't know if there will be any change for bluetooth in that update. Do you have any idea what should I try to make it work?

Again, many thanks for still answering to each and every post in the thread and trying newer boards as well. Respect!
 
Joined
Jan 21, 2018
Messages
252
Motherboard
Asus Z690 ProArt Creator
CPU
i9-12900K
Graphics
AMD RX 6900 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Just to add a note: I have the XFX MERC 315 6900XT and it works flawlessly out of the box on 11.6.1 ... I've had an occasional red flash on window resizing but that's by far not a dealbreaker.
Thanks.

I’ve read other posts of people using the 6900 XT without any problem. I tried everything I could imagined but I can't use it. It lags and freezes my system. I suspect my graphics card came defective. Tomorrow I will try to return it.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,104
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...
Overall, everything went really smooth. Monterey on 970 Evo Plus boots 20 seconds FASTER (~10s in total from OC Picker to macOS login screen) than Big Sur on 970 Evo. At least that's a relief for now, and the fact that almost everything works.
Glad to hear it!

I just have one problem; Bluetooth works until the computer sleeps, then bluetooth stops working. System Preferences -> Bluetooth page is not responding or showing an empty device list or altogether an empty page. About Mac -> System Report -> Bluetooth shows the correct (i think?) information, and information for devices as well.
...
Regarding Bluetooth:
  • Are you using a Fenvi FV-T919 or similar Broadcom-based module?
  • Are you instead using on-board Intel WiFi/BT?
  • In config.plist --> Kernel section, is BlueToolFixup enabled and configured correctly? If unsure, simply post a screenshot of OpenCore Configurator --> Kernel.
If you're on OpenCore 0.7.5 at this time, please ensure that OpenCore Configurator title bar says "OpenCore 0.7.5 Release Configuration".
 
Joined
Apr 4, 2014
Messages
90
Motherboard
GA-Z390-DESIGNARE
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks for this @YossarianKen44 !

I asked CaseySJ this same sort of question not to long ago. I was in a similar predicament. He had me follow the migration to OpenCore and then went through these steps:

First I had to upgrade the BIOS and just modify these steps https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.316533/post-2284374

Then I went through these steps:

It has been extremely helpful and I am running Monterey fine. OpenCore appears to be much easier to maintain than Clover. I don't regret it.
 
Joined
Jan 3, 2020
Messages
16
Motherboard
z390 designare
CPU
i9-9900k
Graphics
Vega 64
Hi guys,

Just upgraded to an overpriced Sapphire Nitro+ Rx 6900xt on my build, wondering if anyone out there can see gpu temps and processor use in istat menus (worked great on my old RX 580).
 
Joined
Mar 2, 2011
Messages
166
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
It does work when plugged into the F_USB, but not in BIOS or during boot.

I’m trying to plug it into a PCIe USB 2.0 card to the internal USB type A port it has. When I do that, Bluetooth works in BIOS / at boot, but fails to be enabled when I get to the desktop after booting.

It seems I need to set the respective port on the PCIe card to 255 with USBMap.kext

Does this sound like it should work? I’m messing around right now with a USB mapping script to create the kext.
Updates.

So I’ve been in a situation recently where a wired connection just isn’t possible at all. So, I’ve been forced to mess around to make this MQUPIN Fenvi T919 wifi/bt card work. Getting any other cards seems to be impossible in Canada right now.

In addition to plugging in the BT header to the F_USB on the motherboard, I ended up having to do the following combination of things to get it working fully and reliably.

1) I put the card in the 2nd PCIE long slot (between the 2 nvme slots) in order to get the Bluetooth working in bios and boot and after boot. No other slots would do this for me.

2) To get my wifi working without stalling and becoming unusable after booting, I added the latest AirportBrcmFixup kext and then removed the plugin, AirPortBrcm4360_Injector.kext inside the package (you can disable it instead) and added the country code and used brcmfx-driver=2 in my boot arguments (not sure if these were needed or not but I added them anyway).

To be safe, I also cleared NVRAM after moving the card and adding the modified kext and boot arguments for opencore.

Handoff, Airdrop, Sidecar, wifi and bt all work fine now for me.
 
Top