Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Sep 21, 2013
Messages
1,085
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Trouble started when I upgraded from Mojave to Big Sur 2-3 weeks ago. Lots of trouble with drivers that BS doesn't like/refuses to install properly without shoehorning with SIP off.

I just enabled VT-D 3 days ago, hard to say if this made matters worse.

I think I have the UAD reset script, thanks.
I was only able to move to Big Sur via updating to Catalina then updating to Big Sur. YMMV, but this is how I got this to work from whatever version was out last spring. of course, the UAD driver is different for Big Sur than Catalina.
 
Joined
Aug 13, 2010
Messages
137
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
i have a Macintosh HD from beta 7, now i guess 8 as well(it wrote over it maye?), i select that (of corse) and it power recycles after 5-10 secs..i will try what you did later since you spent time showing some love...thanks...gonna grab dinner first
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,916
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
You sure? :confused:
I think so, but always good to double-check. I noticed these didn’t get enabled or changed:
  • AdviseFeatures
  • CustomSMBIOSGuid
  • ProvideCurrentCpuInfo
  • SecureBootModel = Default
  • UpdateSMBIOSMode = Custom
 
Joined
May 15, 2020
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
I think so, but always good to double-check. I noticed these didn’t get enabled or changed:
  • AdviseFeatures
  • CustomSMBIOSGuid
  • ProvideCurrentCpuInfo
  • SecureBootModel = Default
  • UpdateSMBIOSMode = Custom
They should stay unchanged from old to new config.plist when using “Update OC” / “Reinstall OC”

New entries (also type changed entries like Boolean -> String) introduced by Acidenthera Team will have admin’s configured value but when it is not available then OC failsafe value will be applied
 
Joined
Aug 13, 2010
Messages
137
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
Yeah that was the same advise from beta 6 and I just toggled it again and SecureBootModel set to Default was a no go again... can I send you maybe a log? I toggled everything in those photos, exactly like you said. This is wierd.
 
Joined
Aug 25, 2012
Messages
1,161
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
They should stay unchanged from old to new config.plist when using “Update OC” / “Reinstall OC”

New entries (also type changed entries like Boolean -> String) introduced by Acidenthera Team will have admin’s configured value but when it is not available then OC failsafe value will be applied
I updated from OC 0.7.3 to 0.7.4 with your terrific hackindrom 2.0.1 tool, but after reboot my hack hung with an error:
OC driver ExFatDxe.efi at 2 couldn't be found.

It was in my previous EFI, I think. I rebooted from an older EFI and copied the driver to the 0..7.4 EFI. That worked.
 
Joined
Aug 25, 2012
Messages
1,161
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
If it's not seen(no device found) loading the driver with kextload will not help. Nothing happens.

I don't think a real Mac would do much better, BTW. Maybe maintenance would be easier.

What makes Logic and Cubase unstable is a combination of 3rd party plugins. It will work fine one day, but after a restart the project suddenly refuses to load or crashes. The crash logs points at some random 3rd party plugin, but that's not it. Reshuffling the way the plugins load will often fix the problem.

I have less trouble with Bitwig, it might be that they have better protection/sandboxing against misbehaving plugins.

On the other hand, I use Bitwig more for sketching and as a playground, the real work is done in Logic or Cubase.

And I like to test new plugins, so my system is always in a state of flux.

What doesn't help either is that I never commit stuff to plain audio, I will keep MIDI with lots of software instruments and plugins until I bounce a master. I could freeze/commit stuff, but the whole composing/recording/mixing/mastering stuff is now a fluid process, and committing breaks the flow for me.
Hm. If I change something in OC, I need to cold boot otherwise my UAD card is missing.
 
Joined
Oct 25, 2019
Messages
61
Motherboard
Gigabyte Z390 Designare
CPU
I7-9700K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Guys,

a quick thank you. Especially to @CaseySJ. I today came here to check for the steps necessary updating from 11.3 to 11.6. Was about time securitywise. Updated OC with a fully automated tool (HackinDrom), did the bootable backup with a fully automated script, updated BIG Sur via System Updates. Read everything about it in various meticulously compiled guides. Flawless.

Man, I am running this machine since early 2019 and while it was some fiddling back then starting with mojave and buggy gfx drivers it‘s so smooth and easy meanwhile. Thanks to everyone contributing here.
 
Top