Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ
Thank you for your comments.
I will try to get the log.

My RAM does not support XMP 2.0. Is XMP supports RAM required to install macOS to this motherboard?
In that case, I need to buy another RAM.
XMP-compliant DIMMs are not required, but in this case BIOS might hide XMP options. For best long-term compatibility, it is better to use XMP-compliant DIMMs -- but this is your choice.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey Casey,

I noticed you updated your guide and included a handy platform chart. I was going to go with the 10.14.4 mac mini (non-headless) for now. Where do I set the platform for my system? Do I have to use 0x3E9B0007 like that exactly? Noticed in Devices --> Properties tab it doesn't look like that.
For non-headless, the Platform ID should remain as 0x3E9B0007. In Devices --> Properties we enter these hexadecimal values in reverse byte order. So 0x3E9B0007 is entered as 07009B3E. So the screenshot is correct. However, you can delete the "device-id" row because with 10.14.4 we no longer need to fake the device ID. The real device-id of the 9th Gen Core processor is 0x3E98, and it is natively supported in this build.
 
Joined
Mar 5, 2019
Messages
69
Motherboard
Designare Z390
CPU
i7-9700K
Graphics
RX580 Pulse
For non-headless, the Platform ID should remain as 0x3E9B0007. In Devices --> Properties we enter these hexadecimal values in reverse byte order. So 0x3E9B0007 is entered as 07009B3E. So the screenshot is correct. However, you can delete the "device-id" row because with 10.14.4 we no longer need to fake the device ID. The real device-id of the 9th Gen Core processor is 0x3E98, and it is natively supported in this build.

Ah lovely, thank you! And the graphics tab in CC should remain blank correct?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ

I tried these;

Fake Id= 0x59128086
ig-platform-id = 0x59120003
Inject intel

I am getting kernel panic when I try to make a boot with IGPU.

And I also tried these;

Fake id= 0x3E9B8086
ig-platform-id = 0x3E9B0007
Inject intel

This time after finishing verbose screen goes to sleep

You also mention about this 0x3E980003 in headless mode. How can I use this in headless mode? I don't know anything about headless mode.
Because you have an AMD graphics card installed, it is necessary to copy Lilu and WhateverGreen to the CLOVER/kexts/Other folder in the EFI partition of the USB flash disk.

If you continue to run into problems, please compress and upload the CLOVER folder from the USB install disk.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Ah lovely, thank you! And the graphics tab in CC should remain blank correct?
Yes, correct. No settings in Graphics page.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
H264 is working
HEVC not working
10.4.4
Imac 18.3
device blank
graphic blank
Have you tried adding shikigva=60 to your Boot Arguments in Clover Configurator?
 
Joined
Mar 5, 2019
Messages
69
Motherboard
Designare Z390
CPU
i7-9700K
Graphics
RX580 Pulse
Yes, correct. No settings in Graphics page.

Weird question, but how do I delete my "device-id" from the devices properties window? When I highlight just the device-id row and hit the minus (-) button in that window to delete the property, it deletes the entire entry in the "Devices" window right next to it.

Is that what you meant? Delete that entire entry? I'm on the latest version of Clover Configurator.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Weird question, but how do I delete my "device-id" from the devices properties window? When I highlight just the device-id row and hit the minus (-) button in that window to delete the property, it deletes the entire entry in the "Devices" window right next to it.

Is that what you meant? Delete that entire entry? I'm on the latest version of Clover Configurator.
Screen Shot 2019-04-08 at 7.48.45 PM.png
 
Joined
Mar 5, 2019
Messages
69
Motherboard
Designare Z390
CPU
i7-9700K
Graphics
RX580 Pulse
Yup I did exactly that. Instead of just the row deleting though, I end up with this...

It deletes the entire device.
398386


Going to try doing it manually in Text Mode. Will make a backup of the config first of course.

**Edit: Removed it manually in TextEdit and it seems to have worked**.
 
Last edited:
Top