Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Headaches!!
View attachment 527179

Finally bought a Corsair RM850x 80 PLUS Gold 850 Watts, will check if my be quiet! Straight Power 11 is creating the short circuit
Supernova not available in Europe :(
if anyone has the same Corsair please let me know if it is working properly for you
Please note that PSU cables are not always interchangeable between different brands. In general we should only use the power cables that come with the PSU.
 
Joined
Sep 24, 2012
Messages
173
Motherboard
ASUS ZenBook Pro Duo 15 UX582
CPU
i9-10980HK
Graphics
UHD 630 + RTX 3070
Hello @shiecldk,

Because your firmware is NVM 62, it may be difficult to modify. I would recommend the following experiment instead:
  • Flash the modified Designare Z390 NVM 33 and see whether Thunderbolt Bus gets activated.
  • You can always flash the original NVM 62 if things don't work.
  • Use the Thunderbolt SSDT that was sent in my last reply. It's okay to use that SSDT with NVM 33.
Thanks. I tested the ROM. However, it shows the same results as before (no Thunderbolt device detected in IOReg) w/wo the SSDT. Do you have the original Titan Ridge ROMs that I could used to compare the patches?
 
Last edited by a moderator:
Joined
Apr 20, 2021
Messages
148
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
Please note that PSU cables are not always interchangeable between different brands. In general we should only use the power cables that come with the PSU.
Also can be different with SAME brand but different model numbers, and this is certainly true with Corsair power supplies.

Please refer to this guide:

Corsair PSU Cable Compatibility
 
Joined
May 15, 2020
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Headaches!!
View attachment 527179

Finally bought a Corsair RM850x 80 PLUS Gold 850 Watts, will check if my be quiet! Straight Power 11 is creating the short circuit
Supernova not available in Europe :(
if anyone has the same Corsair please let me know if it is working properly for you
OUUUH!
my be quiet! Straight Power 11 causes short circuit! Now I hope they will take it back
No more issue with Corsair to boot, even Fenvi's bandwidth is a little better. Will check how Intel WiFi is now, because with be quiet! it was awful too
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks. I tested the ROM. However, it shows the same results as before (no Thunderbolt device detected in IOReg) w/wo the SSDT. Do you have the original Titan Ridge ROMs that I could used to compare the patches?
We have come across a couple of motherboards in which we were never able to activate Thunderbolt Bus despite iterating through several modifications of the firmware. So keep that in mind! :) Meanwhile, here are links to (a) original and (b) modified NVM33 from Designare Z390 (top of Post 1). This pair can be used for identifying the changes.

Screen Shot 2021-08-18 at 2.51.14 PM.png
 
Joined
Sep 21, 2013
Messages
1,087
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
A general observation: I am regularly losing Thunderbolt awareness and connectivity to the Apollo 8 with this Z390 build and OpenCore 072. When it does connect, I no longer have hotswap. I am using the same EFI "Thunderbolt fixins" that I've been using for about a year now. BIOS = Z390DESI_modMC_01052021_0906_Rev_0xEA.F9i
---Rolling back to OC 071 and F9i.
 

Attachments

  • EFI copy.zip
    4.3 MB · Views: 28
Joined
May 15, 2020
Messages
1,301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
A general observation: I am regularly losing Thunderbolt awareness and connectivity to the Apollo 8 with this Z390 build and OpenCore 072. When it does connect, I no longer have hotswap. I am using the same EFI "Thunderbolt fixins" that I've been using for about a year now. BIOS = Z390DESI_modMC_01052021_0906_Rev_0xEA.F9i
---Rolling back to OC 071 and F9i.
Hello @jiffyslot,
What about your BIOS -> Thunderbolt configuration ?
 
Joined
Sep 21, 2013
Messages
1,087
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Hello @jiffyslot,
What about your BIOS -> Thunderbolt configuration ?
I didn't change anything from what was working perfectly. I had full Thunderbolt connectivity, user-authorized security, hotswap, and AVB with Apple Thunderbolt-to-ethernet dongles. Not any more. I rolled back to F9i, OC071, and disabled VTD in the BIOS, and now it works again, sans VTD features.
 

Attachments

  • BIOS-TB-Setting.jpg
    BIOS-TB-Setting.jpg
    43.8 KB · Views: 47
Joined
Aug 25, 2012
Messages
1,168
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
So, I've read all the info on USB troubleshooting. It looks like using a PCIe USB card and connecting everything to that (using powered hubs when needed) is the best solution? USB3 and USB2 can be mixed on this card?
Or is it still better to connect all USB2 devices to a powered USB2 hub connected to an internal USB2 port of the Z390, and use the other ports for USB3 stuff?
Hm. Just lost my Korg Wavestate(USB2) again. Connected straight to my new Fresco chip equipped PCIe USB board. So, still USB trouble.
Any ideas/tips welcome. May also be a Korg bug, of course. But I haven't seen other WS users complaining.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello @CaseySJ,
It even wasn't able to show Gigabyte splash screen.

Looks like the mobo has electric issues as I switched every single piece of my build (including cables) and the issue is still present (very poor BT connection with Fenvi, also with Intel CNVI on Windows, and noises in my Focal studio monitors with UAD sound card). Also tried the build in another house
Ouch. If there's no video output in BIOS (no splash screen) then it points to a more serious issue with the board.

Feels like ill leave Designare family for another Hackintosh build or for next Apple Silicon Mac...
Fortunately there are still many choices...
 
Top