Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
did all the recommended changes that's on here.Yes all you got listed above
  • OpenCore Configurator --> ACPI --> Delete. even try with empty OemTableId
Some more questions:
  • Is this on your Gigabyte Z370 AORUS Ultra?
  • Did you modify your System DMAR table and save it as SSDT-DMAR.aml?
 
Joined
Apr 2, 2011
Messages
122
Motherboard
Gigabyte Z370 AORUS Ultra Gaming WiFi
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Some more questions:
  • Is this on your Gigabyte Z370 AORUS Ultra?
  • Did you modify your System DMAR table and save it as SSDT-DMAR.aml?
absolutely yes sir
 

Attachments

  • SSDT-DMAR.aml.zip
    629 bytes · Views: 39

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
absolutely yes sir
  • Your config.plist setup looks correct.
  • Your SSDT-DMAR also looks correct.
So now please enable DisableIoMapper and reboot. I want to double-check that Bluetooth works after rebooting.
 
Joined
Apr 2, 2011
Messages
122
Motherboard
Gigabyte Z370 AORUS Ultra Gaming WiFi
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
it always works after enabling or checking DisableIoMapper in config.plist
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
it always works after enabling or checking DisableIoMapper in config.plist
I understand the frustration. Unfortunately there are few options left...
  • If you do not need AppleVTD, you can turn it off.
  • Maybe there's a problem with the MQUPIN WiFi/BT card -- perhaps a different model such as YOUBO or Fenvi can be tested.
From the Z490 Vision D thread:

Screen Shot 2021-07-07 at 8.07.18 PM.png
 
Joined
Apr 2, 2011
Messages
122
Motherboard
Gigabyte Z370 AORUS Ultra Gaming WiFi
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
The funniest thing is I have never experience any sleep issue with this card but I will definitely take your advice am gonna try with my Intel CNVI and see.
Appreciate your help a ton big up yourself man
 
Joined
Jan 4, 2015
Messages
437
Motherboard
Gigabyte Z390 Designare
CPU
i7 9700K
Graphics
RX 560
Mac
  1. MacBook Pro
Completely out of the actual trend of the topic but, anyway:

Just for fun, I did a test of Clover 5138 on a spare USB key and got some…interesting… results.

- two Recovery entries shown in the boot GUI (verified and they are a double of the same exact location and GUID?

- iTunes asked me to authorize the computer but I didn’t changed the serial in the SMBIOS section? It was already authorized for the record. It´s like it was seen as a new machine by Apple! The only thing I did was letting the BIOS and EFI version blank as Clover is supposed to fill this information looking in its database. With 5099, I have to enter those values as they aren’t up to date.

- good thing however, the boot was flawless with the correct Quirks added in Config.plist. All Acidanthera kexts were updated (Lilu, VirtualSMC, WG, AppleAlc).

Mind you, it works fine with the actual Acidanthera kexts, OcQuirks-4.efi/FwRuntimeServices.EFI, Mojave and 5099 but it was just an experiment to be up to date to latest Clover…
 
Joined
Feb 14, 2021
Messages
4
Motherboard
ASUS ROG Strix Z370-E Gaming - 1002 - OC UEFI
CPU
i7-8700K
Graphics
RX 6800 XT black
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
  • What is the make/model of the SSD?
  • Is it in a USB Type A or Type C enclosure?
  • If Type C, does it connect if plugged directly into the Thunderbolt port on GC-Titan Ridge?
P.S. Please click ‘edit’ button next to your first post and remove the mini-guide. Otherwise your post could be deleted or forcefully edited.
I found a solution. Enter recovery mode, enter "csrutil disable" in the terminal and press Enter, and then enter "csrutil authenticated-root disable" again, press Enter, and reboot. This problem can also solve the problem of eGPU recognition
 
Joined
Aug 23, 2018
Messages
438
Motherboard
Gigabyte Z690 Aorus Master
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
With F11o genuine or modded I have connected through Alpine Ridge a lot of USB 2 and USB 3 devices. Even sleep, wake work ok.
I’m on holiday now, but when I’ll come back I’ll post IOReg.
Ioreg on modded F11o for z390 Aorus Master. Thunderbolt and USB 2.0, 3.0 working. Sleep, wake, etc.
 

Attachments

  • 1.png
    1.png
    816.8 KB · Views: 28
  • 2.png
    2.png
    854.1 KB · Views: 24
  • 3.png
    3.png
    861.3 KB · Views: 24
  • 4.png
    4.png
    896.5 KB · Views: 25
  • 5.png
    5.png
    870.2 KB · Views: 25
  • 6.png
    6.png
    861.9 KB · Views: 27
Top