Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
when i select igfx i get half way to boot and then the screen distorts, in the ill try boot flag sapricot mentioned in his link but i dont know if it will work
this is my only option to use both hackintosh systems until i can buy a second amd card, there still overpriced
thanks
Please try adding this SSDT to OC/ACPI folder and adding a reference to it in ACPI section of config.plist. Then reboot and see if it makes a difference. There's a chance this SSDT needs a little tweaking, but let's first try it as-is.
 

Attachments

  • SSDT-Designare-Z390-Disable-Slot-1-GPU.aml
    210 bytes · Views: 26
Joined
Aug 13, 2010
Messages
137
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
no luck, i added the file to acpi and make sure it was checked in config

here is a photo of my bios setting for intel gpx
 

Attachments

  • 20210629_150818.jpg
    20210629_150818.jpg
    319.2 KB · Views: 34
Joined
Jun 10, 2021
Messages
256
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Unfortunately this problem cannot be rectified with an SSDT. In fact we don’t use any SSDT for RX580 (RX5xx or even RX 5xxx). Because this is happening in Windows as well, please check if your video cable is okay, the connection on both ends is okay, the monitor itself is okay (I assume you’re using speakers built into your monitor). If you choose a different sound output device, does the sound still stop for a quick millisecond?
Hi CasySJ, Thank you. I managed to fix the issue in windows by downloading AMD Catalyst which installed the proper drivers for sound in windows 10 but the issue still persists in MacOS. I don't think the issue is card related now and is something that needs to be resolved in either a driver/kext or Big Sur.
 
Joined
May 15, 2020
Messages
1,300
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Hi CasySJ, Thank you. I managed to fix the issue in windows by downloading AMD Catalyst which installed the proper drivers for sound in windows 10 but the issue still persists in MacOS. I don't think the issue is card related now and is something that needs to be resolved in either a driver/kext or Big Sur.
Barev!
Could you check if the issue is present in Ubuntu?
 
Joined
Jul 22, 2016
Messages
301
Motherboard
Gigabyte Z690 Aero G
CPU
i9-12900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Hi CasySJ, Thank you. I managed to fix the issue in windows by downloading AMD Catalyst which installed the proper drivers for sound in windows 10 but the issue still persists in MacOS. I don't think the issue is card related now and is something that needs to be resolved in either a driver/kext or Big Sur.
@suren6791

The RX580 works fine on my Designare Z390. I haven't seen other reports like that for this board. Your signature says you have an Asus Rog B560-F Gaming board. I suggest you try a forum for that board.
 
Joined
Jun 10, 2021
Messages
256
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@suren6791

The RX580 works fine on my Designare Z390. I haven't seen other reports like that for this board. Your signature says you have an Asus Rog B560-F Gaming board. I suggest you try a forum for that board.
I created a post for this issue but cannot find any posts for that specific board. I also searched the web for any issues regarding sound for this card and found none, so I'm stuck
 
Joined
Mar 21, 2011
Messages
820
Motherboard
GA-Z390-Aorus Pro
CPU
i7-9700K
Graphics
RX 590
I have the same issue
Well, good luck...
It could come from your Broadcom module, antennas, storage drive, RAM, PSU, GPU; also from your PC case and even from your neighbor's micro-wave :sick:

I tried every combination possible (except GPU and PSU) and never found the issue
Next thing ill try is get out the motherboard from the case and try without the case
in my experience the largest contributor to interference with BT is USB3. I have a NUC hackintosh that I use a BT dongle with, and I have had to use a USB extension cable to locate the BT dongle a couple of feet from the NUC. obviously with the Fenvi card providing BT this isn't an option, but if using a BT dongle it's worth a try.
 
Joined
Aug 8, 2012
Messages
29
Motherboard
Z390 Designare
CPU
i7-9700K
Graphics
RX 580
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Last edited:
Joined
Sep 21, 2013
Messages
1,085
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
@CaseySJ, I'm thinking that it would be a good idea to include minimal OS qualifiers for these guides. I was surprised that everything VT-d related works in Mojave but not in Big Sur. Unflashed TB, too.
 
Last edited:
Top