Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Aug 13, 2010
Messages
128
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
This information going on right now with all this vt-d stuff really states to me why AVB protocol atm is not really a windows thing and maybe one of the reasons why Avid carbon only works on a mac. I don't really see Microsoft talking about AVB much anywhere which makes me scared for the pc audio community.

@CaseySJ would you have info on how to disable my nvidia card on mac os boot so i can use my intel internal gfx for now as posted a few threads back? Thanks
 
Joined
Jul 22, 2016
Messages
283
Motherboard
Gigabyte Z690 Aero G
CPU
i9-12900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
We got a volunteer who owns LG UltraFine 5K, but not someone with Apple Thunderbolt Display. If you have one of these ATD monitors and would like to try the modified BIOS, I can send you the file in private message. We don’t want to publicly release the new BIOS yet because it is still being worked on.

@CaseySJ

I have an Apple Thunderbolt Display. You had already provided me with the experimental F9i BIOS which I have been using during the Experiment #3 testing, but never experimented with the ATD.

I had already increased my RAM to 32GB this morning, so did some testing with the ATD not expecting it to work. I ran a DP cable from my RX580 to the DP In on the Designare. I used the Experiment #3 settings. There was no video on the ATD during boot or OC picker or after reaching the Big Sur window. Of course on-board Ethernet and WiFi were disabled per the results from Experiment #3.

(Since I'm running "headless" there was no video being sent directly to the TB connection -- I guess?}

I then removed one 16GB memory module and used the Experiment #3 settings. There was no video on the ATD during boot or OC picker, but both monitors were active after Big Sur 11.4 was running. The Ethernet, camera, and USB ports were active on the Apple Display.

Is there anything else I should try before putting the Apple Display back in storage?
 
Joined
Dec 21, 2019
Messages
55
Motherboard
Gigabyte Z390 Designare iMac19,1
CPU
i9-9900K
Graphics
RX 5700 XT
This information going on right now with all this vt-d stuff really states to me why AVB protocol atm is not really a windows thing and maybe one of the reasons why Avid carbon only works on a mac. I don't really see Microsoft talking about AVB much anywhere which makes me scared for the pc audio community.

@CaseySJ would you have info on how to disable my nvidia card on mac os boot so i can use my intel internal gfx for now as posted a few threads back? Thanks
I'm not Casey but there's a page about this exact topic in the OC guide: https://dortania.github.io/OpenCore-Install-Guide/extras/spoof.html

Basically you find the pcie path of the Nvidia card, then modify the dsdt entry from the example, compile it with MaciASL and add it to OC.
 
Joined
Apr 2, 2020
Messages
53
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
My Bluetooth seems to work randomly from ok to great. It also shows up randomly in Hackindrom. My magic keyboard and trackpad are working OK but an app like Unlox (formerly MacID) also work randomly.
I tried with 2 different dongle ( Broadcom BCM20702 and Laird BT851-ND )with the same random results.
What is the best way to troubleshoot this ?
 
Joined
May 15, 2020
Messages
1,200
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
My Bluetooth seems to work randomly from ok to great. It also shows up randomly in Hackindrom. My magic keyboard and trackpad are working OK but an app like Unlox (formerly MacID) also work randomly.
I tried with 2 different dongle ( Broadcom BCM20702 and Laird BT851-ND )with the same random results.
What is the best way to troubleshoot this ?
I have the same issue
Well, good luck...
It could come from your Broadcom module, antennas, storage drive, RAM, PSU, GPU; also from your PC case and even from your neighbor's micro-wave :sick:

I tried every combination possible (except GPU and PSU) and never found the issue
Next thing ill try is get out the motherboard from the case and try without the case
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,015
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Does anyone have an SSDT for the RX580. On mine when playing music or videos the sound plays then stop for a quick millisecond and plays again. This happens every 10 to 20 seconds of the song/video. The fact that this is also happening in windows leads me to believe the RX580 needs patching or how do I extract my own SSDT from my DSDT.
Unfortunately this problem cannot be rectified with an SSDT. In fact we don’t use any SSDT for RX580 (RX5xx or even RX 5xxx). Because this is happening in Windows as well, please check if your video cable is okay, the connection on both ends is okay, the monitor itself is okay (I assume you’re using speakers built into your monitor). If you choose a different sound output device, does the sound still stop for a quick millisecond?
 
Joined
Apr 2, 2020
Messages
53
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
I have the same issue
Well, good luck...
It could come from your Broadcom module, antennas, storage drive, RAM, PSU, GPU; also from your PC case and even from your neighbor's micro-wave :sick:

I tried every combination possible (except GPU and PSU) and never found the issue
Next thing ill try is get out the motherboard from the case and try without the case
Well, no neighbours close to me.
I tried a couple of USB port.
My dongle is now out of the G5 mod case on my old Apple A1048 Keyboard. Still the same issue.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,015
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...
@CaseySJ would you have info on how to disable my nvidia card on mac os boot so i can use my intel internal gfx for now as posted a few threads back? Thanks
We have two versions of an SSDT that disables GPUs. If you post a screenshot of the IORegistryExplorer device tree that shows the first few lines of the Nvidia card, I can provide the right SSDT. Alternatively, post the entire IOReg file.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,015
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...

Is there anything else I should try before putting the Apple Display back in storage?
Thanks for the update. For now it's okay to put it back into storage. We might have a new version of the BIOS soon, but cannot say when. It might be a couple of weeks away.
 
Joined
Aug 13, 2010
Messages
128
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
when i select igfx i get half way to boot and then the screen distorts, in the ill try boot flag sapricot mentioned in his link but i dont know if it will work
this is my only option to use both hackintosh systems until i can buy a second amd card, there still overpriced
thanks
 

Attachments

  • iMac.ioreg
    10 MB · Views: 20
Top