Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,261
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Just wanted to report that X299 Gaming 7 the built in ethernet stopped working. Any suggestions on what to try?
As you can see, the number and capacity of memory DIMMs make a difference.
  • How many DIMMs are installed currently?
  • And what is the capacity of each one?
  • You have an Intel HEDT system (X299), which version of macOS are you running?
  • And which of the two Ethernet ports fails?
  • Please post a screenshot of System Information --> Ethernet Cards with both cards selected (as you can see in my screenshot directly above)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,261
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yep both ports work. The ASUS Sage/10G has a Intel X550-AT2 so I modified the EEPROM to work with SmallTree drivers

SMBIOS: MacPro7,1

BIOS changes: None - Can't seem to find VT-D in the ASUS X299 BIOS
config.plist changes: DisableIoMapper (false)
  • AppleVTD Enabled
  • DMAC
  • 4 DIMMS (4 x 16GB @ 3200)
  • Broadcom BCM943602CDP (Wifi + Bluetooth work)
  • Both onboard Ethernet ports work - Intel X550-AT2 with SmallTree8259x.kext
  • No Thunderbolt card (Will be getting a Titan Ridge to flash)
On my Asus X99 Deluxe II, VT-D is located here:
  • Advanced → System Agent Configuration → Intel VT for Directed I/O (VT-d)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,261
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
If you'd like to follow or re-trace the key milestones of this Experiment, simply look here in Post #1:

Screen Shot 2021-06-26 at 5.09.09 PM.png
 
Joined
Apr 18, 2011
Messages
1,328
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
On my Asus X99 Deluxe II, VT-D is located here:
  • Advanced → System Agent Configuration → Intel VT for Directed I/O (VT-d)

:banghead: gah, was thinking of VT-X.. I already had VT-D enabled lol
 
Joined
Nov 30, 2016
Messages
38
Motherboard
Asus Rampage IV Extreme
CPU
Intel Xeon E5-1650 V2
Graphics
Gigabyte Windforce GX 780OC V.2
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. Android
** Experiment Update #3 **
AppleVTD Side-Effects and Mitigation Strategies
It hasn't worked for me. Do I need to change the SSDT? I haven't used a lite/skinny one.

Asus X299 Prime Deluxe II
i9-7900X
4x16GB 3000Mhz DIMM
OSX 10.13.6
TB3 Titan Ridge (built-in) original FW 36
ANTELOPE DISCRETE 8

VT-d -> Enabled
DisableIOMapper (never was on)
Removed 'dart=0'
 

Attachments

  • EFI.zip
    39.7 MB · Views: 20
  • TB Experiment #1.png
    TB Experiment #1.png
    975.7 KB · Views: 34
  • config.plist
    22.6 KB · Views: 22
Last edited:
Joined
Sep 21, 2013
Messages
1,025
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
That's very interesting! You have four 16GB DIMMs running at 2666MHz. Can you confirm if WiFi and Ethernet ports actually connect. In other words, do you see the green dot next to them in System Preferences --> Network, as shown below?

@Inqnuam, do you also see green dots for built-in Ethernet ports and Fenvi WiFi (not Thunderbolt Ethernet)?
View attachment 522961
Yep! This is one reason I'm trying to get this going on my #2 build (Z370) as well; to see if this can be propagated down, so to speak. FWIW, I bought Corsair LPX 2666MHz RAM so that I could run the "native" im/iMp RAM speed without having to count on XMP. Note that this is Mojave.
 

Attachments

  • En0_En1_WiFi_BT.png
    En0_En1_WiFi_BT.png
    28.7 KB · Views: 18
Last edited:
Joined
Dec 19, 2012
Messages
149
Motherboard
Gigabyte GA-Z170X Designare
CPU
i7-6700K
Graphics
RX Vega 64
Mac
  1. iMac
  2. MacBook
  3. Mac Pro
Classic Mac
  1. Color Classic
  2. iMac
  3. Power Mac
  4. PowerBook
  5. SE/30
Mobile Phone
  1. iOS
It hasn't worked for me. Do I need to change the SSDT? I haven't used a lite/skinny one.

Asus X299 Prime Deluxe II
i9-7900X
4x16GB 3000Mhz DIMM
OSX 10.13.6
TB3 Titan Ridge (built-in) original FW 36
ANTELOPE DISCRETE 8

VT-d -> Enabled
DisableIOMapper (never was on)
Removed 'dart=0'
Correct me if I am wrong but I think all the successful builds have been using OpenCore and not Clover....
 
Joined
Dec 21, 2019
Messages
53
Motherboard
Gigabyte Z390 Designare iMac19,1
CPU
i9-9900K
Graphics
RX 5700 XT
Not sure if this VT-d business is only for those with modified TB firmware, but tried anyway. No WiFi/Ethernet for me with:

  • DisableIOMapper off and dart=0 removed.
  • VT-d enabled in bios.
  • 4x16GB ram @2666 MHz (can't do 3000 because usb disks get ejected during sleep).
For fun I tried without XMP too but same result.
 
Top