Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Dec 21, 2019
Messages
53
Motherboard
Gigabyte Z390 Designare iMac19,1
CPU
i9-9900K
Graphics
RX 5700 XT
Kudos! It happened to me with my Z97 Hackintosh: BIOS boot loop but unfortunately, I had flashed the Ozmosis BIOS for my board. As I understand (now!) from your situation, the backup BIOS probably tried to kick in but it was never updated by me. To resume, backup BIOS was probably from too early a version in my understanding.

I RMA’ed the board and bought the same ´cause I didn’t want to suffer the wait. I still have the old MB in its box and the Z97 is still working with the replacement board.

They probably just reflashed (or replaced) the BIOS chip @Gigabyte.
Mine's still under warranty, and I could've had it repaired, but that could take weeks. Also no Z390 Designare in stock anywhere near, and this board is so good for hackintoshing. Just so relieved today to wake up and see the computer peacefully asleep, but happy to wake up and start working. :D
 
Joined
Jan 1, 2020
Messages
511
Motherboard
Gigabyte Z390 Designare
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Hello Elias,

When you say "copy them on same field on the downloaded BIOS firmware" do you mean the BIOS file I posted above, which was extracted using CH341a SPI ROM reader?


Once @Sapricot downloads the file, I'll remove it.
Hello @CaseySJ
late message… this GBe region copying is OK for your personal firmware as well as for Gigabyte website downloaded firmware. Better should be on a clean Gigabyte firmware (Nvram empty).
 
Joined
Jan 1, 2020
Messages
511
Motherboard
Gigabyte Z390 Designare
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Success! Thanks so much for helping me out @CaseySJ and @Elias64Fr! Working computer in basically no time. Plus I learned a ton.
Once done, you only have to verify if you have recovered your 2 MAC address (intel 219 and intel 211 controllers) on network settings.
 
Joined
Dec 21, 2019
Messages
53
Motherboard
Gigabyte Z390 Designare iMac19,1
CPU
i9-9900K
Graphics
RX 5700 XT
Once done, you only have to verify if you have recovered your 2 MAC address (intel 219 and intel 211 controllers) on network settings.
Yup, also confirmed by checking my DHCP server (assigning set IP per MAC). Do the two ports always have very similar MAC addresses? Mine are identical except last digit.
 
Joined
May 10, 2014
Messages
8
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hi all,

I bought this card (Sonnet Solo10G SFP+ - Carte PCIe 10 Gigabit Ethernet) to be able to benefit from the 10 Gb/s from my ISP and for its Windows and MAC compatibility.
Ref => https://www.sonnettech.com/product/solo10g-sfp-pcie-card.html
I put it in the 3rd slot (X4) but it does not appear in the system preferences of my Hackintosh (Ethernet Card and/or PCI).
I tried in the 2nd slot (X8), same thing. In addition, it impacts the 1st PCIE X16 slot which switches to an X8 (bad for my Asus DUAL-RX580-O8G)
Is it normal not to see this card in the system preferences.

PS : The card is perfectly recognized under my Windows 10 boot.

Many thanks.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,347
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi all,

I bought this card (Sonnet Solo10G SFP+ - Carte PCIe 10 Gigabit Ethernet) to be able to benefit from the 10 Gb/s from my ISP and for its Windows and MAC compatibility.
Ref => https://www.sonnettech.com/product/solo10g-sfp-pcie-card.html
I put it in the 3rd slot (X4) but it does not appear in the system preferences of my Hackintosh (Ethernet Card and/or PCI).
I tried in the 2nd slot (X8), same thing. In addition, it impacts the 1st PCIE X16 slot which switches to an X8 (bad for my Asus DUAL-RX580-O8G)
Is it normal not to see this card in the system preferences.

PS : The card is perfectly recognized under my Windows 10 boot.

Many thanks.
Hello @niquau,

Have you tried enabling the Aquantia kernel patch that is already present in the “kernel —> patch” section of config.plist?
 
Joined
Sep 21, 2013
Messages
1,026
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Referring back to the multiple GPU topic on this build, has anyone else tried using two identical dGPUs in this build? One for display, one for compute (PCIx4?) ? I was going to try 2 RX580's in compute mode. I'm using the SSDT-RX580.aml patch for the one but I'm hoping to use it for both cards if it'll work. Does anyone have any advice?
 
Joined
Jan 1, 2020
Messages
1
Motherboard
Gigabyte Designare Z390
CPU
i7-8700K
Graphics
RX 5600 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
**Mini-Guide for Fresh Installation of Catalina 10.15.1 and Newer **
** Please do not quote this guide in any post -- use a link instead **

URGENT: To install Catalina 10.15.4 or newer, please follow the new mini-guide here.
9-Apr-2020: Do not use Clover 5109


...
Oh my goodness, thank you. I had accidentally deleted my EFI folder a few months ago with no backup. It took me forever to find this thread, but thank you so very much.
 
Joined
May 10, 2014
Messages
8
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hello @niquau,

Have you tried enabling the Aquantia kernel patch that is already present in the “kernel —> patch” section of config.plist?

CaseySJ, you are a magician :clap:.
I've now an Aquantia AQC107 in my ethernet cards !
Still waiting for my new internet box, I can't test the speed but will keep you posted.
Many many many thanks for your help & support.
 
Joined
Jan 7, 2019
Messages
73
Motherboard
Gigabyte Z390 Designare
CPU
I7-9700K
Graphics
RX 580
Mobile Phone
  1. Android
Hi, could I ask for help with OpenCore ad this hardware (Designare Z390 + i7-9700K + AMD RX 580) in this forum?
 
Top