Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Feb 18, 2019
Messages
355
Motherboard
ASUS Z690 Maximus Extreme
CPU
i9-12900KF
Graphics
6900XT
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello @ol2003,

We found that the NVM23 we modified for GC-Titan Ridge works in Catalina, but not in the latest versions of Big Sur. Hence Big Sur users should flash the other firmware (by DSM2) that we uploaded to the Repository.

I had to pull the GB TR AIC from my TRX40 build in the latest Big Sur 11.3+ due to freezes. This card is one I've used in previous Z390 and X570 builds. I re-flashed tonight using the recommended firmware from the repository and Big Sur now seems stable with the TR AIC. Thanks!

I know this is another mobo and I'm not asking for help, but I saw one interesting change with this firmware update: DSB2 no longer contains a USB port (shown in Spoiler). This port only appeared after changing the SMBIOS from iMacPro1,1 to MacPro7,1 when using the previous firmware.

In testing checksums, I'm now not certain what firmware I'd flashed onto the chip. Using Hex Fiend, it says in the DROM section, "GIGABYTEZ390 DESIGNARE", so maybe a version intended for the Z390 mobo. There are no matches with NVM 20,21,23,33,43,50,71.

With the older NVM23:
TB3-XHC5.png


With the new, stable firmware:
Screen Shot 2021-05-18 at 7.55.36 PM.png
 
Joined
Jul 17, 2011
Messages
25
Motherboard
Asus X299 Prime Deluxe (1.0)
CPU
i9-10940X
Graphics
Vega 56
Mobile Phone
  1. iOS
@CaseySJ Hi, as you recommend I flashed my TRv1 with the MacOSFirmware (DSM2) post#16393 but now the USB is gone - not shown in IOReg / PCI or Hackintool (Catalina or Big Sur)... do I need a new SSDT, changes in BIOS or anything went bad? In the moment TB3 not really used but thinking about going back to NVM23-Elias64FR... Also can you tell me what is not working in ig Sur with the EliasFR? thx
 
Joined
Jul 17, 2011
Messages
25
Motherboard
Asus X299 Prime Deluxe (1.0)
CPU
i9-10940X
Graphics
Vega 56
Mobile Phone
  1. iOS
@rj510 Hi, interesting. What to do? or usb is not interesting since TB3 is working?
 
Joined
Feb 18, 2019
Messages
355
Motherboard
ASUS Z690 Maximus Extreme
CPU
i9-12900KF
Graphics
6900XT
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@rj510 Hi, interesting. What to do? or usb is not interesting since TB3 is working?

My issue with USB on the TB3 AIC is probably restricted to the AMD platform.

There are some who are using the GB TRX40 mobo that supports a TB3 AIC, having a TB header on the mobo. They have TB and USB functionality on those mobos.

My mobo is an MSI TRX40 that does not have a TB header and there was no USB functionality in Mojave, Catalina or Big Sur while I was using the iMacPro1,1 SMBIOS. What was surprising was the brief tease of USB functionality, cut short by the version 3 and 4 Big Sur betas after I'd switched to the MacPro7,1 SMBIOS.

On these betas, macOS crashed 2 to 5 min after booting; there was no stability until the AIC was removed. At least now, after flashing the new firmware, there is stability and TB function. To me, stability is more important than more USB ports.
 
Joined
Jul 11, 2018
Messages
20
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iMac
Hi all, I'm having a few system lock ups using Logic software, only just started appearing (without any updates/installations) - Am rolling back to a previous backup but wondered if anyone had had the kind of panic report attached and if they had some suggested solutions, Still on Mojave 10.14.6.

Thanks a lot,

Silas
 

Attachments

  • Silas_PanicReport.pdf
    74.4 KB · Views: 29

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,931
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all, I'm having a few system lock ups using Logic software, only just started appearing (without any updates/installations) - Am rolling back to a previous backup but wondered if anyone had had the kind of panic report attached and if they had some suggested solutions, Still on Mojave 10.14.6.

Thanks a lot,

Silas
best to update your kexts
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,915
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I had to pull the GB TR AIC from my TRX40 build in the latest Big Sur 11.3+ due to freezes. This card is one I've used in previous Z390 and X570 builds. I re-flashed tonight using the recommended firmware from the repository and Big Sur now seems stable with the TR AIC. Thanks!

I know this is another mobo and I'm not asking for help, but I saw one interesting change with this firmware update: DSB2 no longer contains a USB port (shown in Spoiler). This port only appeared after changing the SMBIOS from iMacPro1,1 to MacPro7,1 when using the previous firmware.

In testing checksums, I'm now not certain what firmware I'd flashed onto the chip. Using Hex Fiend, it says in the DROM section, "GIGABYTEZ390 DESIGNARE", so maybe a version intended for the Z390 mobo. There are no matches with NVM 20,21,23,33,43,50,71.
...

@CaseySJ Hi, as you recommend I flashed my TRv1 with the MacOSFirmware (DSM2) post#16393 but now the USB is gone - not shown in IOReg / PCI or Hackintool (Catalina or Big Sur)... do I need a new SSDT, changes in BIOS or anything went bad? In the moment TB3 not really used but thinking about going back to NVM23-Elias64FR... Also can you tell me what is not working in ig Sur with the EliasFR? thx
I noticed that too so I've added a note to the Repository shown below. If we connect a Thunderbolt Dock then we can connect USB-C based USB 2.x and USB 3.x devices to a USB-C port on the Dock.

Screen Shot 2021-05-19 at 6.38.16 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,915
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi all, I'm having a few system lock ups using Logic software, only just started appearing (without any updates/installations) - Am rolling back to a previous backup but wondered if anyone had had the kind of panic report attached and if they had some suggested solutions, Still on Mojave 10.14.6.

Thanks a lot,

Silas
The panic report shows the following kexts among numerous others. The backtrace suggests a problem with VirtualSMC, but if it has not been updated then it may not be the real cause.

It may be best to uninstall only the UAD, SoundGrid, and MOTU drivers shown in red. Then reboot and test Logic Pro. If it's stable, install only one of these drives at a time (download latest version) and test Logic Pro again. Repeat until all the necessary ones have been reinstalled.

Screen Shot 2021-05-19 at 6.49.18 AM.png
 
Joined
May 15, 2020
Messages
1,300
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
The panic report shows the following kexts among numerous others. The backtrace suggests a problem with VirtualSMC, but if it has not been updated then it may not be the real cause.

It may be best to uninstall only the UAD, SoundGrid, and MOTU drivers shown in red. Then reboot and test Logic Pro. If it's stable, install only one of these drives at a time (download latest version) and test Logic Pro again. Repeat until all the necessary ones have been reinstalled.

View attachment 519065
If I remember well the issue may come from waves soundgrid which isn't supported on latests Big Sur
Screen Shot 2021-05-19 at 16.02.04.png
Screen Shot 2021-05-19 at 16.08.30.png
 
Last edited:
Top