Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jun 20, 2019
Messages
53
Motherboard
Gigabyte Designare Z390
CPU
i9-990K
Graphics
Vega 56
Some suggestions:
  • Remove agdpmod=pikera from Boot Arguments because you have a Vega GPU instead of a NAVI GPU.
  • Check whether you are running BIOS F9g or F9i. Do not use F9j.
  • If you have a backup of the previous OpenCore EFI (0.6.7), try booting with that to see if these problems do or do not occur.
  • Regarding Bluetooth, it might be a good idea to perform a CMOS Reset, which then requires BIOS parameters to be configured again, starting with F7 (Load Optimized Defaults). Ensure also that BIOS --> Boot --> CFG Lock is Disabled.
1) removed, system acts faster now :)
2) f9i
3) not have a backup anymore, but try to emulate it later on.
4) done, but BT is still not found. Wifi is working...

After the pikers and BIOS and CMOS reset, no issues with numbers etc. even after 6 restarts.


Will try BT in windows. Maybe a hardware issue.
[UPDATE] Windows sees the USB, but with a error: Device Descriptor Request Failed
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
A new OpenIntelWireless build was released earlier today. If you're using the 2.0.0-alpha driver simply download the latest version, rename the file, and replace the existing file in OC/Kexts.

How to rename files:
  • After downloading the Big Sur version, rename it to AirportItlwm-Big-Sur.kext
  • After downloading the Catalina version, rename it to AirportItlwm-Catalina.kext
  • After downloading the Mojave version, rename it to AirportItlwm-Mojave.kext
Click here for more detailed instructions (if needed).

Screen Shot 2021-05-17 at 1.54.18 PM.png



UPDATE: This build seems to drop WiFi connections regularly. Not recommended.
 
Last edited:
Joined
Jul 17, 2011
Messages
25
Motherboard
Asus X299 Prime Deluxe (1.0)
CPU
i9-10940X
Graphics
Vega 56
Mobile Phone
  1. iOS
@CaseySJ Hi, you recommend in post #16393 for the TitanRidge PCI-Card (v1) the macos-Firmware for 11.3 and up. Any reason for this? I am still on Catalina but think about BigSur...
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Hi, you recommend in post #16393 for the TitanRidge PCI-Card (v1) the macos-Firmware for 11.3 and up. Any reason for this? I am still on Catalina but think about BigSur...
Hello @ol2003,

We found that the NVM23 we modified for GC-Titan Ridge works in Catalina, but not in the latest versions of Big Sur. Hence Big Sur users should flash the other firmware (by DSM2) that we uploaded to the Repository.
 
Joined
Dec 15, 2010
Messages
484
Motherboard
Asus ProArt Z690 Creator WiF
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Just read that there may be one last i9 Intel iMac coming. A stay of execution for our way?
 
Joined
Aug 18, 2020
Messages
25
Motherboard
Gigabyte Z390 Mater
CPU
Intel 9900k
Graphics
RTX2080
Hi Casey!

Today I did a clean re-install of Big Sur 11.2.1 because I messed up with my Windows partition. I wipe my whole SSD in the BIOS and did a clean installation with my working EFI files. However, I ended up with two problems.
The first one was in the booting process. I copy my EFI from my old system which is fully tested and make an installation USB based on it. OC version was 0.65
After installation I have three boot option in my BIOS:
1. Old EFI USB
2. New installation USB with same EFI
3. SSD drive where the Big Sur was in, I put the same EFI folder into the EFI partition

I can only boot by #2. Both #1 and #3 will give me black screen with single blinking underscore before the OpenCore boot picker. The blinking underscore will show up right after I exit the bios menu.

The second problem which bothered me more was the LG Ultrafine 5K monitor. (I have a dual monitor set, one is DP based and another is the thunderbolt based LG) It worked perfectly with flashed titan ridge card before re-installation. All I needed was booting into OSX first, reboot, and did a hot replug.
But now, things changed. For the first cold boot, both monitors lit up, like before. Then I reboot, the DP monitor lit up, LG monitor won't lit up but all the USB devices work. At this step, everything is the same. But when I replug the LG display trying to activate the monitor, I wouldn't be able to lit up the screen, and I also lost USB peripheral devices.

Any suggestion would be highly appreciated!!! Thank you, sir!
 
Joined
Apr 20, 2021
Messages
148
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
*** Mini-Guide ***
Catalina/Big Sur: Configure Carbon Copy Cloner for One-Key Bootable Backup

Please do not quote this guide in its entirety. Post a link instead.​
...​
Thank you for this @CaseySJ !!!

This is GOLD! Just got it all set-up and it ran perfectly.

For any not using this yet and looking for solid back-ups, this is amazing.

Thanks so much to CaseySJ, @byteminer and any others who contribute.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Just read that there may be one last i9 Intel iMac coming. A stay of execution for our way?
There's a gold mine of Mac rumors today! Lots of exciting details. Let's see what the new Intel-based Mac features. It may be an update to Mac Pro or a speed-bumped 27" iMac.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you for this @CaseySJ !!!

This is GOLD! Just got it all set-up and it ran perfectly.

For any not using this yet and looking for solid back-ups, this is amazing.

Thanks so much to CaseySJ, @byteminer and any others who contribute.
Glad to hear it! But please see this:

Screen Shot 2021-05-18 at 10.06.09 AM.png
 
Top