Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
May 10, 2014
Messages
8
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hi all,
I work since 1 year with my Mojave Hackintosh without any bug or problem. Thanks to CaseySJ for his wonderful tutorial.

I'm considering switching to Big Sur so I've downloaded the OpenCore 0.6.7 EFI of CaseySJ and followed the procedure for edit the SMBIOS. I created a USB Install Mac OS Big Sur and put the EFI folder in the EFI partition of the key.

If I boot on the USB Key and select my Mojave Hackintosh, I am still stuck on the black screen with the apple logo. Same thing if I select "Install Mac OS Big Sur"

My computer :
Z390 Designare
i9-9900K
64Gb Ram Corsair
Asus Strix RX580
Fractal Design R6

I've added "SSDT-UIAC-DESIGNARE-Z390-FD-DEFINE-R6-USB2-ON-TB-V3.aml & SSDT-Z390-DESIGNARE-RX580-V2.aml" in the ACPI Folder and in my config.plist.

Can you help me ?
 
Joined
Apr 24, 2019
Messages
15
Motherboard
Z390 Designare
CPU
i7-8700K
Graphics
UHD 630
Nope. They said it doesn’t matter if the firmware is flashed or not, and they said they need to remote control the computer. Honestly, for a price of a base Mac mini I don’t think it’s a fair trade.
Apparently they are laughing. Let's wait until no one pays them, or pays them so little that they think twice.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi all,
I work since 1 year with my Mojave Hackintosh without any bug or problem. Thanks to CaseySJ for his wonderful tutorial.

I'm considering switching to Big Sur so I've downloaded the OpenCore 0.6.7 EFI of CaseySJ and followed the procedure for edit the SMBIOS. I created a USB Install Mac OS Big Sur and put the EFI folder in the EFI partition of the key.

If I boot on the USB Key and select my Mojave Hackintosh, I am still stuck on the black screen with the apple logo. Same thing if I select "Install Mac OS Big Sur"

My computer :
Z390 Designare
i9-9900K
64Gb Ram Corsair
Asus Strix RX580
Fractal Design R6

I've added "SSDT-UIAC-DESIGNARE-Z390-FD-DEFINE-R6-USB2-ON-TB-V3.aml & SSDT-Z390-DESIGNARE-RX580-V2.aml" in the ACPI Folder and in my config.plist.

Can you help me ?
Hello @niquau,

Are you following the procedure shown here?

Screen Shot 2021-05-06 at 6.11.51 AM.png
 
Joined
Oct 25, 2019
Messages
61
Motherboard
Gigabyte Z390 Designare
CPU
I7-9700K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey guys,

Is the Fully Bootable Backup Procedure for BIG SUR identical to the Catalina version as stated in the Mini Guide or is there some changes to be aware of? I searched but could not find anything related.

Trying it ATM. Cant break anything I guess.

Thank you
 
Last edited:
Joined
May 10, 2014
Messages
8
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hello @niquau,

Are you following the procedure shown here?

View attachment 517752
No, I hadn't seen it. That's it now.
Resolve my problem, it's the CFG-Lock in my F9i Bios. Grrrrr.... I'm so stupid. :oops:

I can boot on my Mojave Hackintosh or launch install Big Sur, all is OK ! :thumbup:

Many many many many many many thanks CaseySJ.
 
Joined
Nov 18, 2015
Messages
189
Motherboard
GIGABYTE Z490 Vision D
CPU
i9-10850K
Graphics
RX Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

Just getting around to trying the "Radeon Speed Boost" kext on my z390 designaire, Vega 64, OC 0.69, MacOS 11.3 build. So far so bad. My machine refused to boot w/ SSDT-Z390-Vega64-Slot-1.aml & RadeonBoost-v1-4+Vega.kext and WEG enabled. I did add entries to my OC config.plist to the best of my abilities (which I assume where correct).

My question is pretty basic: Which Slot on the board is considered 1 or 2 for the .aml?
This is what my Z390 Manual looks like. I'm GUESSING the (PCIEX16) Slot is labeled "1" somewhere that I'm unaware of?

Thanks,
 

Attachments

  • Screen Shot 2021-05-06 at 10.37.54 AM.png
    Screen Shot 2021-05-06 at 10.37.54 AM.png
    344.2 KB · Views: 25

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey guys,

Is the Fully Bootable Backup Procedure for BIG SUR identical to the Catalina version as stated in the Mini Guide or is there some changes to be aware of? I searched but could not find anything related.

Trying it ATM. Cant break anything I guess.

Thank you
The backup procedure for Big Sur is the same as for Catalina. There is one weird thing to note about Big Sur, however:
  • The first backup of Big Sur uses Apple's "APFS Replication" tool to duplicate both the System and User volumes.
  • The second and all subsequent backups will only clone the User volume.
  • So if the first backup was done with Big Sur 11.3, for example, and you make another backup after installing Big Sur 11.4, the System volume on the backup disk will still be 11.3.
    • If you would like to backup 11.4 to the same backup disk, it will be necessary to erase the backup disk in Disk Utility and then run CCC again.

Update: Modified the Carbon Copy Cloner guide:

Screen Shot 2021-05-06 at 9.30.52 AM.png
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,213
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS

Just getting around to trying the "Radeon Speed Boost" kext on my z390 designaire, Vega 64, OC 0.69, MacOS 11.3 build. So far so bad. My machine refused to boot w/ SSDT-Z390-Vega64-Slot-1.aml & RadeonBoost-v1-4+Vega.kext and WEG enabled. I did add entries to my OC config.plist to the best of my abilities (which I assume where correct).

My question is pretty basic: Which Slot on the board is considered 1 or 2 for the .aml?
This is what my Z390 Manual looks like. I'm GUESSING the (PCIEX16) Slot is labeled "1" somewhere that I'm unaware of?

Thanks,
Correct -- the PCIEX16 slot is Slot 1.
 
Joined
Jul 3, 2010
Messages
295
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Good job!


Unfortunately we're not aware of any solution for this (yet) with the Intel Bluetooth module. But if you connect Apple Mouse and Keyboard via USB cable, then they should work.

I use Logitech wireless mouse and keyboard, which work in BIOS and OpenCanopy with no issues.
If you're using an Apple Magic Mouse 2, which has a lightning port on it, you can use the keyboard in BIOS if you connect a lightning cable to it from your computer. It will work as a USB keyboard.
 
Joined
Aug 13, 2010
Messages
122
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
@casey Can you please add a working to the database?? Ive searched all over and nothing for big sur 11.3 My keyboard layout is not working now. I have a 0.66 build but im not that technical to get the usb ports working and i think its a miss moss of stuff

GIGABYTE Z370 Gaming 7 for build intel gfx​

 
Top