Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,104
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ

Yes that is turned off.
  • When the system wakes up automatically, does it go back to sleep within 30 to 60 seconds?
  • If so, is that acceptable?
  • If not acceptable, then one has to go through this procedure:
  • The suggestions here are straightforward.
  • Also have a look at the first bullet under Suggestions Contributed by Users.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,104
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** Calling all Owners of Good Quality Hackintosh Builds **
We would like to add your OpenCore EFI folders to the HackinDROM database!​

Do you have a well configured Hackintosh based on a motherboard that is not listed below?
  • ASRock X570 Taichi
  • Asus X99 Deluxe II
  • Gigabyte B550 Vision D
  • Gigabyte Z390 Designare
  • Gigabyte Z490 Vision D
  • Gigabyte Z490 Vision G
  • HP Elitebook 850 G7
If so, we would like to add it to the database:
 
Joined
Mar 21, 2019
Messages
74
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
  • When the system wakes up automatically, does it go back to sleep within 30 to 60 seconds?
  • If so, is that acceptable?
  • If not acceptable, then one has to go through this procedure:
  • The suggestions here are straightforward.
  • Also have a look at the first bullet under Suggestions Contributed by Users.
It does go to sleep but only if Intel Power Gadget is not opened before it tries to sleep.


I honestly wouldn't mind if it wakes up then goes back to sleep but looks like its preventing that. Anyway around it besides remembering to quit the app? :lolno:
 

Attachments

  • Screen Shot 2021-05-05 at 4.07.56 PM.png
    Screen Shot 2021-05-05 at 4.07.56 PM.png
    60.2 KB · Views: 35
  • Screen Shot 2021-05-05 at 4.08.45 PM.png
    Screen Shot 2021-05-05 at 4.08.45 PM.png
    89.9 KB · Views: 33
Joined
Jun 18, 2010
Messages
130
Motherboard
z390 Designaire
CPU
i9-9900K
Graphics
AMD Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. Lisa
  5. Plus
  6. Portable
  7. Power Mac
  8. PowerBook
  9. Quadra
Mobile Phone
  1. iOS
It does go to sleep but only if Intel Power Gadget is not opened before it tries to sleep.


I honestly wouldn't mind if it wakes up then goes back to sleep but looks like its preventing that. Anyway around it besides remembering to quit the app? :lolno:
IPG prevents sleep while it is running. Should auto sleep after quit. UserEventAgent can be killed in the terminal, which will usually restore auto sleep function.
Code:
ps -ef | grep UserEventAgent | grep -v grep | awk '{print $2}'| sudo xargs kill -9
 
Joined
Mar 21, 2019
Messages
74
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
IPG prevents sleep while it is running. Should auto sleep after quit. UserEventAgent can be killed in the terminal, which will usually restore auto sleep function.
Code:
ps -ef | grep UserEventAgent | grep -v grep | awk '{print $2}'| sudo xargs kill -9
Sweet! ok so just to clarify for myself...

Do I need to quit IPG every time I want to put it to sleep or will the code you posted be a full fix needing to only be run once and from there on I can keep IPG running every time in the background before sleep?

Also incase it has negative effects, what is the code to reverse what the line of code does that you posted?
 
Joined
Dec 22, 2019
Messages
64
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Dear @CaseySJ, today I was trying to overclock my i5-9600K. When I restarted, macOS didn’t start. Then I restarted it again and the BIOS got stuck. So I decided to make it another day. I put back the BIOS as before. But, when I restarted macOS, some software didn’t work anymore, properly, such Cubase; it was not running some VST and then crashed multiple times. Any thought. Thanks.
 
Last edited:
Joined
May 10, 2014
Messages
11
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Hi all,
I work since 1 year with my Mojave Hackintosh without any bug or problem. Thanks to CaseySJ for his wonderful tutorial.

I'm considering switching to Big Sur so I've downloaded the OpenCore 0.6.7 EFI of CaseySJ and followed the procedure for edit the SMBIOS. I created a USB Install Mac OS Big Sur and put the EFI folder in the EFI partition of the key.

If I boot on the USB Key and select my Mojave Hackintosh, I am still stuck on the black screen with the apple logo. Same thing if I select "Install Mac OS Big Sur"

My computer :
Z390 Designare
i9-9900K
64Gb Ram Corsair
Asus Strix RX580
Fractal Design R6

I've added "SSDT-UIAC-DESIGNARE-Z390-FD-DEFINE-R6-USB2-ON-TB-V3.aml & SSDT-Z390-DESIGNARE-RX580-V2.aml" in the ACPI Folder and in my config.plist.

Can you help me ?
 
Joined
Apr 24, 2019
Messages
16
Motherboard
Z390 Designare
CPU
i7-8700K
Graphics
UHD 630
Nope. They said it doesn’t matter if the firmware is flashed or not, and they said they need to remote control the computer. Honestly, for a price of a base Mac mini I don’t think it’s a fair trade.
Apparently they are laughing. Let's wait until no one pays them, or pays them so little that they think twice.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,104
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi all,
I work since 1 year with my Mojave Hackintosh without any bug or problem. Thanks to CaseySJ for his wonderful tutorial.

I'm considering switching to Big Sur so I've downloaded the OpenCore 0.6.7 EFI of CaseySJ and followed the procedure for edit the SMBIOS. I created a USB Install Mac OS Big Sur and put the EFI folder in the EFI partition of the key.

If I boot on the USB Key and select my Mojave Hackintosh, I am still stuck on the black screen with the apple logo. Same thing if I select "Install Mac OS Big Sur"

My computer :
Z390 Designare
i9-9900K
64Gb Ram Corsair
Asus Strix RX580
Fractal Design R6

I've added "SSDT-UIAC-DESIGNARE-Z390-FD-DEFINE-R6-USB2-ON-TB-V3.aml & SSDT-Z390-DESIGNARE-RX580-V2.aml" in the ACPI Folder and in my config.plist.

Can you help me ?
Hello @niquau,

Are you following the procedure shown here?

Screen Shot 2021-05-06 at 6.11.51 AM.png
 
Joined
Oct 25, 2019
Messages
61
Motherboard
Gigabyte Z390 Designare
CPU
I7-9700K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey guys,

Is the Fully Bootable Backup Procedure for BIG SUR identical to the Catalina version as stated in the Mini Guide or is there some changes to be aware of? I searched but could not find anything related.

Trying it ATM. Cant break anything I guess.

Thank you
 
Last edited:
Top