Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jul 29, 2012
Messages
94
Motherboard
Gigabyte Desingnare
CPU
i9-9900
Graphics
Sapphire Pulse RX 580 8GB
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello everyone, sorry for this question. I'm looking for the latest update from Cathalina to Big sure. Any help will be fantastic. I need to update FCPX, and I can't.
My actual version is Cathalina 10.15.3 (19D76)
Thanks for all your hard work
 
Joined
Apr 4, 2011
Messages
110
Motherboard
Gigabyte Designare Z390 - F6
CPU
i5-9600
Graphics
Sapphire Pulse RX550
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi @CaseySJ,

I just wanted to follow up on the USB issues I was having a while ago. Basically, my SSL UF8 controller was freezing up all the USB ports.

I tried everything, and in the end the ONLY solution was an Inatek PCIe card (KT4004).

Basically, solution 1 found in the Best practices guide didn't work. I purchased a pluggable 10-port USB 2.0 hub but the freezes continued.

You may want to update the guide as keeping USB 2.0 and 3.0 devices separated or on a USB 2.0 hub plugged into HS09 or HS10 did not solve the issues - only using the PCI card to bypass the Intel controller altogether worked.

Also, it may be worth mentioning that most USB 2.0 devices work fine on the built-in USB 3 and 2 ports.

Out of the 11 USB devices I have tried, only 2 have given me issues - both are in fact USB 2.0 hubs with USB 1 devices attached and are the SSL UF8 and Qcon Pro X DAW controllers. As long as these devices are plugged into the PCI card the system is completely stable.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,278
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ, now the only issue is that when I go back to my custom USB Kext, the Bluetooth stops working. Are you able to modify this for me to disable the Fenvi ports and enable the bluetooth port?

I am not certain how to modify this.
  • Are you using Broadcom Bluetooth or Intel Bluetooth?
  • The USBPorts kext already disables HS12, where supposedly the Fenvi Broadcom Bluetooth was connected.
  • If you are using Intel Bluetooth, have you physically removed the Fenvi PCIe card?
  • The USBPorts kext already enables HS14, where Intel Bluetooth is connected.
Conclusion:
  • If you're trying to use Intel Bluetooth and the Fenvi card is physically removed, then your USBPorts kext is already set up correctly.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,278
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ,

I just wanted to follow up on the USB issues I was having a while ago. Basically, my SSL UF8 controller was freezing up all the USB ports.

I tried everything, and in the end the ONLY solution was an inatek PCIe card (KT4004).

Basically, solution 1 found in the Best practices guide didn't work. I purchased a pluggable 10-port USB 2.0 hub but the freezes continued.

You may want to update the guide as keeping USB 2.0 and 3.0 devices separated or on a USB 2.0 hub plugged into HS09 or HS10 did not solve the issues - only using the PCI card to bypass the intel controller altogether worked.

Also, it may be worth mentioning that most USB 2.0 devices work fine on the built-in USB 3 and 2 ports.

Out of the 11 usb devices I have tried, only 2 have given me issues - both are in fact USB 2.0 hubs with USB 1 devices attached and are the SSL UF8 and Qcon Pro X DAW controllers. As long as these devices are plugged into the PCI card the system is completely stable.
I've added a reference to this post in the USB 2.0 Best Practices guide. Seems that Solution 2 worked in this case.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,278
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello everyone, sorry for this question. I'm looking for the latest update from Cathalina to Big sure. Any help will be fantastic. I need to update FCPX, and I can't.
My actual version is Cathalina 10.15.3 (19D76)
Thanks for all your hard work
Have you seen the Quick Reference spoiler at the top of Post 1?
 
Joined
Nov 7, 2013
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
  • Are you using Broadcom Bluetooth or Intel Bluetooth?
  • The USBPorts kext already disables HS12, where supposedly the Fenvi Broadcom Bluetooth was connected.
  • If you are using Intel Bluetooth, have you physically removed the Fenvi PCIe card?
  • The USBPorts kext already enables HS14, where Intel Bluetooth is connected.
Conclusion:
  • If you're trying to use Intel Bluetooth and the Fenvi card is physically removed, then your USBPorts kext is already set up correctly.

I am now using the Intel WiFi/Bluetooth (Kexts that were in your build). I have physically removed the Fenvi PCIe card that has both WiFi and Bluetooth. When I am using the 'USBInjectAll-071' and 'USBInjectAll-076' files, both the Intel WiFi Bluetooth work. When I switch over to my USBPorts.kext though, the WiFi works, but the Bluetooth does not.


USBPorts.Kext enabled (No Bluetooth)
Screen Shot 2021-05-04 at 8.56.40 AM.png



UsbInjectAll kexts enabled (Bluetooth Works)
Screen Shot 2021-05-04 at 9.00.11 AM.png
 
Last edited:
Joined
Sep 21, 2013
Messages
1,025
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Hello again,

I installed Little Snitch. Now my hacki is a bit broken. Little Snitch changed the system Language. If I go to System Preferences -> Language & Region, I get this message "Could not load Language & Region preference pane." and some software didn't work anymore. They are not blocked by Little Snitch, they won't start (Ableton, Telegram). I deinstalled LS, but nothing changed. Most other programs (Adobe stuff, Reaper, Sononym) work normally. I tried to use Time Machine but it won't work. I have read in the forum that I should boot into Recovery Mode and then reinstall Mojave (14.4).

What's the best way to do? Should I upgrade to the newest version of Mojave (14.6) or should I just try to reinstall the current version? Are there any other things that I must consider? Or is there an easier way to fix this?

Thx for the help.
FWIW, I've recently removed the paid app "Little Snitch" from all of my Mojave and Big Sur machines because of ongoing problems with file sharing and screen sharing –despite massaging the rules and filters. Even if it's "Off" there are sharing issues, so it's gone.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,278
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I am now using the Intel WiFi/Bluetooth (Kexts that were in your build). I have physically removed the Fenvi PCIe card that has both WiFi and Bluetooth. When I am using the 'USBInjectAll-071' and 'USBInjectAll-076' files, both the Intel WiFi Bluetooth work. When I switch over to my USBPorts.kext though, the WiFi works, but the Bluetooth does not.


USBPorts.Kext enabled (No Bluetooth)View attachment 517489


UsbInjectAll kexts enabled (Bluetooth Works)
View attachment 517492
Apologies! I really should drink my morning coffee before replying. :)
  • Your USBPorts kext is missing HS14.
  • Please try the attached SSDT that has the following changes:
    • HS14 added
    • HS01 deleted (USB 2.0 devices on front panel USB-C port will not connect)
  • This keeps the number of USB ports at 15.
 

Attachments

  • USBPorts-HS14-No-HS01.kext.zip
    2.7 KB · Views: 27
Joined
Jul 29, 2012
Messages
94
Motherboard
Gigabyte Desingnare
CPU
i9-9900
Graphics
Sapphire Pulse RX 580 8GB
Mac
  1. iMac
Mobile Phone
  1. iOS
Have you seen the Quick Reference spoiler at the top of Post 1?
Yes, I did. I'm a bit confused. Do I use the same steps as the Z490?
Also, what will be better, a brand new installation or update?
Thanks again.
Casey, you ROCK man
 
Top