Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Apr 20, 2021
Messages
138
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
@Inqnuam

A little mention of HackinDROM app on YouTube:
Uh oh...

Peter Paul Chato.jpg
 
Joined
Apr 20, 2021
Messages
138
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
Okay, I'm a total idiot.

I have a second internal that I use as by clone both for EFI and boot. In all my OC shenanigans, I failed to notice that when I was going back to my Clover loader, the new BIOS changed the default UEFI to the clone's EFI which DID in fact have Radeon Boost.

Once I installed and configured RB in OC, my Radeon speeds are where they were in Clover.

Sorry to have wasted time, but I guess we (I) know that RB DOES IN FACT speed up Radeon cards in Catalina. In GB5, I'm seeing 71321 with my internal Vega 64, and 85733 with the eGPU VII (it was 90k in Clover). Perhaps I have to add the 2nd RB aml for slot2 as well. I might try that and see if two amls can coexist.

Thanks for all the help!
J
Hi there @SmackAttack ,

In Big Sur with OC 0.6.8, the graphics response from my music production software is so bad, it's unusable. I am wondering if this Radeon Boost might help, but I know nothing about it.

Is there a guide to installing/using it, or is it something that can be done relatively easily in just a few steps? I have a Sapphire RX 580 4GB.

Thanks!
 
Joined
May 23, 2017
Messages
74
Motherboard
Designare z390
CPU
i9-9900k
Graphics
Vega64
Mac
  1. iMac
Hi there @SmackAttack ,

In Big Sur with OC 0.6.8, the graphics response from my music production software is so bad, it's unusable. I am wondering if this Radeon Boost might help, but I know nothing about it.

Is there a guide to installing/using it, or is it something that can be done relatively easily in just a few steps? I have a Sapphire RX 580 4GB.

Thanks!
I wouldn’t expect your performance to be that bad without it. My internal Vega 64 was maybe a tiny bit low on the Geekbench score, but not nearly as bad as my Radeon VII in the Sonnet eGFX chassis. However, installing the Radeon boost did significantly help both, and now they’re scoring above all the Geekbench benchmarks.
Casey has a link on post #1 somewhere that will take you to the Radeon Boost thread (where you’ll find the install files) but I can tell you you need three things:
1) the .aml that corresponds to your GPU slot configuration.
2) the Radeon Boost kext.
3) your OC config that includes both of those.
Give it a shot!
J
 
Joined
Apr 20, 2021
Messages
138
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
I wouldn’t expect your performance to be that bad without it. My internal Vega 64 was maybe a tiny bit low on the Geekbench score, but not nearly as bad as my Radeon VII in the Sonnet eGFX chassis. However, installing the Radeon boost did significantly help both, and now they’re scoring above all the Geekbench benchmarks.
Casey has a link on post #1 somewhere that will take you to the Radeon Boost thread (where you’ll find the install files) but I can tell you you need three things:
1) the .aml that corresponds to your GPU slot configuration.
2) the Radeon Boost kext.
3) your OC config that includes both of those.
Give it a shot!
J
Awesome! Thank you very much for your quick reply. :)
 
Joined
May 23, 2017
Messages
74
Motherboard
Designare z390
CPU
i9-9900k
Graphics
Vega64
Mac
  1. iMac
Joined
May 23, 2017
Messages
74
Motherboard
Designare z390
CPU
i9-9900k
Graphics
Vega64
Mac
  1. iMac
It’s post 19,314:
Heads up it says not to install the .aml for your card.
 
Joined
Apr 20, 2021
Messages
138
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
Heads up it says not to install the .aml for your card.
Yes, thank you!

I saw that and thought, Oh, ok this should be easier... :rolleyes:

I followed all the instructions, and rebooted and then got the Apple logo... no progress bar, and stuck. Got back in with my installation USB device and am trying to figure it out.

Using OCC 2.36.0.0, in the Kernel section, all the entries have an ExecutablePath of: Contents/MacOS/xxxxxxx
If I put one in for RadeonBoost, I get the stuck Apple. If I go in and wipe that out and leave it blank, then all is good... but I assume RadeonBoost likely is NOT working, and there is some other "secret steps" that weren't mentioned or have changed recently.

Anyone?
 
Joined
Apr 20, 2021
Messages
138
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
Ah, right forgot to clarify that:
You need to leave the "ExecutablePath" empty, and fill "Contents" in to be "Contents/Info.plist."
Then make sure you've got the check box enabled if you're using OCC.

Make sense?
Awesome man! I appreciate your help... OK, going to try that now.
 
Joined
Apr 20, 2021
Messages
138
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
Awesome man! I appreciate your help... OK, going to try that now.
Ok, yep, that's how I last left it.

I suppose it's running then... Is there a quick way to confirm if it's running or not?
 
Top