Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Nov 7, 2013
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
I am posting this from my Z390 Designare Test Bench running the OpenIntelWireless drivers in macOS 11.4 Beta 1.
  • WiFi
    • No issue with scanning for available networks
    • No issue connecting to my WPA2 protected home network
  • Bluetooth
    • No problem with Keychron K1 keyboard
    • But there is connection problem with Logitech Master MX 3 mouse
I have to ask: Have you connected the two-pole antenna to the two coaxial connectors on the rear IO panel?
View attachment 516726View attachment 516725
Yes, I used the Gigabyte antenna to connect to the back. I just remembered that I am using a custom USB kext. Could that be why it’s not working? I’m not sure how to update the Fenvi ports to the other ports of the kext :/
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,262
Motherboard
Asus Z370-A Prime II
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Just so we're clear, this is the chip on the ASRock W480 Creator Thunderbolt daughterboard:View attachment 516710
This chip was a pain in the rear for me. I wish I had found that link before messing around with it.

My EX4 card has it, and I broke it somehow. Luckily, its off getting repaired now, and I was able to get the firmware off it on a rare successful set of reads.

Good job on being careful and doing the research. You love to see it.
 
Joined
Jun 13, 2019
Messages
269
Motherboard
Gigabyte Z690 Aero G DDR4
CPU
i9-12900K
Graphics
RX 6900 XT
Interesting. So you observe the same behavior as I do with Logitech products via the Bluetooth connection under MacOS. First the device connects and then disconnects a second later.
What's even crazier is that the Bluetooth connection under Windows 10 is absolutely stable and the other Bluetooth devices (e.g. JBL Pulse 2) also work. So it has to be related to the kext somehow.
I also have the issue with Logitech devices. MX Anywhere 3 and MX Keys for Mac are unusable with Intel BT on macOS.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,361
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yes, I used the Gigabyte antenna to connect to the back. I just remembered that I am using a custom USB kext. Could that be why it’s not working? I’m not sure how to update the Fenvi ports to the other ports of the kext :/
First use the EFI provided in this thread as-is with no modifications except for PlatformInfo credentials.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,361
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Unfortunately, I need to come back on this one. It seems that the two 2.0 USB ports on the front of my Fractal R6 case are not working anymore. The 3.0 USB ports are working fine. What do you advise @CaseySJ ?

Currently, I'm using this SSDT:
Please post that USB SSDT and I'll take a look. Does it have a maximum of 15 ports defined (Package size = 0x1E)? And XhciPortLimit is disabled in config.plist?
 
Joined
Nov 7, 2013
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
First use the EFI provided in this thread as-is with no modifications except for PlatformInfo credentials.
EDIT: I fixed it.... I had to disable the two ACPI files :banghead:


@CaseySJ - Okay I just did that. I am at a complete loss as to why its not working. I turned off my custom kext and used your direct setup from HackinDROM, and still no success....

Screen Shot 2021-04-28 at 1.17.33 PM.png
Screen Shot 2021-04-28 at 1.18.13 PM.png
Screen Shot 2021-04-28 at 1.19.06 PM.png
Screen Shot 2021-04-28 at 1.17.59 PM.png

IMG_7262.jpg
 
Last edited:
Joined
Nov 7, 2013
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
@CaseySJ, now the only issue is that when I go back to my custom USB Kext, the Bluetooth stops working. Are you able to modify this for me to disable the Fenvi ports and enable the bluetooth port?

I am not certain how to modify this.
 

Attachments

  • USBPorts.kext
    512 bytes · Views: 16
Joined
Nov 7, 2013
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Hi, i have the same issues. Which ACPI files did you disable?


Disable:
SSDT-DESIGNARE-Z390-NO-CNVW.aml
SSDT-UIAC-DESIGNARE-Z390-V7.aml

Enable:
SSDT-UIAC-DESIGNARE-Z390-V7D.aml

@Inqnuam, not sure if it is possible but HackinDROM can possibly override the above setups if someone selects any of the IntelWifi builds.
 
Last edited:
Joined
May 15, 2020
Messages
1,172
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Disable:
SSDT-DESIGNARE-Z390-NO-CNVW.aml
SSDT-UIAC-DESIGNARE-Z390-V7.aml

Enable:
SSDT-UIAC-DESIGNARE-Z390-V7D.aml

@Inqnuam, not sure if it is possible but HackinDROM can possibly override the above setups if someone selects any of the IntelWifi builds.
I didn't understand what is the issue, could you please explain it, with an example if possible ?
 
Top