Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Aug 18, 2020
Messages
4
Motherboard
Gigabyte Designare Z390
CPU
i5-9600kf
Graphics
RX 5700 XT Sapphire Nitro+
Haven't seen this problem reported before. Some questions:
  • What do you mean by "invisible"?
  • What is the make/model of the monitor?
  • Are you using a DP or HDMI cable?
  • Are there any video adapters attached (such as DP to DVI, etc.)?
  • It's very strange but is literally invisible. I can interact with the apps window via mouse or keyboard but I just see the wallpaper.
  • Two monitors:
    • LG 4K HDR 27UL650-W -> HDMI
    • Samsung C24FG78x -> DP
  • No adapters
 
Joined
Jul 3, 2010
Messages
297
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
** Update on OpenIntelWireless Drivers **

On my Designare Z390, the latest 2.0.0-alpha drivers (released on April 24) fail to connect to either the 2.4GHz or 5.0GHz band on my Orbi Mesh 802.11ac router. However, the versions created on Mar 29 are able to connect to both 2.4GHz and 5.0GHz bands.

If you would like to test the 2.0.0-alpha drivers on your Z390 Designare using the Mar 29 drivers, please do the following (supports Catalina, and Big Sur):

EFI Prep:
  • Download the attached EFI folder.
  • Rename the parent folder from OC-068-DESIGNARE-Z390-INTEL-WIRELESS to --> EFI
  • If you have an AMD GPU, rename the file config-AMD-GPU.plist to config.plist
  • If you do not have AMD GPU, rename the file config-Intel-iGPU.plist to config.plist
  • Open config.plist in OpenCore Configurator and go to the PlatformInfo --> DataHub page.
  • Transfer the five highlighted values from your existing config.plist into this new config.plist
View attachment 516310
  • Save the file.
  • Locate a USB flash disk with an EFI partition (or erase a USB flash disk in Disk Utility with Format = MacOS Journaled and Scheme = GUID Partition Map)
  • Copy the new EFI folder to the EFI partition of the USB flash disk.
System Prep:
  • Shutdown the system and flip PSU power switch to OFF.
  • Physically remove the Fenvi or other WiFi/BT PCIe card.
  • Physically disconnect the Bluetooth USB cable.
Begin Test:
  • Connect USB flash disk to system and power it up.
  • At Gigabyte splash screen, press F12 to open BIOS Boot Menu (not OpenCore Picker)
  • Select the USB flash disk.
  • When OpenCore Picker appears, select the normal macOS disk.
On the 802.11n network 5GHz band:
View attachment 516331
Hey CaseySJ, thanks so much for your patience and the new OpenWireless EFI. I still had some issues with it on my system but I think I resolved it. First, it looks like the versions of the driver in the new EFI are the 1.3 version for Catalina and Big Sur, but 2.0 for Mojave. Was that intentional? Anyway, I was still having issues with getting both the Wifi and the Bluetooth to work at the same time with the new EFI. I had the same issue when I first started using the drivers though, so I implemented the same solution, which was to deactivate the IntelBluetoothInjector.kext in the config.plist. I updated the Catalina and Big Sur kexts with the version dated April 21st (Debug version) and it works properly now with the new EFI. Wifi speeds are greatly improved now that I'm connecting with the 802.11ac instead of 11n. Thanks!
 

Attachments

  • AirportItlwm-Big_Sur-v2.0.0-DEBUG-alpha-ee005a1.zip
    12.5 MB · Views: 26
  • AirportItlwm-Catalina-v2.0.0-DEBUG-alpha-ee005a1.zip
    12.5 MB · Views: 27
  • Screen Shot 2021-04-26 at 1.27.03 PM.png
    Screen Shot 2021-04-26 at 1.27.03 PM.png
    136.3 KB · Views: 24

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,965
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
  • It's very strange but is literally invisible. I can interact with the apps window via mouse or keyboard but I just see the wallpaper.
  • Two monitors:
    • LG 4K HDR 27UL650-W -> HDMI
    • Samsung C24FG78x -> DP
  • No adapters
Big Sur 11.3 was officially released this morning. Although not guaranteed to fix this problem, it's worth upgrading because of continuous improvements to graphics drivers.

Have you been able to characterize the problem to determine the conditions under which it does and does not occur? For example:
  • When the problem occurs, does it always occur on the HDMI monitor or the DP monitor?
  • If it always occurs on HDMI monitor, then what happens if you disconnect that monitor? Does it ever move to the DP monitor? (And vice versa.)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,965
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey CaseySJ, thanks so much for your patience and the new OpenWireless EFI. I still had some issues with it on my system but I think I resolved it. First, it looks like the versions of the driver in the new EFI are the 1.3 version for Catalina and Big Sur, but 2.0 for Mojave. Was that intentional?
Ouch, I could have sworn I posted the right ZIP, but alas my mistake! I've taken your April 21 binaries and copied them into the ZIP.

Anyway, I was still having issues with getting both the Wifi and the Bluetooth to work at the same time with the new EFI. I had the same issue when I first started using the drivers though, so I implemented the same solution, which was to deactivate the IntelBluetoothInjector.kext in the config.plist. I updated the Catalina and Big Sur kexts with the version dated April 21st (Debug version) and it works properly now with the new EFI. Wifi speeds are greatly improved now that I'm connecting with the 802.11ac instead of 11n. Thanks!
Interesting. On both my Z390 Designare and Z490 Vision D I am able to activate and use both IntelBluetoothInjector and AirportItlwm at the same time. If there are no other WiFi and Bluetooth devices in the system, and if USB port HS14 is activated, then both drivers should work. Odd...
 
Joined
Aug 18, 2020
Messages
4
Motherboard
Gigabyte Designare Z390
CPU
i5-9600kf
Graphics
RX 5700 XT Sapphire Nitro+
Big Sur 11.3 was officially released this morning. Although not guaranteed to fix this problem, it's worth upgrading because of continuous improvements to graphics drivers.

Have you been able to characterize the problem to determine the conditions under which it does and does not occur? For example:
  • When the problem occurs, does it always occur on the HDMI monitor or the DP monitor?
  • If it always occurs on HDMI monitor, then what happens if you disconnect that monitor? Does it ever move to the DP monitor? (And vice versa.)
I'm using both monitors and the problem always occur on both. To solve the problem I just close and open the apps again. Print Screen attached.
 

Attachments

  • window-invisble.jpg
    1.5 MB · Views: 33

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,965
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks, I will get the Thunderbolt adapter and report back. The old firewire card was recommended here around 2013, I think.
There's no guarantee that a different card will solve the problem, but I believe it's worth trying. Best to buy from a retailer that allows easy returns.
 
Joined
Aug 23, 2018
Messages
373
Motherboard
Gigabyte Z690 Aorus Master
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hey guys,

Sometimes when I unlock my system all windows blink and get invisible. This already happened to anyone?

Open Core: REL-066-2021-02-02
MacOS: BigSur 11.2.3 (20D91)
Radeon Shapphire Nitro+ 5700 XT
Designare Z390
iMac19,1
Boot args: keepsyms=1 dart=0 debug=0x100 agdpmod=pikera alcid=11 shikigva=80 igfxfw=2
If Big Sur, no need for shikigva=80.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,965
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Joined
Aug 23, 2018
Messages
373
Motherboard
Gigabyte Z690 Aorus Master
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
@fenrrir,

And because your CPU has no iGPU, igfxfw=2 is not needed. For DRM using AMD GPU, we can set shikigva = 128.

View attachment 516457

DRM Compatibility on macOS 11​

Things to keep in mind:

  • All kinds of software DRM decoders were removed from macOS 11
  • All kinds of legacy hardware DRM decoders (e.g. NVIDIA VP3) were removed from macOS 11
  • WhateverGreen Shiki functionality is not planned for inclusion for macOS 11
  • AMD GPU video decoder preference can be chosen through preferences overrides for some types of DRM content (like Apple TV and iTunes movie streaming). This preference may not always be compatible with the rest of the operating system and may cause problems with other ways of hardware media decoding and encoding. For this reason such an override is not recommended for daily use and shall only be enabled on demand.
  • Only IGPU-free Mac models allow for full DRM content access given a compatible AMD GPU video decoder
  • For old CPUs (e.g. Xeons or Quad 2 Quad) and supported AMD GPUs injecting unfairgva with <01 00 00 00> value is required for streaming DRM
List of overrides:

  • defaults write com.apple.AppleGVA gvaForceAMDKE -boolean yes forces AMD DRM decoder for streaming services (like Apple TV and iTunes movie streaming)
  • defaults write com.apple.AppleGVA gvaForceAMDAVCDecode -boolean yes forces AMD AVC accelerated decoder
  • defaults write com.apple.AppleGVA gvaForceAMDAVCEncode -boolean yes forces AMD AVC accelerated encoder
  • defaults write com.apple.AppleGVA gvaForceAMDHEVCDecode -boolean yes forces AMD HEVC accelerated decoder
  • defaults write com.apple.AppleGVA disableGVAEncryption -string YES forces AMD HEVC accelerated decoder
  • defaults write com.apple.coremedia hardwareVideoDecoder -string force forces hardware accelerated video decoder (for any resolution)
  • defaults write com.apple.coremedia hardwareVideoDecoder -string disable disables hardware accelerated video decoder (in QuickTime / Apple TV)
 
Top