Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Mar 14, 2020
Messages
12
Motherboard
Laptop make & model # > See Rules!
CPU
i7-4720HQ
Graphics
HD 4600
That's much better. GC-Titan Ridge is on PC01.BR1A. Please try the attached SSDT in combination with SSDT-DTGP.aml.
  • Copy the attached SSDT to OC/ACPI folder.
  • Add a reference in config.plist --> ACPI section.
  • Check that a reference to SSDT-DTGP.aml still exists.
  • Disable any previous Thunderbolt SSDT.
  • Reboot.
  • Post a screenshot of PC01.BR1A section of IORegistryExplorer to confirm.
Thanks a lot. I will try it later and post my result.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,951
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ
Have you tried Screen Mirroring from Big Sur to Apple TV?

I’m using iMacPro1,1 with only AMD GPU (no iGPU in my CPU)
shikigva=128
I’ve the sound but not the video
It used to fully work in Catalina
Any idea what I can do?
I'll try that later today and update this post.
Got sidetracked by recurring problems with 11.3 Beta 4 (IONVMeFamily.kext) so I've rolled back to 11.3 Beta 3.
  • I can AirPlay videos to AppleTV connected to an LG OLED TV.
  • I can also screen-mirror to the LG via the same AppleTV (Family Room).
(From the Z490 Vision D using iMac19,1 and running 11.3 Beta 3.)
Screen Shot 2021-03-19 at 7.16.24 AM.png

IMG_3548-small.jpg

UPDATE: On my B550 Vision D (iMacPro1,1) screen mirroring does not work. I can see the 4-digit code on TV, after which the TV goes blank.
 
Last edited:
Joined
Mar 14, 2020
Messages
12
Motherboard
Laptop make & model # > See Rules!
CPU
i7-4720HQ
Graphics
HD 4600
That's much better. GC-Titan Ridge is on PC01.BR1A. Please try the attached SSDT in combination with SSDT-DTGP.aml.
  • Copy the attached SSDT to OC/ACPI folder.
  • Add a reference in config.plist --> ACPI section.
  • Check that a reference to SSDT-DTGP.aml still exists.
  • Disable any previous Thunderbolt SSDT.
  • Reboot.
  • Post a screenshot of PC01.BR1A section of IORegistryExplorer to confirm.
Thanks for your patch.
I tried and there was my system information about this card. No thunderbolt device plugged.
Is the card working well?
 

Attachments

  • Screen Shot 2021-03-19 at 11.27.13 PM.png
    Screen Shot 2021-03-19 at 11.27.13 PM.png
    298.9 KB · Views: 26
  • Screen Shot 2021-03-19 at 11.28.30 PM.png
    Screen Shot 2021-03-19 at 11.28.30 PM.png
    423.3 KB · Views: 26
  • Screen Shot 2021-03-19 at 11.28.43 PM.png
    Screen Shot 2021-03-19 at 11.28.43 PM.png
    474.3 KB · Views: 25
  • Screen Shot 2021-03-19 at 11.32.51 PM.png
    Screen Shot 2021-03-19 at 11.32.51 PM.png
    1.4 MB · Views: 29
Joined
Mar 21, 2011
Messages
816
Motherboard
GA-Z390-Designare
CPU
i7-9700K
Graphics
RX 590
Of course,
1. I've flashed "GC-ALPINE-RIDGE-NVM21-V3-NATA.bin". It was the one listed in the tutorial. (There was another 2, but I read that some issues were reported with V1 and V2, so I tried V3 (Its an GC-Alpine Ridge PCI-E card.)

2. With the original firmware I needed to start windows, put the devices and restart into macOS Big Sur. It worked but a low speed (800Mb/s). My goal is to make it work directly on Mac and at full speed (or closest to) without the need of enter Windows.

The first time I did the procedure without the SSDT the thunderdrive gave me speeds up to 1500 Mb/s (more or less), and, after the SSDT it went up to 2200 Mb/s, on the other hand, the Terramaster worked, but the Terramaster Qnap array didn't, until I flashed the card and put the SSDT, then it did work.

Thank you
With my Alpine Ridge card, I have had better luck with the V1 and V2 firmware (by Elias) than with the V3 (NATA). I saw the caution about reported problems. But, if it were me, I would try both V1 and V2.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,951
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks for your patch.
I tried and there was my system information about this card. No thunderbolt device plugged.
Is the card working well?
Please replace the Thunderbolt SSDT with the new version attached here. Then reboot and post just the following screenshots:
  • System Information --> Thunderbolt
  • IORegistryExplorer --> BR1A section (Thunderbolt device tree)
 

Attachments

  • SSDT-TB3-HackinDROM-GC-TR.aml
    2.2 KB · Views: 23
Joined
Mar 14, 2020
Messages
12
Motherboard
Laptop make & model # > See Rules!
CPU
i7-4720HQ
Graphics
HD 4600
Please replace the Thunderbolt SSDT with the new version attached here. Then reboot and post just the following screenshots:
  • System Information --> Thunderbolt
  • IORegistryExplorer --> BR1A section (Thunderbolt device tree)
A breakthrough has been made!
In System Information --> PCI, intel JHL7540 Titan Ridge Thunderbolt 3 NHI and intel JHL7540 Titan Ridge USB 3.1 appeared.
USB 3.1 device does not work. I do not have a Thunderbolt device now. I will buy one and test it tomorrow.
 

Attachments

  • Screen Shot 2021-03-20 at 00.50.59.png
    Screen Shot 2021-03-20 at 00.50.59.png
    313.7 KB · Views: 33
  • Screen Shot 2021-03-20 at 00.51.48.png
    Screen Shot 2021-03-20 at 00.51.48.png
    1.9 MB · Views: 35

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,951
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
A breakthrough has been made!
In System Information --> PCI, intel JHL7540 Titan Ridge Thunderbolt 3 NHI and intel JHL7540 Titan Ridge USB 3.1 appeared.
USB 3.1 device does not work. I do not have a Thunderbolt device now. I will buy one and test it tomorrow.
With NVM 50, USB-C devices may only work if they are connected before boot. You may also try NVM 33 from Designare Z390 to see if USB-C devices can hot-plug.
 
Joined
Mar 14, 2020
Messages
12
Motherboard
Laptop make & model # > See Rules!
CPU
i7-4720HQ
Graphics
HD 4600
With NVM 50, USB-C devices may only work if they are connected before boot. You may also try NVM 33 from Designare Z390 to see if USB-C devices can hot-plug.
I will try it. Does NVM 33 for Designare Z390 support JHL7540 too?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,951
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I will try it. Does NVM 33 for Designare Z390 support JHL7540 too?
Yes. But keep in mind that there will be some “eccentricities” with any flashed controller. It won’t be perfect.
 
Joined
Jan 3, 2011
Messages
49
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 590
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Attached is a slightly modified Thunderbolt SSDT that at least removes DSB4 (because you have only one Thunderbolt port) and also removes some extraneous NHI0 properties.

Everything else seems to be configured properly. You have an NVMe SSD attached to the Thunderbolt port.
  • Was this device attached prior to booting?
  • Are you able to hot-plug this device?
  • Do you have any other Thunderbolt devices?

Follow-up suggestions:
  • If you can install Linux on a USB flash disk and boot from that, we can use Linux to obtain the Thunderbolt DROM. (I can show you the procedure.)
    • However, using the correct Thunderbolt DROM may or may not make a difference.
  • Reading the Thunderbolt firmware with an SPI ROM reader should be the last resort. But if all else fails I can modify your on-board Thunderbolt firmware. (But please keep the risks in mind.)
Hi @CaseySJ

I managed to install Linux on a USB stick.
As you mentioned how to proceed from Ubuntu.

Thanks.
 
Top