Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Anyone have trouble installing

XFX RX 5700 Xt Thicc III Ultra 8GB​

I was trying to upgrade but now the screen wont boot. Any work around this?
In boot-args please check if you have agdpmod=pikera
 
Joined
Apr 1, 2020
Messages
93
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
You did it correctly. Namely:
  • Open HackinDROM website, select Copy Config, and choose your Clover config.plist.
  • From the drop-down menu, choose Z390 Designare OC 065 AMD GPU - Casey SJ.
  • Click the COPY button followed by the disk icon.
  • A new config.plist will be downloaded.
  • Copy this file to the OpenCore 0.6.5 OC folder. The name must remain the same: config.plist
@CaseySJ Have the same results with OC 0.6.5. Let me know if you need something specific from me.
 

Attachments

  • Screen Shot 2021-02-04 at 10.53.30 AM.png
    Screen Shot 2021-02-04 at 10.53.30 AM.png
    339.7 KB · Views: 31
  • Img.png
    Img.png
    1.2 MB · Views: 43

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Have the same results with OC 0.6.5. Let me know if you need something specific from me.
Puzzling...
  • Which version of BIOS are you running? F9g, F9i, F9j?
  • What is the make/model of your USB flash drive?
  • Which USB port is it connected to?
  • Other than macOS, which other operating systems are installed?
  • Have you tried CMOS Reset (which requires configuring BIOS parameters again, starting with F7 to Load Optimized Defaults)?
 
Joined
Apr 1, 2020
Messages
93
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Puzzling...
  • Which version of BIOS are you running? F9g, F9i, F9j?
  • What is the make/model of your USB flash drive?
  • Which USB port is it connected to?
  • Other than macOS, which other operating systems are installed?
  • Have you tried CMOS Reset (which requires configuring BIOS parameters again, starting with F7 to Load Optimized Defaults)?
Using BIOS F9g
Using a MicroCenter USB 3.1 32GB stick
Using Blue USB 3.0 Port
No other OS's installed
No on the CMOS reset.

I was going to try another USB still and different port next.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Using BIOS F9g
Using a MicroCenter USB 3.1 32GB stick
Using Blue USB 3.0 Port
No other OS's installed
No on the CMOS reset.

I was going to try another USB still and different port next.
After trying (a) another USB, (b) different USB port, and (c) CMOS Reset, if the problem still occurs then please compress the entire EFI folder (remove serial numbers from config.plist) and post. I will try to boot my system with an exact copy of your EFI (but with my serial numbers).
 
Joined
May 15, 2020
Messages
1,320
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Please try a cold boot first. If that does not solve the problem, then CMOS Reset!
I'm still on F9j.
What if I go back to F9i?
Will flashing firmware resets CMOS automatically?

Please try build 1.0.6.

New EFI partitions will automatically appear in the window.
Leave the window open and plug a storage with EFI Partition
Mount/Unmount too (ex: if you unmount from EFI Agent/OCC..)
Hope this version solves Windows EFI's issue
 

Attachments

  • HackinDROM EFI (1.0.6).zip
    231.6 KB · Views: 34
Joined
Feb 4, 2020
Messages
46
Motherboard
Designare z390
CPU
i9-9900k
Graphics
RX 580
@CaseySJ Do you know of any issues with enabling CSM support? I cannot boot with it on, but I think it will help me with my display issues (sometimes one screen will stay off when the displays sleep - right now the computer itself is set to never go to sleep, but the issue is the same when that is enabled). Here is a picture of the opencore boot log:
FA543284-4FB2-43DE-9409-574C407F2FE9_1_105_c.jpeg

Both displays are connected via displayport to the rtx 580.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
View attachment 507851
Do i need to put something in between?
Your boot-args are correct.

Please describe exactly what happens when you boot the system.
  • Does OpenCore Picker appear?
  • If so, when you select macOS SSD, then what happens?
  • You can also press CMD-V at the OpenCore Picker to enable "verbose" mode. Then select macOS SSD.
 
Top