Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,786
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Appreciate the assist... idk what any of this means lol
Some questions:
  • Does the boot problem occur occasionally or always?
  • Do you have any Hackintosh kexts installed in /Library/Extensions?
    • If unsure, simply post a screenshot of that folder.
  • Are you on BIOS F9i now?
  • If so, is CFG-Lock disabled in BIOS Setup?
  • What other PCIe or Thunderbolt devices are connected to the system (excluding GPU and WiFi/BT card)?
    • Any 10Gbit Ethernet cards or adapters?
    • Any Thunderbolt audio interfaces?
    • Any Thunderbolt docks?
    • Any SATA or RAID PCIe cards?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,786
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey CaseySJ. Thanks for the update. I've found an issue with my configuration though with this version of OpenCore. I've done all the updates since 0.6.0 with no problems at all. But with this version, though it installs OK, I noticed that I can't do a full proper restart from Big Sur 11.2. I thought it might be Big Sur at first, but when I went back to OC 0.6.5, it restarts fine. I can do a shutdown and then start up fine in OC 0.6.6, but if I restart from Big Sur, it restarts the machine but then hangs with a blank screen when it should be starting open core. Have you or anyone else run into this behavior? Thanks.
OpenCore 0.6.6 changes the implementation of 'bootstrap' in significant ways. This might cause some teething issues.

Some guidelines:
  • At OpenCore Picker, press spacebar to reveal Reset NVRAM and select that option.
  • When system restarts, press Del key to enter BIOS Setup.
  • In the Boot section of BIOS Setup, set Boot Priority #1 to the internal macOS SSD (not "OpenCore" or anything else). On the next reboot this boot priority should change to "OpenCore" automatically, which is correct.
  • Now check if OpenCore Picker appears.
  • If so, boot macOS then go to System Preferences --> Startup Disk and select the default startup disk again.
  • Reboot the computer and see if OpenCore Picker appears properly.
 
Last edited:
Joined
Aug 15, 2014
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Some questions:
  • Does the boot problem occur occasionally or always?
  • Do you have any Hackintosh kexts installed in /Library/Extensions?
    • If unsure, simply post a screenshot of that folder.
  • Are you on BIOS F9i now?
  • If so, is CFG-Lock disabled in BIOS Setup?
  • What other PCIe or Thunderbolt devices are connected to the system (excluding GPU and WiFi/BT card)?
    • Any 10Gbit Ethernet cards or adapters?
    • Any Thunderbolt audio interfaces?
    • Any Thunderbolt docks?
    • Any SATA or RAID PCIe cards?
Happens always when I try to boot from the SSD. I am able to boot into the system off of my USB setup thumb drive.

see photo for Extensions.

bios is 9i and CFG-Lock is disabled.

I have a OWC Thunderbolt 3 dock
 

Attachments

  • image.jpg
    image.jpg
    4.5 MB · Views: 45

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,786
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Happens always when I try to boot from the SSD. I am able to boot into the system off of my USB setup thumb drive.

see photo for Extensions.

bios is 9i and CFG-Lock is disabled.

I have a OWC Thunderbolt 3 dock
  • Does the SSD contain exactly the same EFI folder as the USB thumb drive?
  • Are there any other SSDs or HDDs in the system?
    • If so, do any of them also contain EFI partitions?
    • If so, do any of those EFI partitions contain an EFI folder?
  • Have you considered moving to OpenCore?
    • If so, we will need to delete the 4 Hackintosh kexts highlighted in the image.
    • But before deleting them, please see the mini-guide for replacing Clover with OpenCore.
image.jpg
 
Joined
Aug 15, 2014
Messages
107
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I believe the USB should have the exact same unless the latest version of Clover changed something.

I have a second SSD for Windows, 1 HDD for Mac files, 1 HDD for Windows files, 1 HDD for media collection, and 1 SSD I use as a shared drive to share files between the two operating systems. They do all seem to have EFi as I am able to mount each drive in the Clover configurator.

Not sure what OpenCore is, only really have experience in Clover. But if you're recommending a switch, I'll try it. I Just want a working/stable build that I can update without crashing the whole system every time lol.
 
Joined
May 15, 2020
Messages
1,313
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro

Attachments

  • HackinDROM EFI (v1.0.4).zip
    223.5 KB · Views: 48
Joined
Feb 4, 2020
Messages
46
Motherboard
Designare z390
CPU
i9-9900k
Graphics
RX 580
@CaseySJ @jjsenecal & others
Please guys give a try
View attachment 507514

HackinDROM EFI 1.0.4
Looks good! Very intuitive. Love that it doesn't close the window down like EFI Agent does, and I immediately figured out that double clicking on the name will open it in Finder. I get the 'spinning ball of death' for a few seconds when first clicking on the icon. Besides that, making it more compact would make it faster to use, and also reducing the animation time. Great work! What got you into developing this?
 
Joined
Aug 17, 2019
Messages
130
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
RX 5700 XT
So that list was from back in the CLOVER days and before the Thunderbolt controller flashing was a recommended config.
Yes that is correct and I am currently using those files and have been since moving over to OC. No issues with them at all. Although I have not flashed Thunderbolt so am uncertain if you need anything different for that
 
Joined
Feb 4, 2020
Messages
46
Motherboard
Designare z390
CPU
i9-9900k
Graphics
RX 580
Could you please upload Bios F9i to the forum for those who flashed F9j and want to go to back to F9i?
F9g is still available but its a Beta version, would be nice to have an official release here!

Just found on my iCloud.
Z390 Designare Bios F9i
Are there any benefits to using F9i over F9g? In principle I would guess there must be improvements, but it sure is nice not having to worry about CFG-Lock on F9g. Likewise, should F9j be used if we don't need USB 3.X on thunderbolt?
 
Top