Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jan 3, 2011
Messages
56
Motherboard
ThinkPad T480 OC
CPU
i5 8350U
Graphics
UHD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Btw I activated it via using the SSDT in the Z390 ITX forum, which also uses a jhl6240. Not sure if I'll have to change something else apart from what you just mentioned.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Btw I activated it via using the sSSDT in the Z390 ITX forum, which also uses a jhl6240. Not sure if I'll have to change something else apart from what you just mentioned.
Please try the attached SSDT that includes the following additional NHI0 properties:
  • Thunderbolt DROM
  • linkDetails
  • ThunderboltConfig
  • name
  • model
  • device_type
  • AAPL,slot-name
After rebooting, please post the following for verification:
  • Screenshot of System Information --> Thunderbolt
  • Copy of IOReg file (IORegistryExplorer --> File --> Save As...)
I would like to add this configuration to the Alpine Ridge Repository for the benefit of other ThinkPad T480 OC users. What ACPI rename are you using to rename _INI to XINI?
  • Find: ?
  • Replace: ?
 

Attachments

  • SSDT-TbtOnPch_PINI.aml
    4.5 KB · Views: 32
Joined
Jan 3, 2011
Messages
56
Motherboard
ThinkPad T480 OC
CPU
i5 8350U
Graphics
UHD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Please try the attached SSDT that includes the following additional NHI0 properties:
  • Thunderbolt DROM
  • linkDetails
  • ThunderboltConfig
  • name
  • model
  • device_type
  • AAPL,slot-name
After rebooting, please post the following for verification:
  • Screenshot of System Information --> Thunderbolt
  • Copy of IOReg file (IORegistryExplorer --> File --> Save As...)
I would like to add this configuration to the Alpine Ridge Repository for the benefit of other ThinkPad T480 OC users. What ACPI rename are you using to rename _INI to XINI?
  • Find: ?
  • Replace: ?
<dict>
<key>Comment</key>
<string>Thunderbolt 3: RP09._INI to RP09.XINI for ICM disable</string>
<key>Count</key>
<integer>1</integer>
<key>Enabled</key>
<true/>
<key>Find</key>
<data>X0lOSQ==</data>
<key>Limit</key>
<integer>0</integer>
<key>Mask</key>
<data></data>
<key>OemTableId</key>
<data></data>
<key>Replace</key>
<data>WElOSQ==</data>
<key>ReplaceMask</key>
<data></data>
<key>Skip</key>
<integer>11</integer>
<key>TableLength</key>
<integer>0</integer>
<key>TableSignature</key>
<data></data>
</dict>
 
Joined
Jan 3, 2011
Messages
56
Motherboard
ThinkPad T480 OC
CPU
i5 8350U
Graphics
UHD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Android

Attachments

  • new_t480_v2_ioreg.ioreg
    19.1 MB · Views: 22
  • Screenshot 2021-01-19 at 23.54.41.png
    Screenshot 2021-01-19 at 23.54.41.png
    36.7 KB · Views: 36

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Here are the new files
Looks good.

Please try connecting your ThinkPad to a Mac with a Thunderbolt cable to see if Target Disk Mode works. The Mac, of course, needs to be placed into Target Disk Mode.
 
Joined
Jan 3, 2011
Messages
56
Motherboard
ThinkPad T480 OC
CPU
i5 8350U
Graphics
UHD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Okey. My fault. It seems that the included cable with my MacBook Air doesn't comply with target disk mode, only USB 2.0. That was what actually was happening. Might have to wait on that till I buy one.

Anyway, big thanks for the help and I'll keep you posted!
 
Joined
Aug 19, 2010
Messages
524
Motherboard
GA-Z390 Designare
CPU
i7 9900K
Graphics
UHD630 & Radeon VII
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Hello @CaseySJ,

Thanks for keeping this thread so active and helpful. I am hoping you can help get my Thunderbolt card working on one of my X99 systems. I have flashed cards working very well in 3 other systems including Z390 Designare. But this X99 system seems a bit tricky. I have attached what i think are all relevant files.

The board is X99 Designare, and its quite special as it has an onboard TB3 controller and officially allows you to connect a TB3 card in the last slot as well, with a header. I have not bothered to flash the onboard controller nor the controller on GC-AR card in the last slot as they have always worked well with the usual caveats of not showing a Thunderbolt bus. So I am actually trying to install a third Thunderbolt controller on this system. For the extra card I am trying to get working now, its a TRv2 flashed with your NVM50mod. I have the same card and flash working well in a z490 system.

As I have it, the Thunderbolt bus shows up, and attached devices also show up under Thunderbolt devices, but they don't work. I also don't see the card in the PCI system info. So my guess is there is something wrong with the ACPI addresses in my SSDT. When you look at the IOReg, keep in mind there are 2 other non-flashed Thunderbolt controllers. The new, flashed card is the one that shows up under RP01.
 

Attachments

  • Screen Shot 2021-01-20 at 6.15.11 AM.png
    Screen Shot 2021-01-20 at 6.15.11 AM.png
    286.8 KB · Views: 46
  • pcidevices.zip
    11.2 KB · Views: 21
  • EFI-hw16-ttrslot4.zip
    6.4 MB · Views: 28
  • Screen Shot 2021-01-20 at 6.15.16 AM.png
    Screen Shot 2021-01-20 at 6.15.16 AM.png
    309.2 KB · Views: 38
  • X99Desi-Hack Pro-seeRP01.iojones
    3 MB · Views: 22
Last edited by a moderator:
Joined
Jun 1, 2010
Messages
85
Motherboard
Gigabyte Designare Z390
CPU
I9-9900K
Graphics
RX 580
Please do the following:
  • Mount EFI Partition of macOS SSD
  • Go to the OC/ACPI folder
  • Select all SSDTs in that folder using Finder, and select File --> Compress
  • Post the ZIP file
@CaseySJ

Here you go
 

Attachments

  • Archive.zip
    9.5 KB · Views: 22
Joined
Jan 6, 2020
Messages
160
Motherboard
Gigabyte Designare Z390 Thunderbolt 3
CPU
i9-9900K
Graphics
Intel > Need version # > See Rules!
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
I have a problem with my Logiteck keyboard and mouse disconnection using the stick do you have any idea

I'm on Big Sur in 0.6.3

Thank you
 
Top