Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jun 23, 2019
Messages
80
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900K
Graphics
Vega Frontier Edition
This is a forum where feedback should be welcomed, appreciated and acted upon.

Yes of course, it is a forum where people should be able to give feedback. You're right. When I give my feedback, I get opinions on that particular matter too. People seem to be open for it on this thread, which is a good thing. I respect your opinion.

Instead, someone chooses to "ignore the science" to protect and assert one's infallibility, perhaps?

I'm sorry you feel this way. The "science" however, was not applied. I don't believe anything wrong was done. Hence therefore, I responded on the matter. I should not have said anything.

But my main point was to make it clear, that OpenCore is in beta, and a guide-maker is not liable for anyone's bad hackintoshing experience. Especially not for an inactive EFI driver that is not suppose to be used for this particular common system mentioned in this thread.

Yep, I learned the hard way that that particular kext (in clover or opencore, I think) messed with my magic keyboard input, and the reason was that I would accidentally enable it with ProperTree. It might be a good idea to put a small disclaimer about ProperTree or just disabled (but present) kexts in those folders in general, as it is an opportunity to teach users a bit more while avoiding potential frustration.

Having disclaimer is a good thing. I believe disclaimers have generally been used for OpenCore on here before on many occasions. Perhaps it was mentioned so much earlier, that they stopped using disclaimers, thinking that people probably got the message.

I guess if people need disclaimers for not using ProperTree, then that is probably good too.
 
Last edited:
Joined
Jun 23, 2019
Messages
80
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900K
Graphics
Vega Frontier Edition
This wasn't directed at you, and by "science" I meant the OpenCore documentation and my experiential evidence.

Oh alright. Sorry for my misunderstanding. I just thought it was directed towards me, when you mentioned ..

Instead, someone chooses to "ignore the science" to protect and assert one's infallibility, perhaps?

Nvm. Pardon me. :)
 
Joined
Sep 25, 2012
Messages
98
Motherboard
Gigabyte Z390 Designare
CPU
i7 9700K
Graphics
RX 5700 XT
Have you tried doing a CMOS Reset and then configuring BIOS parameters again (starting with F7 -- Load Optimized Defaults)?
I will give that a shot, thank you. Is there a guide on how to configure the BIOS under the new circumstances of Big Sur and OC?

Another thing: It seems like I lost the SATA Hot Swap capability. Can I activate this the same way I did in Catalina?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,096
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I will give that a shot, thank you. Is there a guide on how to configure the BIOS under the new circumstances of Big Sur and OC?
BIOS configuration is the same in Mojave, Catalina and Big Sur. Please see Post #1. However, ensure you have BIOS F9g or newer and also set Boot --> CFG-Lock to Disabled.
Another thing: It seems like I lost the SATA Hot Swap capability. Can I activate this the same way I did in Catalina?
Yes.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,096
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi! After updating latest 11.1 update, is anyone has delaying audio while using Chrome or Safari browser? I'm listening music on Tidal and just using Chrome. It's simple task like open page from new tab and changing tab on browser. I was experiencing delay music sound.
Have you tried other streaming services, including YouTube?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,096
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I find this experience troubling and bizarre, but no hard feelings, purely intellectual. This is a forum where feedback should be welcomed, appreciated and acted upon. Instead, someone chooses to "ignore the science" to protect and assert one's infallibility, perhaps?
Chronology of events:
  • You used ProperTree's OC Snapshot function to build your config.plist, which is a blind operation -- i.e. it provides no transparency into what it's doing.
  • You did not follow the OpenCore 0.6.4 Mini-Guide. @Inqnuam's HackinDROM website simplifies the process of transferring PlatformInfo credentials from one config file into another. You did not use it.
  • Then your system failed. You immediately wanted someone to blame. Re-read your original post.
  • Somehow you determined that one stray EFI driver was the culprit. I'm not sure if you performed A/B comparisons at least two times (i.e. with that EFI driver enabled, then again with it disabled, then again with it enabled) to confirm the suspicion. Anything less would not constitute "science".
  • When we pointed out that your system failure was due to your mistake in using OC Snapshot, we also mentioned that the OpenUsbKbDxe.efi driver was already disabled in the EFI folder we provide.
  • Nevertheless, you went on a vendetta to have the Mini-Guide changed and the EFI driver removed.
  • In all this time, you are the only one to have fallen into this "booby trap".
This post is being written on my Z390 Desginare with OpenCore 0.6.4 and OpenUsbKbDxe.efi enabled. No issues at all with my wireless Logitech keyboard and mouse, whether in BIOS, in OpenCore Picker, or in macOS.

If "science" has determined that OpenUsbKbDxe.efi is deleterious on Z390, then why is my system working normally? Where is the "science" in that?

You may have the last word. But let it be the last.
Screen Shot 2020-12-16 at 4.03.34 AM.pngScreen Shot 2020-12-16 at 4.05.35 AM.png
 
Last edited:
Joined
Jan 1, 2020
Messages
526
Motherboard
Gigabyte Z390 Designare
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Hi @CaseySJ,
about DRM issue on Big Sur (now on 11.1), the only way for me to have Netflix and AppleTV+ working is to switch from iMac19,1 to iMacPro1,1 (with IGPU still enabled by Headless). Opencore is on 0.6.4.

Have you same issue on iMac19,1 ?
 
Top