Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jan 23, 2019
Messages
5
Motherboard
Designare Z390
CPU
i7-9700K
Graphics
AMD RX 580
I did a fresh Big Sur install using your open core method, but decided to do another fresh install with Catalina because of some software not working properly. Super easy and it's working great, thank you for your great guide.

I have one problem, my Syba SD-PEX24055 10gbe LAN card is not working properly now. MacOS has problems booting when the card is connected - usually resulting in a black screen after the loading bar. I had the same problem on Big Sur and thought that was the case so that was one of the reasons why I went back to Catalina. However I had one random successful boot on Big Sur(1 of ca 15 tries) but then the LAN card wasn't working. Do you have any idea what's going on?

I'm running Catalina 10.15.7
Opencore 0.6.3 with your EFI package + SSDT-Designare-Z390-Disable-Slot-2-GPU

Gigabyte Z390 DESIGNARE
Intel Core i7 9700K
Sapphire Pulse Radeon RX 580
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Do we have a good guide or link to dual booting with OpenCore? I’ve managed to get it working (seems relatively simple with separate drives) but am trying to find out how to change the boot option from No Name to Pop!OS.
We have a couple of guides linked in the Z490 Vision D thread:

Screen Shot 2020-11-25 at 6.30.17 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
This thread moves fast! Just bumping this reply in case my reply got buried too quick. Thanks!
Is the playback normal after waking from sleep?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
It is, but still cubase doesn't seem to find it.
The gpu drivers are up to date within windows and of course mojave is at latest build. This doesn't happen on a macbook or in windows
I'm not familiar with Cubase, but does it have an option to explicit choose a GPU when more than one is available? Or does it choose a GPU automatically?

If Cubase is choosing the AMD RX 580, isn't that a good thing?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I did a fresh Big Sur install using your open core method, but decided to do another fresh install with Catalina because of some software not working properly. Super easy and it's working great, thank you for your great guide.

I have one problem, my Syba SD-PEX24055 10gbe LAN card is not working properly now. MacOS has problems booting when the card is connected - usually resulting in a black screen after the loading bar. I had the same problem on Big Sur and thought that was the case so that was one of the reasons why I went back to Catalina. However I had one random successful boot on Big Sur(1 of ca 15 tries) but then the LAN card wasn't working. Do you have any idea what's going on?

I'm running Catalina 10.15.7
Opencore 0.6.3 with your EFI package + SSDT-Designare-Z390-Disable-Slot-2-GPU

Gigabyte Z390 DESIGNARE
Intel Core i7 9700K
Sapphire Pulse Radeon RX 580
Because your card uses the familiar Aquantia AQC107, please try Option 2 in this post, but keep SecureBootModel set to Disabled (not Default):
 
Joined
Jan 8, 2018
Messages
34
Motherboard
Gigabyte Z370N WiFi
CPU
i7-9700K
Graphics
Vega 56
Hi Casey, thanks again for the guide. I had no issues until recently my disk corrupted and I had to do a fresh install (Mojave). After install I replaced the EFI folder with a backup I had from before the corruption. Since then I have had a couple of system freezes after leaving the system on for a while. This never happened before and seems odd considering it's the same EFI. Either way, I went back through your guide and I seem to have a few drivers that you didn't include. I've uploaded screenshots here. I tried getting rid of a few that seemed unnecessary (AptioMemoryFix.efi and OsxAptioFix2Drv-free.efi, etc) according to the guide, but then the system wouldn't boot. I'd like to optimise what I have and also prepare for upgrading to Catalina, so I'd love your suggestions on what to get rid of.

Many thanks
Screenshot 2020-11-25 at 15.50.48.png
 

Attachments

  • Screenshot 2020-11-25 at 15.51.20.png
    Screenshot 2020-11-25 at 15.51.20.png
    216.5 KB · Views: 26

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey, thanks again for the guide. I had no issues until recently my disk corrupted and I had to do a fresh install (Mojave). After install I replaced the EFI folder with a backup I had from before the corruption. Since then I have had a couple of system freezes after leaving the system on for a while. This never happened before and seems odd considering it's the same EFI. Either way, I went back through your guide and I seem to have a few drivers that you didn't include. I've uploaded screenshots here. I tried getting rid of a few that seemed unnecessary (AptioMemoryFix.efi and OsxAptioFix2Drv-free.efi, etc) according to the guide, but then the system wouldn't boot. I'd like to optimise what I have and also prepare for upgrading to Catalina, so I'd love your suggestions on what to get rid of.

Many thanks
Hello @delicious,

If you are using Clover 5xxx (pressing F1 at Clover Boot Menu will give you the version number), then please do the following:
  • Delete the entire drivers64UEFI folder (but not drivers/UEFI).
  • Then delete the following files from inside the drivers/UEFI folder:
    • AptioMemoryFix.efi
    • MemoryAllocation.efi
  • Now try booting.
  • If boot fails due to Couldn't allocate runtime area or End randomseed, please let me know.
 
Joined
Jan 8, 2018
Messages
34
Motherboard
Gigabyte Z370N WiFi
CPU
i7-9700K
Graphics
Vega 56
Hello @delicious,

If you are using Clover 5xxx (pressing F1 at Clover Boot Menu will give you the version number), then please do the following:
  • Delete the entire drivers64UEFI folder (but not drivers/UEFI).
  • Then delete the following files from inside the drivers/UEFIfolder:
    • AptioMemoryFix.efi
    • MemoryAllocation.efi
  • Now try booting.
  • If boot fails due to Couldn't allocate runtime area or End randomseed, please let me know.
Thanks for the quick reply. Yes I'm on Clover 5103. I did as you said and booted successfully - on second warm restart I got stuck with the attached messages, but have done several restarts since then and had no issues. I'll let you know how this goes. For upgrading to Catalina, would you recommend an upgrade or fresh install? I have a spare SSD so I could do a fresh install on that and transfer my settings if that was preferable.
 

Attachments

  • IMG_0314.JPG
    IMG_0314.JPG
    5.3 MB · Views: 31

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks for the quick reply. Yes I'm on Clover 5103. I did as you said and booted successfully - on second warm restart I got stuck with the attached messages, but have done several restarts since then and had no issues. I'll let you know how this goes. For upgrading to Catalina, would you recommend an upgrade or fresh install? I have a spare SSD so I could do a fresh install on that and transfer my settings if that was preferable.
If Mojave was a fresh install, then an in-place upgrade to Catalina would be perfectly okay. But you would need to follow the Mojave-to-Catalina upgrade guide carefully. To unlock MSR 0xE2 (CFG-Lock) it is strongly recommended to install BIOS F9g in which this is already done by default. To find BIOS F9g, open the Quick Reference spoiler at the top of Post 1 and select the 9th bullet in Section 1.
 
Top