Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Feb 11, 2014
Messages
240
Motherboard
Z390 Designare
CPU
i7-9700
Graphics
Radeon Pro WX 9100
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Jules,

Are you following the Clover-to-OpenCore transition guide?
I'll double check. Bios is F9i and CFG-Lock DISABLED (Or it was lol I'll double check) Im booting from USB and having Open Core boot menu then selecting internal M2 drive called "Catalina" Let me go over it again. I'm prone to dumb things like not having an EFI folder in the EFI lol, I sort it out eventually. And man, you are approaching 3000 posts on this thread. You are Epic Man!
 
Joined
Jan 8, 2018
Messages
34
Motherboard
Gigabyte Z370N WiFi
CPU
i7-9700K
Graphics
Vega 56
Edit: FIXED

I have a dual boot of this system with a Windows partition. The Broadcom wifi works fine but on the Windows partition I get about double the speed when doing a speed test, and an even faster speed on my iPhone. Is there something I can change to improve this?
 
Joined
Oct 18, 2011
Messages
67
Motherboard
Gigabyte Z370 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
@CaseySJ - just updated from Clover to OpenCore - again your instructions made it a breeze (and a good learning experience). Still loving this hackintosh after many years (the headroom one feels using it to do video editing, streaming, development is just incredible versus a laptop).

One small recommendation to add the line:
  • You must unlock the MSR 0xE2 register by following the procedure described here.
To the updated OpenCore mini-guide (https://www.tonymacx86.com/threads/...700k-amd-rx-580.267551/page-1165#post-2049168) - just in case people aren't transitioning from older OC to new OC.
 
Joined
Nov 2, 2018
Messages
20
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
Hi guys, I'm having a problem with HEVC decoding. Rebooting seems to enable smooth HEVC playback but I believe login out and back in again breaks it. Running iMac Pro SMBios, iGPU disabled. I have followed the guide here to upgrade from Clover to OC 0.6.3 running Big Sur but had the same problem with Catalina. Specs in side bar are accurate. Any ideas? Thanks!
 
Joined
Nov 20, 2019
Messages
45
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Thanks for pointing this out. I will redact the procedure to mount the root file system with read/write permissions in Big Sur. At this time we must not tamper with Big Sur’s security apparatus.
I've got it working. I had some trial error but its seems fine. The mini guide is updated here

It will be nice if someone else can test & prove if it works for them as well
 
Joined
May 15, 2020
Messages
1,170
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
better option -> linux live cd
HackinDROM will be unavailable during the backup
I tried Clonezilla and it destroyed my Hackintosh EFI partition...
finally copied everything very easily and quickly with linux Gparted tool
but not sure if we can use that to backup our Hackis
maybe we will need to create apfs partition + EFI in macOS then copy our Hacki with Gparted
Capture d’écran 2020-11-21 à 21.15.57.png
 
Joined
Jan 21, 2018
Messages
227
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Does latest BIOS for Z390 AORUS Xtreme contain “CFG-Lock” in the BOOT section of BIOS Setup?
Sorry for my late reply. Could not come back earlier. Just updated to BIOS and I confirm that there is “CFG-Lock” settings in the BIOS Boot section.

I've been looking into the guides you pointed me, and on the second one '** OpenCore 0.6.2 EFI for Designare Z390 **' I see that you attach two files for the Designaire Z390

- Will they work the same way with the Z390 AORUS Xtreme?
- What happens then to the Custom SSDTs for AORUS Xtreme that I have in Clover?
- This guide is for Opencore 0.6.2, should I use Opencore 0.6.3 instead?

Sorry if I'm making any dumb questions. As said before I'm totally new to OpenCore, and still have to read step by step your guides.

Thanks
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Sorry for my late reply. Could not come back earlier. Just updated to BIOS and I confirm that there is “CFG-Lock” settings in the BIOS Boot section.

I've been looking into the guides you pointed me, and on the second one '** OpenCore 0.6.2 EFI for Designare Z390 **' I see that you attach two files for the Designaire Z390

- Will they work the same way with the Z390 AORUS Xtreme?
- What happens then to the Custom SSDTs for AORUS Xtreme that I have in Clover?
- This guide is for Opencore 0.6.2, should I use Opencore 0.6.3 instead?

Sorry if I'm making any dumb questions. As said before I'm totally new to OpenCore, and still have to read step by step your guides.

Thanks
It is best to use OpenCore 0.6.3, but we can easily add the custom AORUS Xtreme SSDTs into the OpenCore OC/ACPI folder and reference them in the config.plist. Using OpenCore Configurator, we can just uncheck the ones that don't apply to the AORUS Xtreme. This is shown below.

Screen Shot 2020-11-21 at 2.58.23 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi guys, I'm having a problem with HEVC decoding. Rebooting seems to enable smooth HEVC playback but I believe login out and back in again breaks it. Running iMac Pro SMBios, iGPU disabled. I have followed the guide here to upgrade from Clover to OC 0.6.3 running Big Sur but had the same problem with Catalina. Specs in side bar are accurate. Any ideas? Thanks!
Which application are you using for HEVC playback?
 
Top