Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,951
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey @CaseySJ, I tried to do a fresh install of big sur using your ** OpenCore 0.6.3 EFI for Designare Z390 ** but after selecting MacOS installer from my USB at the boot screen it just hangs at the Apple Logo and doesn't progress from there. I also tried doing a NVram reset at the OpenCore bootloader by pressing space but still gets stuck.
To do a fresh installation of Big Sur, please follow this guide instead:
Screen Shot 2020-11-17 at 3.59.28 AM.png
 
Joined
Sep 21, 2013
Messages
1,041
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
This thread is amazing :)

I’m a long time lurker, managed to set up a hack somehow last year and been running well so far with some issues.
first thanks to all you wonderful people, everyone doing this to help and learn off each other in these turbulent times. We’ve all we got people.

I build a Catalina clover last year, then jumped ship to OpenCore and now to bleeding edge Big Sur + OpenCore 0.6.3. sadly I had to delete my windows NVMe as it was no longer working.

i was recommend this thread but geez it’s for 2750+ pages. I got a few things to ask

1) will I find most solutions ideas and files on the original post on first page ( it looks heavily updated ) or do I have to go through entire thread ?
2) the first page doesn’t state about 5700XT compatibility with OP. I checked the notes and have a slightly different built ( 9900K + 5700XT + 64GB ). s there a different build you’d recommend ?
3) I want to get back my dual boot Windows + MacOS. What’s the latest update on OpenCore 0.6.3 N-D-K , better to wait for it or get going with the build, is there a fork that’s already 0.6.3 dual boot friendly ?
Start at page 1 and at least work through the build guide. I'd go with OC 0.6.3. There is a lot to know and do: There are often updates, a few spoilers, but no real shortcuts. If I can do it, you can do it. This is a great guide, that's why there are so many pages: People keep coming back to Caseysj's well.

Me, I'm running a dual-boot Mojave/Windows 10 setup that is governed by OC 0.6.3. Windows and most data are on SATA SSDs. Mojave and Sample libraries are on PCIe/M.2 type SSDs. The trick I've learned with Windows 10 (GPT format) is to get the BIOS settings tuned just right, then password lock the BIOS so that Windows can't overwrite it and screw things up. I can pick the OS from the "Open Core boot menu" -I used a combo of the CaseySJ guide and the Dortania guide for the dual boot and other particulars of my system.
 
Joined
Jan 21, 2018
Messages
227
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Hello @ummario,

Good to hear from you again! We can switch from Clover to OpenCore using the guide shown here:

View attachment 496589

The latest version of Clover may work, but I think it is best to switch to OpenCore. In fact, Clover has integrated OpenCore core into itself to create a hybrid. Several Clover releases in the very recent past have had critical bugs that rendered those releases unusable.

Additionally, if everyone switches to OpenCore, it makes it much easier for us to support them in this thread. Otherwise there are too many permutations:
  • Mojave with Clover
  • Mojave with OpenCore
  • Catalina with Clover
  • Catalina with OpenCore
  • Big Sur with Clover
  • Big Sur with OpenCore
Most people who report problems in this thread don't even tell us (a) which OS they're using and (b) which boot loader they're using. It's just too many combinations to support.

So it's best for everyone to adopt OpenCore, because that has become the leading boot loader.
Thank you @CaseySJ . I will take a look into it. Maybe I’ll try that on a secondary disk.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,951
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you @CaseySJ . I will take a look into it. Maybe I’ll try that on a secondary disk.
Does latest BIOS for Z390 AORUS Xtreme contain “CFG-Lock” in the BOOT section of BIOS Setup?
 
Joined
Nov 20, 2019
Messages
45
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
@jiffyslot @CaseySJ Big Thanks ! :headbang:
I've already got opencore 0.6.3 + Big Sur running its the most basic and quickest dortania guided upgrade from Catalina which destroyed my WD NVMe that had windows. Here's how my EFI looks.
Screenshot 2020-11-17 at 12.34.27.png


Everything works but its not optimal. I got like 38 seconds boot time, DarkWake wakes me up every 10/20/30 mins does something with the monitor turned off and sleeps again. Plus my Windows didn't respond to anything after the upgrade so I nuked it for a fresh install.

So now I have
Samsung NVMe -> Big Sur with OC 0.6.3
WD NMVe -> Where I want to install Windows

How can I install Windows keeping OC in charge and primary , but also without having to open up my desktop ?
Once I do this, I'll start updating my EFI to Caseys

p.s. Updated bios to F9i
 
Joined
Jan 6, 2014
Messages
38
Motherboard
Gigabyte Designare Z390 (Thunderbolt 3)
CPU
i9-9900K
Graphics
RX 580
It's best to follow the OpenCore 0.6.3 Mini-Guide and use config-AMD-GPU.plist as the starting point. Rename that to config.plist and enter your Serial Number, System UUID, System Name, MLB (Board Serial Number), and ROM into that file. In other words, don't use your current config.plist -- just back it up.

A link to the OpenCore 0.6.3 Mini-Guide appears in Section 1 of the Quick Reference spoiler at the top of Post 1.
Thanks CaseySJ,
the problem was on Open Core Configurator, for me the good version is 2.15.2.0, the 2.16.0.0 or 2.18.0.0 have created problems with CustomMemory and ForceResolution at reboot.
Now it’s ok! Truly grateful for your help
 
Joined
Nov 22, 2011
Messages
122
Motherboard
z390 Designare
CPU
i9 9900k
Graphics
Radeon 6900xt
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey CaseySJ, can you update the link on "OpenCore Mini-Guide for Designare Z390" to go to 0.6.3? I think that might solve a lot of headaches. I think most long time followers of this page only look at the top and occasionally go through your updates to see if something's new.


Also, now on Big Sur! But I'm wondering whatever happened to RadeonBoost? I remember reading the dev was giving up because it was supposed to be in Big Sur. My experience with it was I saw the performance increase but it introduced graphic render errors "Random White Boxes" in exported video in Premiere when Red Giant effects were used on clips. This was sadly a deal breaker for me and I had to abandon it. It showed a lot of promise to me, sad it wasn't built on.
 
Joined
Nov 22, 2011
Messages
122
Motherboard
z390 Designare
CPU
i9 9900k
Graphics
Radeon 6900xt
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Does latest BIOS for Z390 AORUS Xtreme contain “CFG-Lock” in the BOOT section of BIOS Setup?
Yes, I saw that! and when you unlock through grub it changes to disable.
 
Joined
Jun 21, 2019
Messages
14
Motherboard
Gigabyte Z390 Designare
CPU
Intel i9-9900k
Graphics
AMD Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It looks like Big Sur breaks LG UltraFine 5k support. I had it working well with my Z390 Aorus Pro and Titan Ridge 1.0 card with Elias23 firmware but on Big Sur the monitor doesn't turn on when I boot or restart. Has anyone else gotten their setup to work with Big Sur?
My LG Ultrafine 5k is currently working fine on Big Sur except it's running at 4k (it was running true 5k on Catalina).

Note that I'm using a GC-Titan Ridge PCIe card as a 2xDP to TB3 converter, it's the only way I managed to get 5k to work with the Ultrafine since it needs 2 DP stream and the onboard Alpine Ridge of the Z390 Designare is not capable of converting 2 DP stream from the dGPU (since it's also hardwired to the iGPU).

Edit: My LG Ultrafine 5k is now running at 5k on Big Sur. The problem wasn't related to Big Sur at all but to my migration from Clover to OpenCore, I was missing some boot argument.
 
Last edited:
Top